Bug 11215 - INFO: possible recursive locking detected ps2_command
INFO: possible recursive locking detected ps2_command
Status: RESOLVED OBSOLETE
Product: Drivers
Classification: Unclassified
Component: Input Devices
All Linux
: P1 normal
Assigned To: drivers_input-devices
:
: 11662 15371 34922 (view as bug list)
Depends on:
Blocks: Regressions-2.6.26
  Show dependency treegraph
 
Reported: 2008-08-01 13:48 UTC by Rafael J. Wysocki
Modified: 2013-12-19 15:04 UTC (History)
11 users (show)

See Also:
Kernel Version: 2.6.39-rc7
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-08-01 13:48:01 UTC
Subject    : INFO: possible recursive locking detected ps2_command
Submitter  : "Zdenek Kabelac" <zdenek.kabelac@gmail.com>
Date       : 2008-07-31 9:41
References : http://marc.info/?l=linux-kernel&m=121749737011637&w=4

This entry is being used for tracking a regression from 2.6.26.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Andrew Morton 2008-08-01 14:00:28 UTC
Methinks this should be assigned to Dmitry, not Russell.
Comment 2 Dmitry Torokhov 2008-08-01 14:12:49 UTC
Actually Peter... I don't know why lockdep annotation only works first time around.
Comment 3 Rafael J. Wysocki 2008-08-07 15:26:11 UTC
Handled-By : Dmitry Torokhov <dmitry.torokhov@gmail.com>
Comment 4 Dmitry Torokhov 2008-08-07 17:31:57 UTC
No, it is not handled by me. As far as I know locking in serio and psmouse is correct and I do not know lockdep well enough to tell why the annotation on pass-through port works only once.
Comment 5 Rafael J. Wysocki 2008-08-08 03:46:15 UTC
Not-Handled-By : Dmitry Torokhov <dmitry.torokhov@gmail.com>
Comment 6 Rafael J. Wysocki 2008-08-08 13:49:30 UTC
Handled-By : Peter Zijlstra <a.p.zijlstra@chello.nl>
Comment 7 Zdenek Kabelac 2008-08-12 02:13:08 UTC
Just an update as a response to automatically generated request message from Rafael - this trace is still displayed when PS2 mouse is reattached to my docking station.

Tested with todays kernel commit: 10fec20ef5eec1c91913baec1225400f0d02df40
Comment 8 Zdenek Kabelac 2008-08-27 02:58:36 UTC
Warning message still present with commit: (Tue Aug 26 10:45:20 2008)
1941246dd98089dd637f44d3bd4f6cc1c61aa9e4
Comment 9 Zdenek Kabelac 2008-11-05 05:18:41 UTC
Obviously no one has made any updates in lockdep checker neither in ps2 driver - so I still get the same INFO call while using 2.6.28-rc3 kernel
Comment 10 Rafael J. Wysocki 2008-11-09 13:23:58 UTC
Not-Handled-By : Peter Zijlstra <a.p.zijlstra@chello.nl>
Comment 11 Zdenek Kabelac 2008-12-13 16:34:47 UTC
This INFO trace is still present in 2.6.28-rc8 - someone should probably check if the nesting of this lock is properly marked in the source, so the lockdep validator could be quiet.
Comment 12 Dmitry Torokhov 2009-09-05 03:56:01 UTC
*** Bug 11662 has been marked as a duplicate of this bug. ***
Comment 13 Dmitry Torokhov 2010-02-22 22:10:03 UTC
*** Bug 15371 has been marked as a duplicate of this bug. ***
Comment 14 Florian Mickler 2010-08-16 13:18:57 UTC
Hum... I _guess_ this is still present. 
Nobody here wanna show off a little lockdep-fu?
Comment 15 Witold Baryluk 2011-08-28 21:53:20 UTC
Hey. I reported similar report few months ago. See bug #34922 . It happened when resuming my ThinkPad T43. I was not using any docking station, and was just using internal tracpoint and/or touchpad. So it is essentially impossible it was disconected physically. It can still be possible there were some power fluctutations and trackpoint chipset performed reset, and this triggered this problem. It can be also purly software problem in kernel.
Comment 16 Alan 2012-05-22 13:08:31 UTC
*** Bug 34922 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.