Bug 11204 - Commit 76a2a6ee8a0660a29127f05989ac59ae1ce865fa breaks PXA270 (at least)?
Summary: Commit 76a2a6ee8a0660a29127f05989ac59ae1ce865fa breaks PXA270 (at least)?
Status: CLOSED CODE_FIX
Alias: None
Product: Process Management
Classification: Unclassified
Component: Scheduler (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Ingo Molnar
URL:
Keywords:
Depends on:
Blocks: Regressions-2.6.26
  Show dependency tree
 
Reported: 2008-07-31 14:11 UTC by Rafael J. Wysocki
Modified: 2008-08-12 11:06 UTC (History)
3 users (show)

See Also:
Kernel Version: Commit 76a2a6ee8a0660a29127f05989ac59ae1ce865fa
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-07-31 14:11:57 UTC
Subject    : Fwd: Commit 76a2a6ee8a0660a29127f05989ac59ae1ce865fa breaks PXA270 (at least)?
Submitter  : Russell King - ARM Linux <linux@arm.linux.org.uk>
Date       : 2008-07-29 22:31
References : http://marc.info/?l=linux-kernel&m=121737075314966&w=4
Handled-By : Peter Zijlstra <a.p.zijlstra@chello.nl>

This entry is being used for tracking a regression from 2.6.26.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-07-31 14:12:32 UTC
Caused by:

commit 76a2a6ee8a0660a29127f05989ac59ae1ce865fa
Author: Peter Zijlstra <a.p.zijlstra@chello.nl>
Date:   Fri Jun 27 13:41:15 2008 +0200

    sched: sched_clock_cpu() based cpu_clock()
Comment 2 Rafael J. Wysocki 2008-08-01 13:14:52 UTC
Patch : http://marc.info/?l=linux-kernel&m=121754090926333&w=4
Comment 3 Rafael J. Wysocki 2008-08-10 05:39:55 UTC
On Sunday, 10 of August 2008, Russell King wrote:
> On Sun, Aug 10, 2008 at 12:43:50AM +0200, Rafael J. Wysocki wrote:
> > The following bug entry is on the current list of known regressions
> > from 2.6.26.  Please verify if it still should be listed and let me know
> > (either way).
> 
> Well, in theory we're waiting for Bill Gatliff to do some testing
> last Monday/Tuesday of the proposed fix.
> 
> > Bug-Entry   : http://bugzilla.kernel.org/show_bug.cgi?id=11204
> > Subject             : Commit 76a2a6ee8a0660a29127f05989ac59ae1ce865fa
> breaks PXA270 (at least)?
> > Submitter   : Russell King - ARM Linux <linux@arm.linux.org.uk>
> > Date                : 2008-07-29 22:31 (12 days old)
> > References  : http://marc.info/?l=linux-kernel&m=121737075314966&w=4
> > Handled-By  : Peter Zijlstra <a.p.zijlstra@chello.nl>
> > Patch               :
> http://marc.info/?l=linux-kernel&m=121754090926333&w=4
Comment 4 Adrian Bunk 2008-08-12 11:06:34 UTC
fixed by commit c1955a3d4762e7a9bf84035eb3c4886a900f0d15

Note You need to log in before you can comment on or make changes to this bug.