Bug 112011 - Bug in net/sched/sch_hfsc.c
Summary: Bug in net/sched/sch_hfsc.c
Status: RESOLVED DUPLICATE of bug 109581
Alias: None
Product: Networking
Classification: Unclassified
Component: Other (show other bugs)
Hardware: x86-64 Linux
: P1 blocking
Assignee: Stephen Hemminger
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-05 23:04 UTC by Sebastian Kricner
Modified: 2016-02-07 21:10 UTC (History)
0 users

See Also:
Kernel Version: 4.1.15-gentoo-r1
Tree: Mainline
Regression: No


Attachments

Description Sebastian Kricner 2016-02-05 23:04:11 UTC
[ 2358.039213] ------------[ cut here ]------------
[ 2358.039221] WARNING: CPU: 3 PID: 19 at net/sched/sch_hfsc.c:1429 hfsc_dequeue+0x330/0x350()
[ 2358.039227] CPU: 3 PID: 19 Comm: ksoftirqd/3 Tainted: G        W       4.1.15-gentoo-r1 #1
[ 2358.039230] Hardware name: To Be Filled By O.E.M. To Be Filled By O.E.M./AD2550B-ITX, BIOS P1.20 11/14/2012
[ 2358.039234]  0000000000000000 ffffffff819ac03f ffffffff8168a197 0000000000000000
[ 2358.039241]  ffffffff81051914 ffff880079fed600 000000089233f6a1 ffff88007b054000
[ 2358.039261]  ffff88007b054490 0000000000000104 ffffffff815343e0 ffff880079fed600
[ 2358.039262] Call Trace:
[ 2358.039269]  [<ffffffff8168a197>] ? dump_stack+0x40/0x50
[ 2358.039275]  [<ffffffff81051914>] ? warn_slowpath_common+0x74/0xb0
[ 2358.039282]  [<ffffffff815343e0>] ? hfsc_dequeue+0x330/0x350
[ 2358.039288]  [<ffffffff815243a7>] ? __qdisc_run+0x47/0x1d0
[ 2358.039294]  [<ffffffff81500523>] ? net_tx_action+0xd3/0x170
[ 2358.039300]  [<ffffffff810542db>] ? __do_softirq+0xeb/0x1e0
[ 2358.039306]  [<ffffffff810543ea>] ? run_ksoftirqd+0x1a/0x40
[ 2358.039310]  [<ffffffff8106b6b7>] ? smpboot_thread_fn+0x117/0x180
[ 2358.039315]  [<ffffffff8106b5a0>] ? sort_range+0x20/0x20
[ 2358.039319]  [<ffffffff81068a0e>] ? kthread+0xbe/0xe0
[ 2358.039324]  [<ffffffff81068950>] ? __kthread_parkme+0x70/0x70
[ 2358.039328]  [<ffffffff8168fd82>] ? ret_from_fork+0x42/0x70
[ 2358.039332]  [<ffffffff81068950>] ? __kthread_parkme+0x70/0x70
[ 2358.039335] ---[ end trace 3bf95ea71027d327 ]---

Fills up.

Sebastian Kricner
Comment 1 Sebastian Kricner 2016-02-05 23:07:58 UTC
Also causes problems with IPSec.

INFO: begin Base mode.
ERROR: sendmsg (Permission denied)
ERROR: sendfromto failed
ERROR: phase1 negotiation failed due to send error. a680d720548618fe:0000000000000000
ERROR: failed to begin ipsec sa negotication.

Using racoon.
Comment 2 Sebastian Kricner 2016-02-05 23:08:48 UTC
Kernel 4.0.9 works.
Comment 3 Sebastian Kricner 2016-02-05 23:48:50 UTC
IPSec error is local, had to turn off firewall rules and it does not allow IPSec then.
Comment 4 Stephen Hemminger 2016-02-07 21:10:28 UTC

*** This bug has been marked as a duplicate of bug 109581 ***

Note You need to log in before you can comment on or make changes to this bug.