Bug 11190 - [USB boot crash, -git] ecm_do_notify(), list_add corruption. prev->next should be next (ffff88003b8f82f8)
Summary: [USB boot crash, -git] ecm_do_notify(), list_add corruption. prev->next shoul...
Status: CLOSED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: USB (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: David Brownell
URL:
Keywords:
Depends on:
Blocks: Regressions-2.6.26
  Show dependency tree
 
Reported: 2008-07-31 05:35 UTC by Rafael J. Wysocki
Modified: 2008-08-14 01:04 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.26-tip-06162-g2ef4b1e-dirty
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-07-31 05:35:27 UTC
Subject    : [USB boot crash, -git] ecm_do_notify(), list_add corruption. prev->next should be next (ffff88003b8f82f8)
Submitter  : Ingo Molnar <mingo@elte.hu>
Date       : 2008-07-22 13:40
References : http://marc.info/?l=linux-usb&m=121673409124827&w=4
Handled-By : Alan Stern <stern@rowland.harvard.edu>
Handled-By : David Brownell <david-b@pacbell.net>
Patch      : http://marc.info/?l=linux-kernel&m=121708481823201&w=4

This entry is being used for tracking a regression from 2.6.26.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 David Brownell 2008-07-31 13:13:04 UTC
fix submitted as:
http://marc.info/?l=linux-usb&m=121736205900735&w=2
Comment 2 Rafael J. Wysocki 2008-07-31 13:31:28 UTC
Please close the bug when the fix appears in the mainline.
Comment 3 Adrian Bunk 2008-08-14 01:04:55 UTC
fixed by commit c728df70ab0dd59b8ccdc3c611ea88925e6697db

Note You need to log in before you can comment on or make changes to this bug.