Bug 11189 - sky2 WOL broken
sky2 WOL broken
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Network
All Linux
: P1 normal
Assigned To: Stephen Hemminger
:
: 11181 (view as bug list)
Depends on:
Blocks: Regressions-2.6.26
  Show dependency treegraph
 
Reported: 2008-07-31 05:28 UTC by Rafael J. Wysocki
Modified: 2008-08-20 12:06 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.27-rc1
Tree: Mainline
Regression: Yes


Attachments
Fix patch (for the record) (5.32 KB, patch)
2008-08-05 05:34 UTC, Rafael J. Wysocki
Details | Diff
Patch fixing the issue for me (1.47 KB, patch)
2008-08-09 12:39 UTC, Rafael J. Wysocki
Details | Diff
Smaller patch that fixes the issue for me (646 bytes, patch)
2008-08-09 13:38 UTC, Rafael J. Wysocki
Details | Diff

Description Rafael J. Wysocki 2008-07-31 05:28:47 UTC
Subject    : Re: linux-next: Tree for July 18: sky2 WOL broken
Submitter  : "Rafael J. Wysocki" <rjw@sisk.pl>
Date       : 2008-07-20 0:20:10
References : http://marc.info/?l=linux-next&m=121651311115104&w=4
Handled-By : Stephen Hemminger <shemminger@vyatta.com>
Patch      : http://marc.info/?l=linux-netdev&m=121694346401281&w=4

This entry is being used for tracking a regression from 2.6.26.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Stephen Hemminger 2008-08-04 21:55:31 UTC
Fix has been sent
Comment 2 Stephen Hemminger 2008-08-04 21:56:21 UTC
*** Bug 11181 has been marked as a duplicate of this bug. ***
Comment 3 Rafael J. Wysocki 2008-08-05 05:29:47 UTC
Ignore-Patch : http://marc.info/?l=linux-netdev&m=121694346401281&w=4
Comment 4 Rafael J. Wysocki 2008-08-05 05:34:44 UTC
Created attachment 17090 [details]
Fix patch (for the record)
Comment 5 Rafael J. Wysocki 2008-08-05 05:35:10 UTC
Patch : http://bugzilla.kernel.org/attachment.cgi?id=17090&action=view
Comment 7 Rafael J. Wysocki 2008-08-09 12:37:28 UTC
Unfortunately, I have to reopen the bug, because my testing of 2.6.27-rc2-git4 containing the commit above shows that the issue described in the original e-mail thread is still present.

Namely, after running 'ethtool -s eth0 wol g' the box hangs solid during
- suspend to RAM
- hibernation
- power off
as soon as either sky2_suspend() or sky2_shutdown() is called.
Comment 8 Rafael J. Wysocki 2008-08-09 12:39:39 UTC
Created attachment 17157 [details]
Patch fixing the issue for me

Although this patch fixes the issue for me, I'm not sure if it's generally acceptable.

I'll try to narrow down the problem further.
Comment 9 Rafael J. Wysocki 2008-08-09 13:38:29 UTC
Created attachment 17158 [details]
Smaller patch that fixes the issue for me

Well, this seems to be more acceptable. :-)
Comment 10 Rafael J. Wysocki 2008-08-09 15:50:23 UTC
Handled-By : Rafael J. Wysocki <rjw@sisk.pl>
Patch : http://marc.info/?l=linux-netdev&m=121831747612598&w=2
Comment 11 Rafael J. Wysocki 2008-08-09 15:59:16 UTC
Ignore-Patch : http://bugzilla.kernel.org/attachment.cgi?id=17090&action=view
Comment 13 Mircea Gherzan 2008-08-14 13:20:03 UTC
The -rc3 fix solves the shutdown issue for me with WOL disabled. But with "wol g", the system hangs at shutdown with a WARNING at smp_function_call_single().
Comment 14 Rafael J. Wysocki 2008-08-14 13:27:58 UTC
The fix from Comment #12 hasn't been merged yet.

Note You need to log in before you can comment on or make changes to this bug.