Bug 11182 - commit a352def21a642133758b868c71bee12ab34ad5c5 broke pptp
commit a352def21a642133758b868c71bee12ab34ad5c5 broke pptp
Status: CLOSED CODE_FIX
Product: Networking
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: Arnaldo Carvalho de Melo
:
Depends on:
Blocks: Regressions-2.6.26
  Show dependency treegraph
 
Reported: 2008-07-30 14:03 UTC by Rafael J. Wysocki
Modified: 2008-08-01 14:06 UTC (History)
2 users (show)

See Also:
Kernel Version: commit a352def21a642133758b868c71bee12ab34ad5c5
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-07-30 14:03:35 UTC
Subject    : commit a352def21a642133758b868c71bee12ab34ad5c5 broke pptp.
Submitter  : "Alexey Zaytsev" <alexey.zaytsev@gmail.com>
Date       : 2008-07-23 18:11
References : http://marc.info/?l=linux-kernel&m=121683672229516&w=4
Handled-By : "Alexey Zaytsev" <alexey.zaytsev@gmail.com>
Patch      : http://marc.info/?l=linux-kernel&m=121744891810034&w=4

This entry is being used for tracking a regression from 2.6.26.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-07-30 14:09:37 UTC
Reportedly caused by:

commit a352def21a642133758b868c71bee12ab34ad5c5
Author: Alan Cox <alan@redhat.com>
Date:   Wed Jul 16 21:53:12 2008 +0100

    tty: Ldisc revamp

    Signed-off-by: Alan Cox <alan@redhat.com>
    Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
Comment 2 Alan 2008-07-30 15:55:36 UTC
modprobe the ppp line discipline and verify that it then works, if so then the patch is pending, small and embarrassingly stupid
Comment 3 Rafael J. Wysocki 2008-07-31 04:41:23 UTC
Handled-By : Alan Cox <alan@lxorguk.ukuu.org.uk>
Comment 4 Adrian Bunk 2008-08-01 14:06:30 UTC
fixed by commit 3ab36ab68531ad90648fdeedcaf437f121572ede

Note You need to log in before you can comment on or make changes to this bug.