Bug 11181 - power-off broken
power-off broken
Status: CLOSED DUPLICATE of bug 11189
Product: Drivers
Classification: Unclassified
Component: Network
All Linux
: P1 normal
Assigned To: Jeff Garzik
:
Depends on:
Blocks: Regressions-2.6.26 56331
  Show dependency treegraph
 
Reported: 2008-07-30 13:57 UTC by Mircea Gherzan
Modified: 2013-04-09 06:23 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.27-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Mircea Gherzan 2008-07-30 13:57:58 UTC
Latest working kernel version: 2.6.26
Earliest failing kernel version: 2.6.27-rc1
Distribution: Debian Sid
Hardware Environment: Fujitsu Siemens Lifebook E8110, Intel T2400
Software Environment: Gnome 2.22
Problem Description: the notebook does not shutdown anymore, hanging after "acpi_power_off called"

Steps to reproduce: `sudo poweroff` or the Gnome equivalent
Comment 1 Zhang Rui 2008-07-30 19:51:02 UTC
as it works well in 2.6.26,
can you run git bisect to see which commit introduces this regression please?
Comment 2 Mircea Gherzan 2008-08-01 13:23:06 UTC
Here it is:

a068c0adf2fe28b324bca87f85d27af7f993cdaf is first bad commit
commit a068c0adf2fe28b324bca87f85d27af7f993cdaf
Author: Stephen Hemminger <shemminger@vyatta.com>
Date:   Wed May 14 17:04:17 2008 -0700

    sky2: pci power savings
    
    Turn on special bits to save more power when device is shutdown.
    Tested on a limited range of hardware, some of the bits are for
hardware that probably isn't even in production (like Yukon Supreme)
and was ported from the vendor driver.
    
    Signed-off-by: Stephen Hemminger <shemminger@vyatta.com>
    Signed-off-by: Jeff Garzik <jgarzik@redhat.com>

----------- Relevant lspci -v section : -------------

Ethernet controller: Marvell Technology Group Ltd. 88E8055
PCI-E Gigabit Ethernet Controller (rev 12) 
Subsystem: Fujitsu Limited. Device 139a 
Flags: bus master, fast devsel, latency 0, IRQ 220 
Memory at f0000000 (64-bit, non-prefetchable) [size=16K] 
I/O ports at 2000 [size=256]
[virtual] Expansion ROM at 78000000 [disabled] [size=128K]
Capabilities: [48] Power Management version 3
Capabilities: [50] Vital Product Data <?>
Capabilities: [5c] Message Signalled Interrupts: Mask- 64bit+
	Queue=0/0 
Enable+ Capabilities: [e0] Express Legacy Endpoint,MSI 00 
Capabilities: [100] Advanced Error Reporting <?>
Kernel driver in use: sky2
Kernel modules: sky2


Comment 3 Rafael J. Wysocki 2008-08-03 05:11:51 UTC
On Sunday, 3 of August 2008, Mircea Gherzan wrote:
> Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.26.  Please verify if it still should be listed
> > and let me know (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=11181
> > Subject		: power-off broken
> > Submitter	: Mircea Gherzan <mgherzan@anaconda.cs.pub.ro>
> > Date		: 2008-07-30 13:57 (4 days old)
> 
> Yes, it should be listed.

Comment 4 Zhang Rui 2008-08-03 18:40:48 UTC
Re-assign to Stephen
Comment 5 Stephen Hemminger 2008-08-04 21:56:21 UTC

*** This bug has been marked as a duplicate of bug 11189 ***

Note You need to log in before you can comment on or make changes to this bug.