Bug 11169 - No sound after resume
No sound after resume
Status: CLOSED OBSOLETE
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA)
All Linux
: P1 normal
Assigned To: Jaroslav Kysela
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2008-07-27 03:41 UTC by Eugenia Loli-Queru
Modified: 2012-05-22 13:04 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.24-19 ubuntu
Tree: Mainline
Regression: Yes


Attachments

Description Eugenia Loli-Queru 2008-07-27 03:41:00 UTC
Latest working kernel version: 2.6.20
Earliest failing kernel version: 2.6.24+ (whatever comes with ubuntu 8.04+updates)
Distribution: Ubuntu 8.04 + official occasional updates
Hardware Environment: IBM Thinkpad T23
Software Environment: X11/Gnome/PowerManager
Problem Description:

**Please re-assign to the right component, I couldn't find where to file this bug as there seems to be no "alsa" component on this bugzilla.**

So, I have an IBM Thinkpad T23 and it works 100% with Ubuntu, except one
thing: the sound doesn't work after you resume from sleep (it works beforehand). However, if you play with the master or PCM volume controls (even if you just move the sliders by 2 pixels), the sound comes back! During that time, the sliders are not, neither are shown as muted. After filing a bug report at Ubuntu, the original idea was that PulseAudio was messing up, but its developer told me via email that it's possibly a Gnome Power Manager bug. I filed a bug with Gnome's power manager guy and he said ( http://bugzilla.gnome.org/show_bug.cgi?id=543652 ) that the bug is the ALSA-kernel's module. So here I am. So far, I am been bounced like a ball trying to get this fixed. The bug appears to only happen with some older Thinkpads.

Bug report with more info here (although some of the info there might be pretty confusing as some users there don't know what they are talking about or they are mixing different problems with this):
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/202089

Steps to reproduce: Put the Thinkpad to sleep while logged in on gnome, wake it up, no sound.
Comment 1 Rafael J. Wysocki 2011-01-16 21:53:06 UTC
Please try 2.6.37 and report back.

Note You need to log in before you can comment on or make changes to this bug.