Bug 11124 - less power consumption after suspend to ram (HP Laptops)
Summary: less power consumption after suspend to ram (HP Laptops)
Status: CLOSED DUPLICATE of bug 11122
Alias: None
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: power-management_other
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-19 11:04 UTC by Daniel Würfel
Modified: 2009-04-02 05:01 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.25 (2.6.25-gentoo-r6)
Tree: Mainline
Regression: No


Attachments

Description Daniel Würfel 2008-07-19 11:04:39 UTC
Latest working kernel version:2.6.25 (2.6.25-gentoo-r6)
Earliest failing kernel version:2.6.23
Distribution:gentoo
Hardware Environment:HP 6715b (AMD Turion(tm) 64 X2 TL-58, ATI X1250)
Software Environment:2.6.25-gentoo-r6, gnome 2.20, ATI 8.50.3
Problem Description: The 6715b i use consumes 18 W power in idle with lowest display backlight. After suspend-to-ram it consumes only 14-15 W.
I checked the module list (lsmod), the available of both cpu cores, the files in /proc and /sys before and after s2r, but i can't find differences.
The low power usage is real, because powertop shows it, a power analyzer i plugged between laptop and power socket shows it, the cpu fan doesn't turn on so frequently and the laptop runs 0,75 hour longer, if i initialize a s2r after i plugged in a full battery.
The problem is not the low power consumption after s2r, it is the high power consumption after a reboot or suspend-to-disk. 
The problem could be the HP BIOS (version F.07) or the apic interpretion of the kernel, but there is no newer bios available for the 6715b.
Yes, the messages 

APIC error on CPU0: 40(40)
APIC error on CPU1: 40(40)

i can see very often in the log (after s2r too), without any problems.
With boot parameter "noapic" and "nolapic" after a boot the power consumption fall to 14-15 W too, but then only one CPU Core is working (after s2r really both cpu cores are working)    
I use the kernel native suspend-to-ram and suspend-to-disk procedure, which are available since 2.6.23.

Another guy i met in a forum said, he have the same problem with a HP 2510p running Ubuntu. This laptop have a complete other hardware then the 6715b.

Steps to reproduce:
1. boot linux on a 6715b -> high power
2. initialize s2r
3. resume from s2r -> low power usage
4. initialize s2d and resume -> high power usage
Comment 1 Andrew Morton 2008-07-19 11:28:29 UTC
This is a dupe of #11122

*** This bug has been marked as a duplicate of bug 11122 ***
Comment 2 Daniel Würfel 2008-07-20 01:48:36 UTC
(In reply to comment #0)
> Latest working kernel version:2.6.25 (2.6.25-gentoo-r6)
> Earliest failing kernel version:2.6.23
> Distribution:gentoo
> Hardware Environment:HP 6715b (AMD Turion(tm) 64 X2 TL-58, ATI X1250)
> Software Environment:2.6.25-gentoo-r6, gnome 2.20, ATI 8.50.3
> Problem Description: The 6715b i use consumes 18 W power in idle with lowest
> display backlight. After suspend-to-ram it consumes only 14-15 W.
> I checked the module list (lsmod), the available of both cpu cores, the files
> in /proc and /sys before and after s2r, but i can't find differences.
> The low power usage is real, because powertop shows it, a power analyzer i
> plugged between laptop and power socket shows it, the cpu fan doesn't turn on
> so frequently and the laptop runs 0,75 hour longer, if i initialize a s2r
> after
> i plugged in a full battery.
> The problem is not the low power consumption after s2r, it is the high power
> consumption after a reboot or suspend-to-disk. 
> The problem could be the HP BIOS (version F.07) or the apic interpretion of
> the
> kernel, but there is no newer bios available for the 6715b.
> Yes, the messages 
> 
> APIC error on CPU0: 40(40)
> APIC error on CPU1: 40(40)
> 
> i can see very often in the log (after s2r too), without any problems.
> With boot parameter "noapic" and "nolapic" after a boot the power consumption
> fall to 14-15 W too, but then only one CPU Core is working (after s2r really
> both cpu cores are working)    
> I use the kernel native suspend-to-ram and suspend-to-disk procedure, which
> are
> available since 2.6.23.
> 
> Another guy i met in a forum said, he have the same problem with a HP 2510p
> running Ubuntu. This laptop have a complete other hardware then the 6715b.
> 
> Steps to reproduce:
> 1. boot linux on a 6715b -> high power
> 2. initialize s2r
> 3. resume from s2r -> low power usage
> 4. initialize s2d and resume -> high power usage
> 

Hi,

i was making a silly mistake filling out the bug report for bug 11122 (now 11124): 
"Latest working kernel version" is not the kernel 2.6.25. The problem, i have discribed, you can find in this kernel(2.6.25) too.
I apologize for this mistake.

kind regards

Daniel
Comment 3 Adrian Bunk 2008-07-21 12:36:00 UTC

*** This bug has been marked as a duplicate of bug 11122 ***

Note You need to log in before you can comment on or make changes to this bug.