Bug 11119 - PATCH from usb-rndis-lite: merge support for tethering with Windows Mobile 6 devices
Summary: PATCH from usb-rndis-lite: merge support for tethering with Windows Mobile 6 ...
Status: RESOLVED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: USB (show other bugs)
Hardware: All Linux
: P1 enhancement
Assignee: Greg Kroah-Hartman
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-18 12:29 UTC by Adam Williamson
Modified: 2009-09-24 07:27 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.27
Tree: Mainline
Regression: No


Attachments
Patch to allow tethering using Windows Mobile 6 devices (1.73 KB, patch)
2008-07-18 12:31 UTC, Adam Williamson
Details | Diff

Description Adam Williamson 2008-07-18 12:29:40 UTC
Latest working kernel version: N/A
Earliest failing kernel version: N/A
Distribution: Generic
Hardware Environment: Windows Mobile 6+ devices
Software Environment: N/A
Problem Description:

As is probably well-known, the SynCE developers have a separate tree - usb-rndis-lite - for the kernel modules relevant to Windows Mobile devices (rndis_host , usbnet , cdc_ether). Lately bits of the SynCE tree are being merged upstream, which is great (kernel.org modules can sync with WM5 and WM6 devices now). I'd like to suggest another bit that should be merged - tethering support. With these small changes, Windows Mobile 6 devices can be used as modems. This is confirmed to work - see for example http://forum.eeeuser.com/viewtopic.php?id=36316 . The changes are quite small and should be safe. I will attach the patch - it's just the difference between revisions 2997 and 2998 in usb-rndis-lite in SynCE's SVN. The work was done by John Carr (john carr unrouted co uk), who blessed me to submit it for upstream inclusion (he intended to but is too busy).
Comment 1 Adam Williamson 2008-07-18 12:31:45 UTC
Created attachment 16879 [details]
Patch to allow tethering using Windows Mobile 6 devices

Author: John Carr
Comment 2 Greg Kroah-Hartman 2008-07-18 12:45:41 UTC
On Fri, Jul 18, 2008 at 12:31:45PM -0700, bugme-daemon@bugzilla.kernel.org wrote:
> Created an attachment (id=16879)
>  --> (http://bugzilla.kernel.org/attachment.cgi?id=16879&action=view)
> Patch to allow tethering using Windows Mobile 6 devices

Please submit kernel patches through email, as
Documentation/SubmittingPatches describes.

thanks,

greg k-h
Comment 3 Adam Williamson 2008-07-18 12:48:03 UTC
ah, sorry, wasn't aware of that. Will do. Should I close the bug?
Comment 4 Greg Kroah-Hartman 2008-07-18 13:17:21 UTC
I can do that :)
Comment 5 Adam Williamson 2009-09-24 07:27:01 UTC
for the benefit of rob townley who just added himself to CC: this stuff was merged upstream quite a while ago.

Note You need to log in before you can comment on or make changes to this bug.