Bug 110481 - console(4) is out of date
Summary: console(4) is out of date
Status: RESOLVED CODE_FIX
Alias: None
Product: Documentation
Classification: Unclassified
Component: man-pages (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: documentation_man-pages@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-01-07 08:31 UTC by Marko Myllynen
Modified: 2016-03-15 08:41 UTC (History)
2 users (show)

See Also:
Kernel Version:
Tree: Mainline
Regression: No


Attachments

Description Marko Myllynen 2016-01-07 08:31:34 UTC
http://man7.org/linux/man-pages/man4/console.4.html should be updated to match modern distributions, currently it talks about inittab and MAKEDEV.
Comment 1 Peter Hurley 2016-01-07 22:27:40 UTC
Or remove it altogether, and let the distros maintain their own console(4) page that reflects the actual setup.

FWIW, Debian and derivatives don't install this page and Fedora is stripped down to near meaninglessness.
Comment 2 Michael Kerrisk 2016-03-15 00:50:17 UTC
So, I'm not averse to deleting this page. It has seen no substantial updates since it was first written in 1994. Marko, what are your thoughts?

Cheers,

Michael
Comment 3 Marko Myllynen 2016-03-15 07:11:27 UTC
Yeah, might be probably best just to drop the page, otherwise it would need to be entirely rewritten, in current form it doesn't offer anything helpful or even correct information. Thanks.
Comment 4 Michael Kerrisk 2016-03-15 08:41:26 UTC
Okay, I've deleted this page. Change will appear in man-pages-4.06.

Note You need to log in before you can comment on or make changes to this bug.