Bug 110331 - Lenovo Yoga 900 trackpad and touchscreen doesn't work
Summary: Lenovo Yoga 900 trackpad and touchscreen doesn't work
Status: RESOLVED DUPLICATE of bug 108581
Alias: None
Product: Drivers
Classification: Unclassified
Component: I2C (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Drivers/I2C virtual user
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-01-04 18:13 UTC by Allan Bogh
Modified: 2016-01-20 23:47 UTC (History)
1 user (show)

See Also:
Kernel Version: 4.4-rc7
Tree: Mainline
Regression: No


Attachments

Description Allan Bogh 2016-01-04 18:13:42 UTC
The Lenovo Yoga 900 trackpad and touchscreen do not work with the default kernel. I've upgraded to 4.4-rc7 to get the latest changes, but this version still doesn't have the correct drivers.

A workaround has been created, which requires a custom kernel compilation. It would be nice if the hardware works with the default kernel though.

Here is the initial fix that lead to a workaround.

http://www.spinics.net/lists/linux-i2c/msg22055.html

Here is an article I created to help others using Ubuntu.

https://allanbogh.com/2015/12/23/installing-ubuntu-16-04-daily-on-a-lenovo-yoga-900/
Comment 1 Wolfram Sang 2016-01-20 23:47:24 UTC

*** This bug has been marked as a duplicate of bug 108581 ***

Note You need to log in before you can comment on or make changes to this bug.