Bug 11030 - (ehci_hcd) ehci_hcd resetting USB very frequently
(ehci_hcd)
ehci_hcd resetting USB very frequently
Status: REJECTED INVALID
Product: Drivers
Classification: Unclassified
Component: USB
All Linux
: P1 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-03 03:49 UTC by Antonio Batovanja
Modified: 2012-05-09 20:42 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.26-rc9
Tree: Mainline
Regression: ---


Attachments
system log (82.70 KB, text/plain)
2008-07-03 14:42 UTC, Antonio Batovanja
Details
kernel config (85.34 KB, text/plain)
2008-07-03 14:50 UTC, Antonio Batovanja
Details
Debug-Logfile (166.00 KB, text/plain)
2008-07-13 11:18 UTC, Antonio Batovanja
Details

Description Antonio Batovanja 2008-07-03 03:49:49 UTC
Latest working kernel version: ?
Earliest failing kernel version: 2.6.24-17
Distribution: Ubuntu
Hardware Environment: USB ID 058f:6362 Alcor Micro Corp. Hi-Speed 21-in-1 Flash Card Reader/Writer (Internal/External)
Software Environment: basic install, also from live cd
Problem Description: USB port is being reset all the time when using uhci_hcd (ohci_hcd is working fine!)

Steps to reproduce:
modprobe uhci_hcd while the above card reader is connected

This bug is simmilar to bug#10913, if I unload the uhci_hcd module, everything works fine.

> uname -r
2.6.24-19-generic
(same messages as with 2.6.24-17, have no earlier kernel versions available)

Kernel messages:

Jul  2 18:56:26 biser kernel: [  657.430935] usb 2-5: new high speed USB device using ehci_hcd and address 9
Jul  2 18:56:26 biser kernel: [  657.787498] usb 2-5: configuration #1 chosen from 1 choice
Jul  2 18:59:18 biser kernel: [  829.158847] usb 2-5: USB disconnect, address 9
Jul  2 18:59:49 biser kernel: [  860.781594] usb 2-5: new high speed USB device using ehci_hcd and address 11
Jul  2 18:59:49 biser kernel: [  860.915970] usb 2-5: configuration #1 chosen from 1 choice
Jul  2 18:59:49 biser kernel: [  860.930915] scsi10 : SCSI emulation for USB Mass Storage devices
Jul  2 18:59:54 biser kernel: [  865.935757] scsi 10:0:0:0: Direct-Access     Generic  USB SD Reader    1.00 PQ: 0 ANSI: 0
Jul  2 18:59:54 biser kernel: [  865.937506] scsi 10:0:0:1: Direct-Access     Generic  USB CF Reader    1.01 PQ: 0 ANSI: 0
Jul  2 18:59:54 biser kernel: [  865.939503] scsi 10:0:0:2: Direct-Access     Generic  USB SM Reader    1.02 PQ: 0 ANSI: 0
Jul  2 18:59:54 biser kernel: [  865.941501] scsi 10:0:0:3: Direct-Access     Generic  USB MS Reader    1.03 PQ: 0 ANSI: 0
Jul  2 18:59:55 biser kernel: [  866.158072] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 18:59:55 biser kernel: [  866.417792] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 18:59:55 biser kernel: [  866.673629] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 18:59:55 biser kernel: [  866.929454] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 18:59:56 biser kernel: [  867.177290] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 18:59:56 biser kernel: [  867.808865] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 18:59:57 biser kernel: [  868.064713] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 18:59:57 biser kernel: [  868.328524] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 18:59:57 biser kernel: [  868.644311] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 18:59:57 biser kernel: [  868.900145] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 18:59:58 biser kernel: [  869.279898] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 18:59:58 biser kernel: [  869.527726] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 18:59:58 biser kernel: [  869.783559] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 18:59:59 biser kernel: [  870.075373] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 18:59:59 biser kernel: [  870.367180] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 18:59:59 biser kernel: [  870.619014] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 18:59:59 biser kernel: [  870.891035] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 19:00:00 biser kernel: [  871.166650] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 19:00:00 biser kernel: [  871.426482] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 19:00:00 biser kernel: [  871.714297] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 19:00:00 biser kernel: [  871.970127] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 19:00:01 biser kernel: [  872.221953] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 19:00:01 biser kernel: [  872.509767] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 19:00:01 biser kernel: [  872.769596] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 19:00:02 biser kernel: [  873.041412] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 19:00:02 biser kernel: [  873.176269] sd 10:0:0:0: [sdd] READ CAPACITY failed
Jul  2 19:00:02 biser kernel: [  873.176277] sd 10:0:0:0: [sdd] Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK,SUGGEST_OK
Jul  2 19:00:02 biser kernel: [  873.176284] sd 10:0:0:0: [sdd] Sense not available.
Jul  2 19:00:02 biser kernel: [  873.293245] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 19:00:02 biser kernel: [  873.565070] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 19:00:02 biser kernel: [  873.832888] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 19:00:03 biser kernel: [  874.464471] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 19:00:03 biser kernel: [  874.716305] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 19:00:03 biser kernel: [  874.964131] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 19:00:04 biser kernel: [  875.219968] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 19:00:04 biser kernel: [  875.354683] sd 10:0:0:0: [sdd] Write Protect is off
Jul  2 19:00:04 biser kernel: [  875.354784] sd 10:0:0:0: [sdd] Attached SCSI removable disk
Jul  2 19:00:04 biser kernel: [  875.354845] sd 10:0:0:0: Attached scsi generic sg4 type 0
Jul  2 19:00:04 biser kernel: [  875.365742] sd 10:0:0:1: [sde] Attached SCSI removable disk
Jul  2 19:00:04 biser kernel: [  875.365809] sd 10:0:0:1: Attached scsi generic sg5 type 0
Jul  2 19:00:04 biser kernel: [  875.379734] sd 10:0:0:2: [sdf] Attached SCSI removable disk
Jul  2 19:00:04 biser kernel: [  875.379803] sd 10:0:0:2: Attached scsi generic sg6 type 0
Jul  2 19:00:04 biser kernel: [  875.388731] sd 10:0:0:3: [sdg] Attached SCSI removable disk
Jul  2 19:00:04 biser kernel: [  875.388799] sd 10:0:0:3: Attached scsi generic sg7 type 0
Jul  2 19:00:04 biser kernel: [  875.547859] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 19:00:04 biser kernel: [  875.815574] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 19:00:05 biser kernel: [  876.175334] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 19:00:05 biser kernel: [  876.443151] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 19:00:05 biser kernel: [  876.718976] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 19:00:06 biser kernel: [  877.058751] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 19:00:06 biser kernel: [  877.362550] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 19:00:06 biser kernel: [  877.622382] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 19:00:06 biser kernel: [  877.994134] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 19:00:07 biser kernel: [  878.261959] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 19:00:07 biser kernel: [  878.537774] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 19:00:07 biser kernel: [  878.825581] usb 2-5: reset high speed USB device using ehci_hcd and address 11
Jul  2 19:00:08 biser kernel: [  879.093409] usb 2-5: reset high speed USB device using ehci_hcd and address 11
(...)


With ohci-hcd (and SD-card plugged in):
Jul  3 12:27:16 biser kernel: [ 2306.093309] usb 1-10: new full speed USB device using ohci_hcd and address 4
Jul  3 12:27:16 biser kernel: [ 2306.308850] usb 1-10: configuration #1 chosen from 1 choice
Jul  3 12:27:16 biser kernel: [ 2306.324218] scsi11 : SCSI emulation for USB Mass Storage devices
Jul  3 12:27:21 biser kernel: [ 2311.338008] scsi 11:0:0:0: Direct-Access     Generic  USB SD Reader    1.00 PQ: 0 ANSI: 0
Jul  3 12:27:21 biser kernel: [ 2311.345014] scsi 11:0:0:1: Direct-Access     Generic  USB CF Reader    1.01 PQ: 0 ANSI: 0
Jul  3 12:27:21 biser kernel: [ 2311.352007] scsi 11:0:0:2: Direct-Access     Generic  USB SM Reader    1.02 PQ: 0 ANSI: 0
Jul  3 12:27:21 biser kernel: [ 2311.359002] scsi 11:0:0:3: Direct-Access     Generic  USB MS Reader    1.03 PQ: 0 ANSI: 0
Jul  3 12:27:21 biser kernel: [ 2311.379056] sd 11:0:0:0: [sdd] Attached SCSI removable disk
Jul  3 12:27:21 biser kernel: [ 2311.379121] sd 11:0:0:0: Attached scsi generic sg4 type 0
Jul  3 12:27:21 biser kernel: [ 2311.390065] sd 11:0:0:1: [sde] Attached SCSI removable disk
Jul  3 12:27:21 biser kernel: [ 2311.390131] sd 11:0:0:1: Attached scsi generic sg5 type 0
Jul  3 12:27:21 biser kernel: [ 2311.401048] sd 11:0:0:2: [sdf] Attached SCSI removable disk
Jul  3 12:27:21 biser kernel: [ 2311.401113] sd 11:0:0:2: Attached scsi generic sg6 type 0
Jul  3 12:27:21 biser kernel: [ 2311.412036] sd 11:0:0:3: [sdg] Attached SCSI removable disk
Jul  3 12:27:21 biser kernel: [ 2311.412100] sd 11:0:0:3: Attached scsi generic sg7 type 0
Jul  3 12:28:02 biser kernel: [ 2351.548308] sd 11:0:0:0: [sdd] 1000448 512-byte hardware sectors (512 MB)
Jul  3 12:28:02 biser kernel: [ 2351.561292] sd 11:0:0:0: [sdd] Write Protect is off
Jul  3 12:28:02 biser kernel: [ 2351.572284] sd 11:0:0:0: [sdd] 1000448 512-byte hardware sectors (512 MB)
Jul  3 12:28:02 biser kernel: [ 2351.585274] sd 11:0:0:0: [sdd] Write Protect is off
Jul  3 12:28:02 biser kernel: [ 2351.585290]  sdd: sdd1
Comment 1 Antonio Batovanja 2008-07-03 03:52:48 UTC
Sorry for typos, ehci_hcd is the failing module, NOT uhci_hcd
Comment 2 Antonio Batovanja 2008-07-03 05:36:13 UTC
> lspci
00:00.0 Memory controller: nVidia Corporation CK804 Memory Controller (rev a3)
00:01.0 ISA bridge: nVidia Corporation CK804 ISA Bridge (rev a3)
00:01.1 SMBus: nVidia Corporation CK804 SMBus (rev a2)
00:02.0 USB Controller: nVidia Corporation CK804 USB Controller (rev a2)
00:02.1 USB Controller: nVidia Corporation CK804 USB Controller (rev a3)
00:04.0 Multimedia audio controller: nVidia Corporation CK804 AC'97 Audio Controller (rev a2)
00:06.0 IDE interface: nVidia Corporation CK804 IDE (rev f2)
00:07.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev f3)
00:08.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev f3)
00:09.0 PCI bridge: nVidia Corporation CK804 PCI Bridge (rev a2)
00:0a.0 Bridge: nVidia Corporation CK804 Ethernet Controller (rev a3)
00:0b.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0c.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0d.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0e.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: nVidia Corporation GeForce 8600 GT (rev a1)
05:06.0 Multimedia controller: Philips Semiconductors SAA7133/SAA7135 Video Broadcast Decoder (rev d0)
Comment 3 Greg Kroah-Hartman 2008-07-03 11:43:35 UTC
Does this also show up in the kernel.org 2.6.25.10 release?  Or 2.6.26-rc8?

We don't/can't support vendor kernels here, sorry.
Comment 4 Antonio Batovanja 2008-07-03 14:40:40 UTC
OK, I gave 2.6.25.10 a try.
Still not working, even got an oops. See attached system log.
How can I help? What else can I provide?
Note that I didn't try to configure much, just did "make oldconfig".

Comment 5 Antonio Batovanja 2008-07-03 14:42:59 UTC
Created attachment 16726 [details]
system log
Comment 6 Antonio Batovanja 2008-07-03 14:50:34 UTC
Created attachment 16727 [details]
kernel config
Comment 7 Antonio Batovanja 2008-07-13 11:01:02 UTC
Tested with 2.6.26-rc9, still not working.
This time with build options CONFIG_USB_DEBUG, I'm attaching the log files.
Comment 8 Antonio Batovanja 2008-07-13 11:18:39 UTC
Created attachment 16802 [details]
Debug-Logfile
Comment 9 Antonio Batovanja 2008-08-16 05:30:10 UTC
It was a hardware defect.
New card reader works perfectly (same model).
Comment 10 mayr0r 2008-11-23 17:07:23 UTC
This bug still seems to be alive, for example in Ubuntu: https://bugs.launchpad.net/ubuntu/intrepid/+source/linux/+bug/88746
I don't think all the instances where this behavior has been reported are hardware defects. Often the hardware seems to work fine with MS Windows.
Please re-examine the issue.
Thank you.
Comment 11 Troy James Sobotka 2008-12-08 10:30:55 UTC
As per comment #10, there is apparently still an issue.  Of the massive list of comments from https://bugs.launchpad.net/ubuntu/intrepid/+source/linux/+bug/88746, several are related to the Alcor chip as with this one.  There are probably several other suspected sets as well.
Comment 12 Greg Kroah-Hartman 2008-12-08 19:54:28 UTC
may0r and troy, if you have different devices with this issue, please open new bugs, or better yet, email the linux-usb@vger.kernel.org mailing list with the information and the developers there will work on it.
Comment 13 Bryan Tanoue 2009-01-11 21:27:48 UTC
Hello,
I seem to have the same problem with an External USB HD.  Its ASIC is based on the ALI chipset.  When I write a certain amount of data (about a few GB) to the device, I start to get a bunch of reset errors.  I've used other Hardrives to test this and it is repeatable.  Not only that I have two of the enclosures and both behave the same.  I can safely but slowly copy the data if I remove the highspeed kernel module, but when backing up ten's of GB of data, hours turn into days.  I will be very happy to help debug the issue.  Please let me know what data you need with the correct commands and I'll do my best.  

I have been using DEBIAN sid for a while and it too has the bug.  I recently decided to build an Ubuntu 8.10 machine due to a hardware malfunction and the problem exists there as well.

On a side not, when I format with an ext3 filesystem, it has trouble and I get the resets.  It never finishes.  If I take the same drive and connect it to a WinXP machine, I can format it in NTFS and copy all I want with no problems.

I know this used to work fine, but I can't remember what kernel level it did work on.  I'm sorry.

I think the ALI chip is the culprit.

Attached is the lsusb output:
 Bus 009 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 003: ID 0402:5621 ALi Corp. USB 2.0 Storage Device
Bus 006 Device 002: ID 05e3:0710 Genesys Logic, Inc. USB 2.0 33-in-1 Card Reader
Bus 006 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 004: ID 0557:2221 ATEN International Co., Ltd 
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Comment 14 Ed Falk 2009-05-04 03:26:03 UTC
Status is "rejected invalid".  What does this mean?  I certainly have the bug, and hundreds of comments at https://bugs.launchpad.net/ubuntu/intrepid/+source/linux/+bug/88746 show that the bug is still there.

Does "rejected invalid" mean that there are no plans to fix the bug?  Is it official then?  Linux doesn't support USB 2.0?

Note You need to log in before you can comment on or make changes to this bug.