Bug 11025 - [problem] raid performance loss with 2.6.26-rc8 on 32-bit x86 (bisected)
[problem] raid performance loss with 2.6.26-rc8 on 32-bit x86 (bisected)
Status: CLOSED CODE_FIX
Product: Memory Management
Classification: Unclassified
Component: Page Allocator
All Linux
: P1 normal
Assigned To: Andrew Morton
:
Depends on:
Blocks: 10492
  Show dependency treegraph
 
Reported: 2008-07-02 07:33 UTC by Rafael J. Wysocki
Modified: 2008-07-06 08:50 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.26-rc8
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-07-02 07:33:15 UTC
Subject    : [problem] raid performance loss with 2.6.26-rc8 on 32-bit x86 (bisected)
Submitter  : Dan Williams <dan.j.williams@intel.com>
Date       : 2008-07-01 1:57
References : http://marc.info/?l=linux-kernel&m=121487749429883&w=4
Handled-By : Mel Gorman <mel@csn.ul.ie>
Handled-By : Andy Whitcroft <apw@shadowen.org>

This entry is being used for tracking a regression from 2.6.25.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-07-02 09:30:49 UTC
Reportedly cause by:

Author: Mel Gorman <mel@csn.ul.ie>
Date:   Mon Apr 28 02:12:16 2008 -0700

    mm: use two zonelist that are filtered by GFP mask

    Signed-off-by: Mel Gorman <mel@csn.ul.ie>
    Acked-by: Christoph Lameter <clameter@sgi.com>
    Signed-off-by: Lee Schermerhorn <lee.schermerhorn@hp.com>
    Cc: KAMEZAWA Hiroyuki <kamezawa.hiroyu@jp.fujitsu.com>
    Cc: Mel Gorman <mel@csn.ul.ie>
    Cc: Christoph Lameter <clameter@sgi.com>
    Cc: Hugh Dickins <hugh@veritas.com>
    Cc: Nick Piggin <nickpiggin@yahoo.com.au>
    Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
Comment 2 Adrian Bunk 2008-07-06 08:50:11 UTC
fixed by commit 494de90098784b8e2797598cefdd34188884ec2e

Note You need to log in before you can comment on or make changes to this bug.