Bug 11016 - i945: mplayer -vo gl messes up screen
i945: mplayer -vo gl messes up screen
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel)
All Linux
: P1 low
Assigned To: Jesse Barnes
:
Depends on:
Blocks: 10492
  Show dependency treegraph
 
Reported: 2008-07-01 03:26 UTC by Tomas Janousek
Modified: 2008-07-03 08:53 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.26-rc1
Tree: Mainline
Regression: Yes


Attachments
don't use tile bits on non-965 (597 bytes, patch)
2008-07-01 11:27 UTC, Jesse Barnes
Details | Diff

Description Tomas Janousek 2008-07-01 03:26:31 UTC
Latest working kernel version: v2.6.25
Earliest failing kernel version: v2.6.25-5100-g7b832b5, 2.6.26-rc1
Distribution: Debian
Hardware Environment: HP Compaq nx7300, i945
Software Environment: xorg-video-intel 2.3.1, MPlayer dev-SVN-r27057-4.2.4

Problem Description:
It looks like this: http://tomi.nomi.cz/tmp/broken_mplayer_gl_2.6.26.mov
You can see the screen gets corrupted at the top around the mplayer window,
but it's the same rectange that gets corrupted in which the video works and
outside doesn't.

I had intel driver 2.1.1 a few weeks ago and it looked a bit different there -- didn't corrupt the top of the screen but was corrupted in the whole mplayer window.

I bisected it to 7b832b56bd971348329c3f4c753ca0abfdf3a3d1. i945 seems not to support these tiled XY blits, or at least not this way. Reverting this at HEAD serves as a workaround.
Comment 1 Tomas Janousek 2008-07-01 03:30:36 UTC
adding the commit signoffs to cc
Comment 2 Andrew Morton 2008-07-01 11:12:06 UTC
A post-2.6.25 regression.

The simplest fix would be to revert Keith's change.  But the changelog
for that patch has insufficient information to permit to know what the
effect of that revert would be.  Did the patch fix a bug?  If so, what
was it?
Comment 3 Jesse Barnes 2008-07-01 11:27:18 UTC
Created attachment 16679 [details]
don't use tile bits on non-965

Yeah, we don't want to revert the change, however we shouldn't set those bits on pre-965 chips either.  Does this patch help?
Comment 4 Keith Packard 2008-07-01 12:17:14 UTC
Looks like the 945 doesn't need these register settings -- it uses the fence registers for detiling instead of explicit configuration. Jbarnes has a patch, and liskni_s is testing it now.
Comment 5 Tomas Janousek 2008-07-01 12:22:37 UTC
works indeed.
Comment 6 Rafael J. Wysocki 2008-07-01 12:38:47 UTC
This entry is being used for tracking a regression from 2.6.25.  Please don't
close it until the problem is fixed in the mainline.
Comment 7 Jesse Barnes 2008-07-01 12:43:35 UTC
Just sent the fix to Linus & Dave.  Should be applied soon.
Comment 8 Adrian Bunk 2008-07-01 12:44:53 UTC
Handled-By      : Jesse Barnes <jbarnes@virtuousgeek.org>
Patch           : http://bugzilla.kernel.org/attachment.cgi?id=16679
Comment 9 Jesse Barnes 2008-07-03 08:53:08 UTC
Fixed by 3d25802e3ba7c82457b5c12bbfeefe391d8a333e.

Note You need to log in before you can comment on or make changes to this bug.