Bug 110151 - No driver for Intel Atom x7 (Cherrytrail) ISP [Surface 3]
Summary: No driver for Intel Atom x7 (Cherrytrail) ISP [Surface 3]
Status: RESOLVED DUPLICATE of bug 109821
Alias: None
Product: v4l-dvb
Classification: Unclassified
Component: v4l-other (show other bugs)
Hardware: x86-64 Linux
: P2 normal
Assignee: v4l-other
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-12-30 02:54 UTC by Stephen Just
Modified: 2018-08-16 13:47 UTC (History)
1 user (show)

See Also:
Kernel Version: 4.4.0
Tree: Mainline
Regression: No


Attachments

Description Stephen Just 2015-12-30 02:54:01 UTC
The Microsoft Surface 3 has an Intel Atom Z8700 processor in it. This SoC contains an ISP which handles input from the device's two cameras. This ISP has no driver available currently. The ISP shows up as a PCI device.

It might be possible to build a driver based on the atomisp driver written for an older Atom platform (here: https://kernel.googlesource.com/pub/scm/linux/kernel/git/kas/3.0-mid/+/HEAD/drivers/media/video/atomisp) and Intel's datasheets.

Neither of the camera sensors in the tablet have drivers either, so it might be necessary to write at least one of those drivers first to test anything. The sensors are an Aptina AR0330 and an OmniVision OV8835.
Comment 1 Andy Shevchenko 2015-12-30 10:39:04 UTC
Downgrade the importance since the cameras are not so critical for running Linux.
Comment 2 Andy Shevchenko 2016-02-01 10:46:13 UTC

*** This bug has been marked as a duplicate of bug 109821 ***

Note You need to log in before you can comment on or make changes to this bug.