Bug 110001 - ASUS N550JX external sub-woofer doesn't work out of the box.
Summary: ASUS N550JX external sub-woofer doesn't work out of the box.
Status: RESOLVED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Jaroslav Kysela
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-12-26 05:58 UTC by liudas
Modified: 2016-01-18 18:47 UTC (History)
2 users (show)

See Also:
Kernel Version: 4.2.5
Tree: Mainline
Regression: No


Attachments
alsa-info.sh output (37.90 KB, application/octet-stream)
2015-12-26 05:58 UTC, liudas
Details
Test fix patch (768 bytes, patch)
2016-01-12 08:41 UTC, Takashi Iwai
Details | Diff

Description liudas 2015-12-26 05:58:22 UTC
Created attachment 198331 [details]
alsa-info.sh output

ASUS N550JX external sub-woofer doesn't work out of the box. In order correctly register sub-woofer node with ALSA, pin change patch is required:
--------
[codec]
0x10ec0668 0x104313df 0

[pincfg]
0x1a 0x00106111
--------
Attached alsa-info.sh output is generated from patched and working system.
Comment 1 Takashi Iwai 2016-01-12 08:40:46 UTC
Could you try the patch below?
Comment 2 Takashi Iwai 2016-01-12 08:41:04 UTC
Created attachment 199411 [details]
Test fix patch
Comment 3 Raymond 2016-01-14 10:12:45 UTC
Do hdajacksensetest -a report the jack state of the external subwoofer since other asus n. Series laptop using alc668 can detect the subwoofer?
Comment 4 liudas 2016-01-17 18:13:31 UTC
(In reply to Takashi Iwai from comment #1)
> Could you try the patch below?

Yes it works. Thank you.
Comment 5 Takashi Iwai 2016-01-18 18:47:19 UTC
I queued the patch now.  It'll be included in the next pull request for 4.5-rc1, and backported to stable kernels eventually later.

Note You need to log in before you can comment on or make changes to this bug.