Bug 10988 - Hangs on resume with acpi_sleep=s3_bios
Hangs on resume with acpi_sleep=s3_bios
Status: CLOSED DUPLICATE of bug 7225
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: power-management_other
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-26 10:27 UTC by Kirill A. Shutemov
Modified: 2009-04-02 04:56 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.26-rc7
Tree: Mainline
Regression: No


Attachments

Description Kirill A. Shutemov 2008-06-26 10:27:54 UTC
Earliest failing kernel version: 2.6.26-rc7
Hardware Environment: laptop Dell XPS M1210, x86_64
Problem Description:

I have problem with video restore therefore I have tried to boot with 'acpi_sleep=s3_bios'. The system hangs on wake up on line 'asm volatile("lcallw   $0xc000,$3");' at arch/x86/kernel/acpi/realmode/wakemain.c

I have applied patch http://bugzilla.kernel.org/attachment.cgi?id=16604. See bug #10927 for more details. Probably this bug can be related with #10927.

Steps to reproduce:
1. Boot with 'acpi_sleep=s3_bios'.
2. Suspend to RAM.
3. Hangs on wake up.
Comment 1 Rafael J. Wysocki 2008-06-26 10:59:33 UTC

*** This bug has been marked as a duplicate of bug 7225 ***

Note You need to log in before you can comment on or make changes to this bug.