Bug 10974 - 2.6.25 regression: delay needed after audio CD insertion
2.6.25 regression: delay needed after audio CD insertion
Status: RESOLVED OBSOLETE
Product: SCSI Drivers
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: scsi_drivers-other
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-24 02:27 UTC by Geert Uytterhoeven
Modified: 2012-10-30 14:54 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.25
Tree: Mainline
Regression: Yes


Attachments

Description Geert Uytterhoeven 2008-06-24 02:27:52 UTC
Latest working kernel version: 2.6.24
Hardware Environment: PS3
Problem Description: Audio CD cannot be read within 10 seconds after insertion

Steps to reproduce:
  1. Insert an audio CD
  2. Run the following command as soon as the blue CD/DVD/BD drive LED
     stops blinking and is lit continuously:
      
     cdparanoia -Z -q 1-1[:1] /dev/null || echo failed

On 2.6.25 (and current mainline), you have to wait ca. 10 seconds after
insertion, or it will fail.
On 2.6.24 and older, it just works immediately.

(I could reproduce it on an Athlon with sym53c8xx SCSI running a Debianized
 2.6.25 kernel, too, but I didn't try a 2.6.24 kernel there)

The problem was introduced by:

commit 38582a62ecd337de4212004c7d4844899dc57890
Author: James Bottomley <James.Bottomley@HansenPartnership.com>
Date:   Wed Feb 6 13:01:58 2008 -0600

    [SCSI] sr: fix test unit ready responses

References: http://lkml.org/lkml/2008/6/13/89
Comment 1 Geert Uytterhoeven 2008-10-21 02:37:42 UTC
I wrote:
| (I could reproduce it on an Athlon with sym53c8xx SCSI running a Debianized
|  2.6.25 kernel, too, but I didn't try a 2.6.24 kernel there)

However, I gave a Debianized 2.6.24 kernel a try on the machine above. It behaved differently, but it still didn't work.

CD-ROM specs:
  Vendor: PLEXTOR  Model: CD-R   PX-W1210S Rev: 1.01
  Type:   CD-ROM                           ANSI  SCSI revision: 02

So perhaps it's just a fortunate `accident' the above command sequence works on PS3 on 2.6.x with x <= 24?
Comment 2 Alan 2012-10-30 14:54:15 UTC
If this is still seen with modern kernels please update/re-open

Note You need to log in before you can comment on or make changes to this bug.