Bug 10973 - Xen build error
Xen build error
Status: CLOSED CODE_FIX
Product: Virtualization
Classification: Unclassified
Component: Xen
All Linux
: P1 normal
Assigned To: virtualization_xen
:
Depends on:
Blocks: 10492
  Show dependency treegraph
 
Reported: 2008-06-24 00:51 UTC by Adrian Bunk
Modified: 2008-06-24 12:30 UTC (History)
0 users

See Also:
Kernel Version: 2.6.26-rc7-git
Tree: Mainline
Regression: Yes


Attachments

Description Adrian Bunk 2008-06-24 00:51:23 UTC
Subject         : Xen build error
Submitter       : Adrian Bunk <bunk@kernel.org>
References      : http://lkml.org/lkml/2008/6/24/78
Comment 1 Adrian Bunk 2008-06-24 00:52:42 UTC
Caused by:

commit ebb9cfe20fe167f29960a5e913193a684fac50bf
Author: Jeremy Fitzhardinge <jeremy@goop.org>
Date:   Mon Jun 16 15:01:56 2008 -0700

    xen: don't drop NX bit
    
    Because NX is now enforced properly, we must put the hypercall page
    into the .text segment so that it is executable.
    
    Signed-off-by: Jeremy Fitzhardinge <jeremy.fitzhardinge@citrix.com>
    Cc: Stable Kernel <stable@kernel.org>
    Cc: the arch/x86 maintainers <x86@kernel.org>
    Signed-off-by: Ingo Molnar <mingo@elte.hu>
Comment 2 Adrian Bunk 2008-06-24 12:30:09 UTC
fixed by commit 28499143933f19b28008a556ed59255d6009391a

Note You need to log in before you can comment on or make changes to this bug.