Bug 10962 - 2.6.26-rc2 WARNING from usb-serial, and then my gps is dead
2.6.26-rc2 WARNING from usb-serial, and then my gps is dead
Status: CLOSED WILL_NOT_FIX
Product: Drivers
Classification: Unclassified
Component: USB
All Linux
: P1 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: 10492
  Show dependency treegraph
 
Reported: 2008-06-22 11:31 UTC by Rafael J. Wysocki
Modified: 2008-07-02 14:41 UTC (History)
0 users

See Also:
Kernel Version: 2.6.26-rc2
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-06-22 11:31:24 UTC
Subject    : 2.6.26-rc2 WARNING from usb-serial, and then my gps is dead
Submitter  : Helge Hafting <helge.hafting@aitel.hist.no>
Date       : 2008-06-22 18:22
References : http://marc.info/?l=linux-kernel&m=121415899320685&w=4

This entry is being used for tracking a regression from 2.6.25.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-06-22 12:02:19 UTC
Handled-By : Greg Kroah-Hartman <greg@kroah.com>
Comment 2 Rafael J. Wysocki 2008-06-25 15:14:45 UTC
On Wednesday, 25 of June 2008, Helge Hafting wrote:
> Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.25.  Please verify if it still should be listed.
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=10962
> > Subject		: 2.6.26-rc2 WARNING from usb-serial, and then my gps is dead
> > Submitter	: Helge Hafting <helge.hafting@aitel.hist.no>
> > Date		: 2008-06-22 18:22 (1 days old)
> > References	: http://marc.info/?l=linux-kernel&m=121415899320685&w=4
> > 
> > 
> 
> I can confirm that this problem still happens in 2.6.26-rc8.
> When the gps loose connection (probably due to faulty USB cabling), then
> the kernel spits out numerous WARNINGs.
> 
> I'll try to reproduce with USB debugging later.

Comment 3 Helge Hafting 2008-07-02 03:52:32 UTC
I did reproduce the bug with USB debugging, and the log is at:
http://www.aitel.hist.no/~helgehaf/usbtrouble1.log.bz2
(Kernel 2.6.26-rc8, SMP, amd64, voluntary preempt)
Comment 4 Greg Kroah-Hartman 2008-07-02 14:20:40 UTC
Thanks for the log file, you can safely ignore this warning at this time, the tty layer rework is fixing this type of issue for 2.6.27.

Note You need to log in before you can comment on or make changes to this bug.