Bug 10961 - 2.6.26-rc: nfsd hangs for a few sec
2.6.26-rc: nfsd hangs for a few sec
Status: CLOSED CODE_FIX
Product: Memory Management
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: Andrew Morton
:
Depends on:
Blocks: 10492
  Show dependency treegraph
 
Reported: 2008-06-22 11:26 UTC by Rafael J. Wysocki
Modified: 2008-07-05 13:09 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.26-rc
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-06-22 11:26:17 UTC
Subject    : 2.6.26-rc: nfsd hangs for a few sec
Submitter  : "Alexander Beregalov" <a.beregalov@gmail.com>
Date       : 2008-06-21 12:57
References : http://marc.info/?l=linux-kernel&m=121405308328004&w=4
References : http://marc.info/?l=linux-kernel&m=121412880115289&w=4
Handled-By : Linus Torvalds <torvalds@linux-foundation.org>
Handled-By : Mel Gorman <mel@csn.ul.ie>
Handled-By : Christoph Lameter <clameter@sgi.com>

This entry is being used for tracking a regression from 2.6.25.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-06-22 11:28:15 UTC
Reportedly caused by:

commit 54a6eb5c4765aa573a030ceeba2c14e3d2ea5706
Author: Mel Gorman <mel@csn.ul.ie>
Date:   Mon Apr 28 02:12:16 2008 -0700

   mm: use two zonelist that are filtered by GFP mask
Comment 2 Rafael J. Wysocki 2008-07-02 09:26:48 UTC
References : http://marc.info/?t=121416305600004&r=1&w=4

Note You need to log in before you can comment on or make changes to this bug.