Bug 10959 - stuck tcp connections 2.6.26-rc7
stuck tcp connections 2.6.26-rc7
Status: CLOSED INVALID
Product: Networking
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: Arnaldo Carvalho de Melo
:
Depends on:
Blocks: 10492
  Show dependency treegraph
 
Reported: 2008-06-22 11:15 UTC by Rafael J. Wysocki
Modified: 2008-06-29 13:58 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.26-rc7
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-06-22 11:15:32 UTC
Subject    : stuck tcp connections 2.6.26-rc7
Submitter  : "Justin Mattock" <justinmattock@gmail.com>
Date       : 2008-06-22 18:09
References : http://marc.info/?l=linux-kernel&m=121415821219644&w=4

This entry is being used for tracking a regression from 2.6.25.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-06-22 14:24:59 UTC
On Sunday, 22 of June 2008, Justin Mattock wrote:
> On Sun, Jun 22, 2008 at 5:54 PM, Rafael J. Wysocki <rjw@sisk.pl> wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> >
> > The following bug entry is on the current list of known regressions
> > from 2.6.25.  Please verify if it still should be listed.
> >
> >
> > Bug-Entry       : http://bugzilla.kernel.org/show_bug.cgi?id=10959
> > Subject         : stuck tcp connections 2.6.26-rc7
> > Submitter       : Justin Mattock <justinmattock@gmail.com>
> > Date            : 2008-06-22 18:09 (1 days old)
> > References      : http://marc.info/?l=linux-kernel&m=121415821219644&w=4
> >
> >
> >
> 
> Yes;
> As a short work around setting #define TCP_RTO_MAX	((unsigned)(120*HZ)) to
> #define TCP_RTO_MAX	((unsigned)(60*HZ)) in include/net/tcp.h does
> help, but the problem is still there.
> After testing this setting out for a few days, I decided to revert it
> back, so I don't mess my tcp packets up, and feel like an internet hog
> regards;

Comment 2 Adrian Bunk 2008-06-27 14:37:16 UTC
Rafael, please try to check whether people use external modules (in this case madwifi) before listing something as regression...

http://lkml.org/lkml/2008/6/26/68
Comment 3 Justin P. Mattock 2008-06-27 15:10:19 UTC
On Fri, Jun 27, 2008 at 9:37 PM,  <bugme-daemon@bugzilla.kernel.org> wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=10959
>
>
> bunk@kernel.org changed:
>
>           What    |Removed                     |Added
> ----------------------------------------------------------------------------
>                 CC|                            |bunk@kernel.org
>             Status|NEW                         |REJECTED
>         Resolution|                            |INVALID
>
>
>
>
> ------- Comment #2 from bunk@kernel.org  2008-06-27 14:37 -------
> Rafael, please try to check whether people use external modules (in this case
> madwifi) before listing something as regression...
>
> http://lkml.org/lkml/2008/6/26/68
>
>
> --
> Configure bugmail: http://bugzilla.kernel.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug, or are watching someone who is.
>

This was the case for me,(madwifi) luckily wpa_supplicant was not
running in the background, or who knows how long it
would of been before seeing what exactly was going on.
regards;



Note You need to log in before you can comment on or make changes to this bug.