Bug 10957 - pata_pcmcia with Sandisk Extreme III 8GB
pata_pcmcia with Sandisk Extreme III 8GB
Status: CLOSED CODE_FIX
Product: IO/Storage
Classification: Unclassified
Component: Serial ATA
All Linux
: P1 normal
Assigned To: Alan
:
: 10661 (view as bug list)
Depends on:
Blocks: 10492
  Show dependency treegraph
 
Reported: 2008-06-22 10:52 UTC by Rafael J. Wysocki
Modified: 2008-09-23 03:30 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.26-rc4
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-06-22 10:52:39 UTC
Subject    : [KERNEL 2.6.26-rc4]  bugreport : pata_pcmcia with Sandisk Extreme III 8GB
Submitter  : Komuro <komurojun-mbn@nifty.com>
Date       : 2008-06-07 13:37
References : http://marc.info/?l=linux-kernel&m=121284627119861&w=4
Handled-By : Tejun Heo <htejun@gmail.com>
Handled-By : Dominik Brodowski <linux@dominikbrodowski.net>

This entry is being used for tracking a regression from 2.6.25.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-06-22 10:53:54 UTC
Caused by:

commit f046519fc85a8fdf6a058b4ac9d897cdee6f3e52
Author: Tejun Heo <htejun@gmail.com>
Date:   Mon May 19 01:15:08 2008 +0900

    libata: kill hotplug related race condition

Comment 2 Pavel Machek 2008-06-26 09:19:02 UTC
Hmm, I get deadlock, not any messages, and I need plug/unplug/plug for the error to fully manifest itself. Seems like different problem?
Comment 3 Komuro 2008-06-27 16:28:40 UTC
Before the "kill hotplug related race condition" patch,
only 0.0  exist at /sys/bus/pcmcia/devices.

but after this patch,
0.0 and 0.1  exist at /sys/bus/pcmcia/devices.

This 0.1 causes the problem...
Comment 4 Tejun Heo 2008-06-27 20:18:34 UTC
I'm seriously running out of ideas for this one.  I can't really see how the race condition fix patch can bring the second pcmcia port into life.  Strange.  :-(
Comment 5 Rafael J. Wysocki 2008-07-02 09:25:41 UTC
On Tuesday, 1 of July 2008, Komuro wrote:
> 
> Hi,
> 
> This problem is not fixed yet.
> 
> 
> 
> Best Regards
> Komuro
> 
> 
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.25.  Please verify if it still should be listed.
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=10957
> > Subject		: pata_pcmcia with Sandisk Extreme III 8GB
> > Submitter	: Komuro <komurojun-mbn@nifty.com>
> > Date		: 2008-06-07 13:37 (23 days old)
> > References	: http://marc.info/?l=linux-kernel&m=121284627119861&w=4
> > Handled-By	: Tejun Heo <htejun@gmail.com>
> > 		  Dominik Brodowski <linux@dominikbrodowski.net>

Comment 6 Rafael J. Wysocki 2008-07-06 04:20:11 UTC
Handled-By : Komuro <komurojun-mbn@nifty.com>
Patch : http://marc.info/?l=linux-kernel&m=121530861605673&w=4
Comment 7 Rafael J. Wysocki 2008-07-13 12:55:35 UTC
Ignore-Patch : http://marc.info/?l=linux-kernel&m=121530861605673&w=4
Comment 8 Alan 2008-09-22 08:03:21 UTC
Fixed

Its a pcmcia core bug - changing the objects hide it because pcmcia was reading wrong data via dev->private_data. Patch posted to Linus/LKML
Comment 9 Alan 2008-09-22 08:04:12 UTC
*** Bug 10661 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.