Bug 10954 - hda_intel: azx_get_response timeout, switching to polling mode: last cmd=0x011f000c
Summary: hda_intel: azx_get_response timeout, switching to polling mode: last cmd=0x01...
Status: CLOSED DOCUMENTED
Alias: None
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Jaroslav Kysela
URL:
Keywords:
Depends on:
Blocks: 10492
  Show dependency tree
 
Reported: 2008-06-22 10:37 UTC by Rafael J. Wysocki
Modified: 2012-05-09 20:44 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.27.10
Tree: Mainline
Regression: Yes


Attachments
remove headphones (46.12 KB, application/octet-stream)
2008-06-29 11:44 UTC, Justin P. Mattock
Details
just rebooted (38.06 KB, application/octet-stream)
2008-06-29 11:52 UTC, Justin P. Mattock
Details
dmesg on linux-2.6.28-rc7-git4 (41.58 KB, application/octet-stream)
2008-12-06 04:18 UTC, Giovanni Pellerano
Details

Description Rafael J. Wysocki 2008-06-22 10:37:20 UTC
Subject    : hda_intel: azx_get_response timeout, switching to polling mode: last cmd=0x011f000c
Submitter  : "Justin Mattock" <justinmattock@gmail.com>
Date       : 2008-06-21 2:05
References : http://marc.info/?l=linux-kernel&m=121401399622190&w=4

This entry is being used for tracking a regression from 2.6.25.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-06-22 14:29:22 UTC
On Sunday, 22 of June 2008, Justin Mattock wrote:
> On Sun, Jun 22, 2008 at 5:54 PM, Rafael J. Wysocki <rjw@sisk.pl> wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> >
> > The following bug entry is on the current list of known regressions
> > from 2.6.25.  Please verify if it still should be listed.
> >
> >
> > Bug-Entry       : http://bugzilla.kernel.org/show_bug.cgi?id=10954
> > Subject         : hda_intel: azx_get_response timeout, switching to polling
> mode: last cmd=0x011f000c
> > Submitter       : Justin Mattock <justinmattock@gmail.com>
> > Date            : 2008-06-21 2:05 (2 days old)
> > References      : http://marc.info/?l=linux-kernel&m=121401399622190&w=4
> >
> >
> >
> 
> I'm up in the air with this one, i.g. one minute this message is
> appearing, and then the next it's not.
> If nobody else is catching this or seeing this happen, then I'll take
> it as a .config problem on my part.
Comment 2 Adrian Bunk 2008-06-27 14:39:28 UTC
Does a 2.6.26-rc8 kernel that is both unpatched and without any external modules loaded exhibit this problem?

If yes, please attach the output of "dmesg -s 1000000".
Comment 3 Justin P. Mattock 2008-06-27 15:13:47 UTC
On Fri, Jun 27, 2008 at 9:39 PM,  <bugme-daemon@bugzilla.kernel.org> wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=10954
>
>
> bunk@kernel.org changed:
>
>           What    |Removed                     |Added
> ----------------------------------------------------------------------------
>                 CC|                            |bunk@kernel.org
>
>
>
>
> ------- Comment #2 from bunk@kernel.org  2008-06-27 14:39 -------
> Does a 2.6.26-rc8 kernel that is both unpatched and without any external
> modules loaded exhibit this problem?
>
> If yes, please attach the output of "dmesg -s 1000000".
>
>
> --
> Configure bugmail: http://bugzilla.kernel.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug, or are watching someone who is.
>

You would have to give me some time. i.g. I need to download a fresh
kernel and recompile.
but I can give you info from what I experienced I noticed this twice
upon a compile of a fresh kernel with patches
that are now in the mainline. But after a couple of reboots this
message disappeared, only to return once when
the system was under heavy load(compiling)
regards;
Comment 4 Justin P. Mattock 2008-06-27 22:22:53 UTC
On Fri, Jun 27, 2008 at 10:13 PM, Justin Mattock
<justinmattock@gmail.com> wrote:
> On Fri, Jun 27, 2008 at 9:39 PM,  <bugme-daemon@bugzilla.kernel.org> wrote:
>> http://bugzilla.kernel.org/show_bug.cgi?id=10954
>>
>>
>> bunk@kernel.org changed:
>>
>>           What    |Removed                     |Added
>> ----------------------------------------------------------------------------
>>                 CC|                            |bunk@kernel.org
>>
>>
>>
>>
>> ------- Comment #2 from bunk@kernel.org  2008-06-27 14:39 -------
>> Does a 2.6.26-rc8 kernel that is both unpatched and without any external
>> modules loaded exhibit this problem?
>>
>> If yes, please attach the output of "dmesg -s 1000000".
>>
>>
>> --
>> Configure bugmail: http://bugzilla.kernel.org/userprefs.cgi?tab=email
>> ------- You are receiving this mail because: -------
>> You are on the CC list for the bug, or are watching someone who is.
>>
>
> You would have to give me some time. i.g. I need to download a fresh
> kernel and recompile.
> but I can give you info from what I experienced I noticed this twice
> upon a compile of a fresh kernel with patches
> that are now in the mainline. But after a couple of reboots this
> message disappeared, only to return once when
> the system was under heavy load(compiling)
> regards;
>
> --
> Justin P. Mattock
>

You can you the same dmesg from GPE storm that I had just sent.
This is unreproducible in my case. It just happens on a random(every X
amount of boots)
regards
Comment 5 Justin P. Mattock 2008-06-29 11:44:33 UTC
Created attachment 16654 [details]
remove headphones

this is dmesg of azx_get_response timeout, going off
after I removed the headphnes.
Comment 6 Justin P. Mattock 2008-06-29 11:52:47 UTC
Created attachment 16655 [details]
just rebooted

This is dmesg of azx_get_response after a fresh reboot.
Comment 7 Rafael J. Wysocki 2008-07-02 09:22:07 UTC
References : http://marc.info/?t=121416231700010&r=1&w=4
Comment 8 Rafael J. Wysocki 2008-07-06 11:09:02 UTC
On Sunday, 6 of July 2008, Justin Mattock wrote:
> On Sun, Jul 6, 2008 at 11:45 AM, Rafael J. Wysocki <rjw@sisk.pl> wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> >
> > The following bug entry is on the current list of known regressions
> > from 2.6.25.  Please verify if it still should be listed.
> >
> >
> > Bug-Entry       : http://bugzilla.kernel.org/show_bug.cgi?id=10954
> > Subject         : hda_intel: azx_get_response timeout, switching to polling
> mode: last cmd=0x011f000c
> > Submitter       : Justin Mattock <justinmattock@gmail.com>
> > Date            : 2008-06-21 2:05 (16 days old)
> > References      : http://marc.info/?l=linux-kernel&m=121401399622190&w=4
> >                  http://marc.info/?t=121416231700010&r=1&w=4
> >
> >
> >
> 
> yes;
> as an estimate(been busy with another bug), I'm going to say out of
> 100 reboots this message will
> appear 2 times in a row, and then disappear.
> regards;
Comment 9 Justin P. Mattock 2008-07-07 19:59:22 UTC
after looking around, I remembered that in /etc/modprobe.d
I had to add a line due to the clicking noise in the headphones that would occur from time to time.
As a test I'm removing: options snd-hda-intel position_fix=1 
in /etc/modprobe.d/alsa-base to see if this bug appears.
Comment 10 Rafael J. Wysocki 2008-07-13 13:00:22 UTC
On Sunday, 13 of July 2008, Justin Mattock wrote:
> On Sun, Jul 13, 2008 at 6:00 PM, Rafael J. Wysocki <rjw@sisk.pl> wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> >
> > The following bug entry is on the current list of known regressions
> > from 2.6.25.  Please verify if it still should be listed.
> >
> >
> > Bug-Entry       : http://bugzilla.kernel.org/show_bug.cgi?id=10954
> > Subject         : hda_intel: azx_get_response timeout, switching to polling
> mode: last cmd=0x011f000c
> > Submitter       : Justin Mattock <justinmattock@gmail.com>
> > Date            : 2008-06-21 2:05 (23 days old)
> > References      : http://marc.info/?l=linux-kernel&m=121401399622190&w=4
> >                  http://marc.info/?t=121416231700010&r=1&w=4
> >
> >
> >
> 
> yes;
> after running a small test of removing options snd-hda-intel position_fix=1
> out of /etc/modprobe.d I was still receiving this message, but instead
> of twice in a row
> like it was doing, I am only seeing this happen occasionally once.
Comment 11 Giovanni Pellerano 2008-12-06 04:12:09 UTC
i got: 

hda_intel: azx_get_response timeout, switching to polling mode: last cmd=0x020c0000

on sony vaio sr19xn kernel linux-2.6.28-rc7-git4
Comment 12 Giovanni Pellerano 2008-12-06 04:18:36 UTC
Created attachment 19176 [details]
dmesg on linux-2.6.28-rc7-git4
Comment 13 Justin P. Mattock 2008-12-06 06:59:38 UTC
On Sat, Dec 6, 2008 at 4:18 AM,  <bugme-daemon@bugzilla.kernel.org> wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=10954
>
>
>
>
>
> ------- Comment #12 from giovanni.pellerano@gmail.com  2008-12-06 04:18
> -------
> Created an attachment (id=19176)
>  --> (http://bugzilla.kernel.org/attachment.cgi?id=19176&action=view)
> dmesg on linux-2.6.28-rc7-git4
>
>
> --
> Configure bugmail: http://bugzilla.kernel.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug, or are watching someone who is.
>

I see this with
2.6.28-rc7-00091-gf6f7b52
[   11.780016] hda_intel: azx_get_response timeout, switching to
polling mode: last cmd=0x00af0900
once/maybe twice every 20/30 reboots
not as intense as a few months ago.
(which I think was every 10 reboots.)
Comment 14 James Ettle 2009-01-10 04:34:28 UTC
Spotted in kernel-2.6.27.10-169.fc10.x86_64:

ALSA sound/pci/hda/hda_intel.c:623: hda_intel: azx_get_response timeout, switching to polling mode: last cmd=0x006f000a
CE: hpet increasing min_delta_ns to 22500 nsec

and seen in the logs as far back as 2.6.27.9 (possibly earlier). This is with a Realtek ALC 883 codec. Sound seems to carry on working.
Comment 15 Florian Mickler 2010-08-16 11:47:17 UTC
Hi Justin!

Is this still an issue? Also I gather there are no symptoms accompanying the message? 

There is one commit from 2009 which specifically mentions to fix an occurrence of this message: 
9d30937acc ALSA: hda_intel: more strict alc880_parse_auto_config dig_nid checking 

But of course, that could be any occurrence and doesn't have to affect this issue.  Anyway, a quick thumbs up(or down) would be awesome. 

Cheers,
Flo
Comment 16 Justin P. Mattock 2010-08-16 16:12:58 UTC
On 08/16/2010 04:47 AM, bugzilla-daemon@bugzilla.kernel.org wrote:
> https://bugzilla.kernel.org/show_bug.cgi?id=10954
>
>
> Florian Mickler<fmickler@gmx.de>  changed:
>
>             What    |Removed                     |Added
> ----------------------------------------------------------------------------
>                   CC|                            |fmickler@gmx.de
>
>
>
>
> --- Comment #15 from Florian Mickler<fmickler@gmx.de>   2010-08-16 11:47:17
> ---
> Hi Justin!
>
> Is this still an issue? Also I gather there are no symptoms accompanying the
> message?
>
> There is one commit from 2009 which specifically mentions to fix an
> occurrence
> of this message:
> 9d30937acc ALSA: hda_intel: more strict alc880_parse_auto_config dig_nid
> checking
>
> But of course, that could be any occurrence and doesn't have to affect this
> issue.  Anyway, a quick thumbs up(or down) would be awesome.
>
> Cheers,
> Flo
>


not sure if this should be closed or not.. As for the message itself, I 
have seen this fire off, but cant remember what kernel version etc.. due 
to it rarely firing off, and causing no performance/sound issues at 
all.. so it's not really an issue.

Justin P. Mattock
Comment 17 Florian Mickler 2010-08-17 18:30:36 UTC
Well, I guess it is up to Takashi Iwai. Is this something serious or is it expected to happen under some circumstances?
Comment 18 Takashi Iwai 2010-08-17 21:18:21 UTC
The switching to polling mode itself has been never a serious issue.  See Documentation/sound/alsa/HD-Audio.txt.
Comment 19 Florian Mickler 2010-09-03 08:03:59 UTC
I'm closing it then.
Comment 20 Justin P. Mattock 2010-09-03 08:16:03 UTC
On 09/03/2010 01:04 AM, bugzilla-daemon@bugzilla.kernel.org wrote:
> https://bugzilla.kernel.org/show_bug.cgi?id=10954
>
>
> Florian Mickler<florian@mickler.org>  changed:
>
>             What    |Removed                     |Added
> ----------------------------------------------------------------------------
>               Status|RESOLVED                    |CLOSED
>
>
>
>
> --- Comment #19 from Florian Mickler<florian@mickler.org>   2010-09-03
> 08:03:59 ---
> I'm closing it then.
>

yeah.. I rarely(if at all) see this pop up...

Justin P. Mattock

Note You need to log in before you can comment on or make changes to this bug.