Bug 1095 - USB Mouse stops working, need to rmmod/modprobe hid to get it back
Summary: USB Mouse stops working, need to rmmod/modprobe hid to get it back
Status: CLOSED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: USB (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: Greg Kroah-Hartman
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-08-13 08:21 UTC by David Hollis
Modified: 2003-10-06 20:54 UTC (History)
0 users

See Also:
Kernel Version: 2.6.0-test2-mm4
Tree: Mainline
Regression: ---


Attachments
dmesg output (15.09 KB, text/plain)
2003-08-13 08:22 UTC, David Hollis
Details
lsusb -v output (6.26 KB, text/plain)
2003-08-13 08:23 UTC, David Hollis
Details
kernel .config (33.52 KB, text/plain)
2003-08-13 08:24 UTC, David Hollis
Details

Description David Hollis 2003-08-13 08:21:46 UTC
Distribution: RedHat Linux 9
Hardware Environment: Compaq Evo N610c
Software Environment: 
Problem Description:
I use a Microsoft USB mouse with my laptop which had no problems at all with 2.4
all through 2.6.0-test2-mm2.  As of 2.6.0-test2-mm4, the mouse freezes and I
have remove the hid driver and reload it to get it back.  It may work for 2
minutes, 20 minutes, maybe a bit longer (but not much), and it will freeze
again.  I have to constantly remove hid and reload it.

Here is dmesg output after a lockup:
drivers/usb/core/usb.c: deregistering driver hiddev
drivers/usb/core/usb.c: deregistering driver hid
ohci-hcd 0000:02:0e.0: shutdown urb efb54b00 pipe 40408380 ep1in-intr
usb 1-2: hcd_unlink_urb efb54b00 fail -22
usb 1-2: hcd_unlink_urb efb54980 fail -22
usb 1-2: hcd_unlink_urb efb54b00 fail -22
drivers/usb/core/usb.c: registered new driver hiddev
hid 1-2:0: usb_probe_interface
hid 1-2:0: usb_probe_interface - got id
input: USB HID v1.00 Mouse [Microsoft Microsoft 3-Button Mouse with IntelliEye?]
on usb-0000:02:0e.0-2
drivers/usb/core/usb.c: registered new driver hid
drivers/usb/input/hid-core.c: v2.0:USB HID core driver

Steps to reproduce:
Build 2.6.0-test3-mm2, use the USB mouse as normal.
Comment 1 David Hollis 2003-08-13 08:22:52 UTC
Created attachment 645 [details]
dmesg output

Complete bootup dmesg output
Comment 2 David Hollis 2003-08-13 08:23:27 UTC
Created attachment 646 [details]
lsusb -v output

Output from lsusb
Comment 3 David Hollis 2003-08-13 08:24:01 UTC
Created attachment 647 [details]
kernel .config

My kernel .config
Comment 4 Greg Kroah-Hartman 2003-08-14 09:30:22 UTC
Do you have problems using 2.6.0-test3 (no -mm)?
Comment 5 David Hollis 2003-08-15 11:09:20 UTC
Just tested with stock 2.6.0-test3 (used the same .config) and the problem
persists.  I think my next test is to try with 2.6.0-test2-mm3 to see if it
occurs there and if so try to isolate which patch is the culprit.
Comment 6 David Hollis 2003-08-16 12:38:18 UTC
2.6.0-test2-mm3 also exhibits this problem so it seems it's something that was
added at that point.  It may be something that was added in one of Linus' BK
snapshots.  I will try and isolate further.
Comment 7 David Hollis 2003-08-19 17:45:56 UTC
Ok, took it down to stock 2.6.0-test2 and added the linus.patch from
2.6.0-test2-mm3.  Problem exists.  In fact, it's even a bit worse in that it
seems to kill the local ps2 mouse as well.  Next step is to try tracking down
what patch  in that set is causing the problems.
Comment 8 David Hollis 2003-08-24 06:26:28 UTC
Interestingly enough, 2.6.0-test4 seems to be working fine for me.  I'm
certainly keeping an eye on it, but I think this bug can be closed.

Note You need to log in before you can comment on or make changes to this bug.