Bug 10946 - 2.6.26-rc7: x86 build error
2.6.26-rc7: x86 build error
Status: CLOSED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: i386
All Linux
: P1 normal
Assigned To: platform_i386
:
: 10953 (view as bug list)
Depends on:
Blocks: 10492
  Show dependency treegraph
 
Reported: 2008-06-21 03:03 UTC by Adrian Bunk
Modified: 2008-06-22 10:39 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.26-rc7
Tree: Mainline
Regression: Yes


Attachments

Description Adrian Bunk 2008-06-21 03:03:29 UTC
Subject         : 2.6.26-rc7: x86 build error
Submitter       : Adrian Bunk <bunk@kernel.org>
References      : http://lkml.org/lkml/2008/6/21/31
Comment 1 Adrian Bunk 2008-06-21 03:03:50 UTC
Caused by:

commit d3942cff620bea073fc4e3c8ed878eb1e84615ce
Author: Bernhard Walle <bwalle@suse.de>
Date:   Sun Jun 8 16:16:07 2008 +0200

    x86: use BOOTMEM_EXCLUSIVE on 32-bit
    
    This patch uses the BOOTMEM_EXCLUSIVE for crashkernel reservation also for
    i386 and prints a error message on failure.
    
    The patch is still for 2.6.26 since it is only bug fixing. The unification
    of reserve_crashkernel() between i386 and x86_64 should be done for 2.6.27.
    
    Signed-off-by: Bernhard Walle <bwalle@suse.de>
    Signed-off-by: Ingo Molnar <mingo@elte.hu>
    Cc: <stable@kernel.org>

Comment 2 Adrian Bunk 2008-06-22 01:07:26 UTC
fixed by commit 71c2742f5e6348d76ee62085cf0a13e5eff0f00e
Comment 3 Adrian Bunk 2008-06-22 10:39:15 UTC
*** Bug 10953 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.