Bug 10944 - hrtimers and dyntick broken due tu lapic "not functionnal"
hrtimers and dyntick broken due tu lapic "not functionnal"
Status: CLOSED DOCUMENTED
Product: Timers
Classification: Unclassified
Component: Other
All Linux
: P1 low
Assigned To: john stultz
:
Depends on:
Blocks: 10492
  Show dependency treegraph
 
Reported: 2008-06-21 01:53 UTC by Christian Casteyde
Modified: 2008-06-21 11:49 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.26-rc6
Tree: Mainline
Regression: Yes


Attachments
2.6.25.6 dmesg log (17.85 KB, text/plain)
2008-06-21 01:54 UTC, Christian Casteyde
Details
2.6.26-rc6 dmesg log, with the lapic error (19.07 KB, text/plain)
2008-06-21 01:54 UTC, Christian Casteyde
Details

Description Christian Casteyde 2008-06-21 01:53:42 UTC
Latest working kernel version: 2.6.25.6
Earliest failing kernel version: 2.6.26-rc6 or less
Distribution: Bluewhite64 (64 bits Slackware)
Hardware Environment: Athlon 64 X2, 64 bits
Software Environment: Dynticks, hrtimers activated in config
Problem Description:
It may very well be only a trace or a warning on something that never worked, but since 2.6.26 I got the following warnings in dmesg:

Clockevents: could not switch to one-shot mode: lapic is not functional.
Could not switch to high resolution mode on CPU 0
Clockevents: could not switch to one-shot mode: lapic is not functional.
Could not switch to high resolution mode on CPU 1

followed by:
Clockevents: could not switch to one-shot mode:<6>Clockevents: could not switch to one-shot
 mode: lapic is not functional.
Could not switch to high resolution mode on CPU 0
 lapic is not functional.
Could not switch to high resolution mode on CPU 1

These logs were not present with 2.6.25. They seem to indicate that lapic code is not working anymore in 2.6.26. I do not see any problem otherwise in using the kernel.

I append full 2.6.25 and 2.6.26 dmesg logs for analysis.

Steps to reproduce:
Maybe this is platform specific. I can do test and patch if necessary.
Comment 1 Christian Casteyde 2008-06-21 01:54:24 UTC
Created attachment 16567 [details]
2.6.25.6 dmesg log

Lapic seems functionnal, as well as hrtimers on this version
Comment 2 Christian Casteyde 2008-06-21 01:54:47 UTC
Created attachment 16568 [details]
2.6.26-rc6 dmesg log, with the lapic error
Comment 3 Christian Casteyde 2008-06-21 01:56:03 UTC
btw, sorry, couldn't see that before because I was blocked by hardware reset sata_uli bug until yersterday and couldn't boot any 2.6.26 kernel
Comment 4 Thomas Gleixner 2008-06-21 11:37:49 UTC
Command line differs. the 2.6.26 one has: nmi_watchdog=1

nmi_watchdog=1 disables the local apic timers and therefor highres/nohz

Try to use nmi_watchdog=2 instead.

Thanks,
       tglx

Note You need to log in before you can comment on or make changes to this bug.