Bug 10941 - Microphone don't work on Acer Aspire 5720
Microphone don't work on Acer Aspire 5720
Status: RESOLVED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA)
All Linux
: P1 high
Assigned To: Takashi Iwai
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-19 22:44 UTC by Juan Pizarro
Modified: 2009-07-29 16:58 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.26-rc6
Tree: Mainline
Regression: No


Attachments
Change value "Internal Mic" to 0x1 (395 bytes, patch)
2008-06-19 22:48 UTC, Juan Pizarro
Details | Diff
alsa-info for Acer Aspire 5720G (14.92 KB, text/plain)
2008-07-03 04:14 UTC, Juan Pizarro
Details
config-2.6.30-gentoo-r1 (50.64 KB, text/plain)
2009-07-29 16:38 UTC, pi3mm3
Details

Description Juan Pizarro 2008-06-19 22:44:20 UTC
Latest working kernel version: 2.6.25.7
Earliest failing kernel version:
Distribution: Debian Lenny
Hardware Environment: ALC268 on Acer Aspire 5720
Software Environment:
Problem Description:
The Microphone don't work, but in the kernel version 2.6.25.7 work fine.

Solution:
In the file sound/pci/hda/patch_realtek.c the value of "Internal Mic" on static struct hda_input_mux alc268_acer_capture_source, should be 0x1, as before in the 2.6.25.x kernel.

that work for my notebook.
Comment 1 Juan Pizarro 2008-06-19 22:48:09 UTC
Created attachment 16557 [details]
Change value "Internal Mic" to 0x1
Comment 2 Andrew Morton 2008-07-01 14:19:44 UTC
Takashi, there's a patch here.

Juan, please submit patches via email, not via bugzilla.

Documentation/SubmitChecklist has details.

Suitable addressees are:

Andrew Morton <akpm@linux-foundation.org>
Takashi Iwai <tiwai@suse.de>
linux-kernel@vger.kernel.org

Thanks.
Comment 3 Takashi Iwai 2008-07-02 02:42:40 UTC
Then the pin mapping is different from other Acer laptops.  Your patch could break other machines, so it can't be applied as is.

For further analysis, please run alsa-info.sh with --no-upload option and attach the generated file here.  The script is found at
    http://www.alsa-proejct.org/alsa-info.sh

Thanks.
Comment 4 Juan Pizarro 2008-07-03 04:14:58 UTC
Created attachment 16715 [details]
alsa-info for Acer Aspire 5720G
Comment 5 Juan Pizarro 2008-10-09 16:30:13 UTC
Today i update the kernel code to git://git.kernel.org/pub/scm/linux/kernel/git/nigelc/tuxonice-head.git and the internal Mic from my Acer Aspire 5720 don't work.

The solution in the patch http://bugzilla.kernel.org/attachment.cgi?id=16557 work for this model.

In this moment exist in code the quirk for the aspire 5720z on
SND_PCI_QUIRK(0x1025, 0x011e, "Acer Aspire 5720z", ALC268_ACER)
the problem is, the device code "0x011e", is the same for my acer (exist other way to select betwen the models? ).

I don't know if the internal mic works on 5720z model.

Thanks.
Comment 6 pi3mm3 2009-07-29 16:36:57 UTC
Hi, I have the same problem with my Toshiba Portege m750.
The kernel version is 2.6.30-gentoo-r1 but even with the 2.6.29 version I wasn't able to use internal microphone.
The only thing I know is that the codec is "Realtek ALC268".
Comment 7 pi3mm3 2009-07-29 16:38:15 UTC
Created attachment 22524 [details]
config-2.6.30-gentoo-r1
Comment 8 pi3mm3 2009-07-29 16:40:43 UTC
This is the audio device:

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
	Subsystem: Toshiba America Info Systems Device 0001
	Flags: bus master, fast devsel, latency 0, IRQ 22
	Memory at ff9f8000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: [50] Power Management version 2
	Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Count=1/1 Enable-
	Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
	Capabilities: [100] Virtual Channel <?>
	Capabilities: [130] Root Complex Link <?>
	Kernel driver in use: HDA Intel
	Kernel modules: snd-hda-intel
Comment 9 Takashi Iwai 2009-07-29 16:57:42 UTC
A different machine, a different problem.  Please don't mix up, but open another bug report.

AFAIK, the problem of Acer Aspire 5720 was already fixed in the recent kernel.
Let's close now.

Note You need to log in before you can comment on or make changes to this bug.