Bug 10936 - fw-ohci: DV reception with dvgrab broken on VT630x in OHCI 1.0 mode
Summary: fw-ohci: DV reception with dvgrab broken on VT630x in OHCI 1.0 mode
Status: REJECTED UNREPRODUCIBLE
Alias: None
Product: Drivers
Classification: Unclassified
Component: IEEE1394 (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_ieee1394
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-06-18 13:47 UTC by Stefan Richter
Modified: 2008-12-20 03:59 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.22 and later
Tree: Mainline
Regression: ---


Attachments

Description Stefan Richter 2008-06-18 13:47:39 UTC
fw-ohci works incorrectly with VIA VT6306 and VT6307 if the controller EEPROM programs them into OHCI 1.0 mode (most or all VT6306, many but not all VT6307):

DV reception with dvgrab stops after a few frames (one or two frames fro example).  Curiously, reception with kino actually works.

Last tested:  libraw1394 from Dan Dennedy's git repo (revision f9681ff59da0acca543ad5d15213c6253114f0ce from April 30 plus "Plug dir leak and initialize data structs"), dvgrab 3.1, kino 1.3.0

See downstream report at https://bugzilla.redhat.com/show_bug.cgi?id=415841
Comment 1 Stefan Richter 2008-12-18 15:25:37 UTC
This bug does not occur anymore in 2.6.27.7-53.fc9.x86_64 and 2.6.28-rc7.

Why?
Comment 2 Stefan Richter 2008-12-20 03:59:46 UTC
2.6.27.10 was also tested successfully here.  I did not change the base configuration of the kernel (CONFIG_HZ_*, CONFIG_PREEMPT* etc.) nor the hardware since my last unsuccessful test.  I don't remember what the last known bad kernel was.

Note You need to log in before you can comment on or make changes to this bug.