Bug 109241 - Asus zenbook touchpad not recognized
Summary: Asus zenbook touchpad not recognized
Status: RESOLVED DUPLICATE of bug 108581
Alias: None
Product: Drivers
Classification: Unclassified
Component: Input Devices (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_input-devices
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-12-11 20:20 UTC by zenPhysics
Modified: 2015-12-11 23:44 UTC (History)
1 user (show)

See Also:
Kernel Version: 4.3.0-040300-generic
Tree: Mainline
Regression: No


Attachments

Description zenPhysics 2015-12-11 20:20:44 UTC
I have an Asus Zenbook UX305c with a fresh install of Ubuntu 15.10 and the touchpad is not recognized.  An external mouse works fine.  

Ubuntu 15.10 comes with the 4.2 kernel and that didn't work, so I upgraded to the 4.3 kernel and that doesn't work either.

cat /proc/bus/input/devices
produces:
I: Bus=0019 Vendor=0000 Product=0005 Version=0000
N: Name="Lid Switch"
P: Phys=PNP0C0D/button/input0
S: Sysfs=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/input/input0
U: Uniq=
H: Handlers=event0 
B: PROP=0
B: EV=21
B: SW=1

I: Bus=0019 Vendor=0000 Product=0003 Version=0000
N: Name="Sleep Button"
P: Phys=PNP0C0E/button/input0
S: Sysfs=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input1
U: Uniq=
H: Handlers=kbd event1 
B: PROP=0
B: EV=3
B: KEY=4000 0 0

I: Bus=0019 Vendor=0000 Product=0001 Version=0000
N: Name="Power Button"
P: Phys=LNXPWRBN/button/input0
S: Sysfs=/devices/LNXSYSTM:00/LNXPWRBN:00/input/input2
U: Uniq=
H: Handlers=kbd event2 
B: PROP=0
B: EV=3
B: KEY=10000000000000 0

I: Bus=0011 Vendor=0001 Product=0001 Version=ab41
N: Name="AT Translated Set 2 keyboard"
P: Phys=isa0060/serio0/input0
S: Sysfs=/devices/platform/i8042/serio0/input/input3
U: Uniq=
H: Handlers=sysrq kbd event3 leds 
B: PROP=0
B: EV=120013
B: KEY=402000000 3803078f800d001 feffffdfffefffff fffffffffffffffe
B: MSC=10
B: LED=7

I: Bus=0019 Vendor=0000 Product=0006 Version=0000
N: Name="Video Bus"
P: Phys=LNXVIDEO/video/input0
S: Sysfs=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input4
U: Uniq=
H: Handlers=kbd event4 
B: PROP=0
B: EV=3
B: KEY=3e000b00000000 0 0 0

I: Bus=0003 Vendor=064e Product=9700 Version=0101
N: Name="USB2.0 UVC HD Webcam"
P: Phys=usb-0000:00:14.0-5/button
S: Sysfs=/devices/pci0000:00/0000:00:14.0/usb1/1-5/1-5:1.0/input/input6
U: Uniq=
H: Handlers=kbd event6 
B: PROP=0
B: EV=3
B: KEY=100000 0 0 0

I: Bus=0019 Vendor=0000 Product=0000 Version=0000
N: Name="Asus WMI hotkeys"
P: Phys=asus-nb-wmi/input0
S: Sysfs=/devices/platform/asus-nb-wmi/input/input7
U: Uniq=
H: Handlers=rfkill kbd event7 
B: PROP=0
B: EV=100013
B: KEY=80000 0 800000000000 0 0 a1606f00900000 8200027800501000 e000000000000 0
B: MSC=10

I: Bus=0000 Vendor=0000 Product=0000 Version=0000
N: Name="HDA Intel PCH Headphone"
P: Phys=ALSA
S: Sysfs=/devices/pci0000:00/0000:00:1f.3/sound/card0/input8
U: Uniq=
H: Handlers=event8 
B: PROP=0
B: EV=21
B: SW=4

I: Bus=0000 Vendor=0000 Product=0000 Version=0000
N: Name="HDA Intel PCH HDMI/DP,pcm=3"
P: Phys=ALSA
S: Sysfs=/devices/pci0000:00/0000:00:1f.3/sound/card0/input9
U: Uniq=
H: Handlers=event9 
B: PROP=0
B: EV=21
B: SW=140

I: Bus=0000 Vendor=0000 Product=0000 Version=0000
N: Name="HDA Intel PCH HDMI/DP,pcm=7"
P: Phys=ALSA
S: Sysfs=/devices/pci0000:00/0000:00:1f.3/sound/card0/input10
U: Uniq=
H: Handlers=event10 
B: PROP=0
B: EV=21
B: SW=140

I: Bus=0000 Vendor=0000 Product=0000 Version=0000
N: Name="HDA Intel PCH HDMI/DP,pcm=8"
P: Phys=ALSA
S: Sysfs=/devices/pci0000:00/0000:00:1f.3/sound/card0/input11
U: Uniq=
H: Handlers=event11 
B: PROP=0
B: EV=21
B: SW=140

As you can see, there's no pointing device at all.

 dmesg | grep elan
produces:

[   10.041848] elan_i2c i2c-ELAN1000:00: writing cmd (0x0005) failed: -11
[   10.041851] elan_i2c i2c-ELAN1000:00: device reset failed: -11
[   10.041853] elan_i2c i2c-ELAN1000:00: device initialize failed: -11
[   10.077590] elan_i2c i2c-ELAN1000:00: writing cmd (0x0005) failed: -11
[   10.077593] elan_i2c i2c-ELAN1000:00: device reset failed: -11
[   10.077607] elan_i2c i2c-ELAN1000:00: device initialize failed: -11
[   10.113699] elan_i2c i2c-ELAN1000:00: writing cmd (0x0005) failed: -11
[   10.113702] elan_i2c i2c-ELAN1000:00: device reset failed: -11
[   10.113704] elan_i2c i2c-ELAN1000:00: device initialize failed: -11
[   10.156859] elan_i2c: probe of i2c-ELAN1000:00 failed with error -11

I've been on Google a lot the past couple days and it seems it's time to report this as a bug.
Comment 1 Dmitry Torokhov 2015-12-11 23:44:35 UTC

*** This bug has been marked as a duplicate of bug 108581 ***

Note You need to log in before you can comment on or make changes to this bug.