Bug 10912 - Regressions in the last kernels
Regressions in the last kernels
Status: CLOSED INVALID
Product: Platform Specific/Hardware
Classification: Unclassified
Component: i386
All Linux
: P1 normal
Assigned To: platform_i386
:
Depends on:
Blocks: 10492
  Show dependency treegraph
 
Reported: 2008-06-14 13:15 UTC by Rafael J. Wysocki
Modified: 2008-06-22 13:18 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.26-rc
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-06-14 13:15:32 UTC
Subject    : Regressions in the last kernels
Submitter  : "werner" <werner@sys-linux.yi.org>
Date       : 2008-06-14 18:26
References : http://marc.info/?l=linux-kernel&m=121346933911641&w=4

This entry is being used for tracking a regression from 2.6.25.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Arjan van de Ven 2008-06-14 14:19:29 UTC
This isn't a bug, but rather a bugfix.

A 486 cpu doesn't support PAE, and if you try to boot a PAE kernel it will panic.

So if you want to run on a 486... you cannot use PAE.. and thus not being able to select it in KConfig is a fix, not a regression.
Comment 2 Adrian Bunk 2008-06-14 14:20:31 UTC
Not a 2.6.26-rc regression - the dependency got added in 2.6.16.
Comment 3 Rafael J. Wysocki 2008-06-15 03:56:45 UTC
The other problem described in the original message seems to be a recent regression.
References : http://lkml.org/lkml/2008/6/15/35
Comment 4 Werner Landgraf 2008-06-16 19:17:16 UTC
W.r.t. the limitation to < 4 GB on i486 processors:    That treatment by the kernel of the limitation isn`t user-friendly.   The kernel people should invent something to resolve that problem,   that users with a 486 on one side and other users with >4 GB memory on the other side (and the distro-makers) don't need 2 different kernels.  For example, permit a configuration > 4 GB, what`s working on processors > i486 but when a runtime check shows that the computer is a i486 then it uses only <4 GB memory.

  Many people here still have 486 computers, others have newer computers with > 4 GB memory.  Some users have both an old and another new computer.  The kernel configured to >8 GB should see when it's running on a 486 computer and in this case automatically disconnect >4 GB memory, but when it's running on a newer computer with > 4 GB memory then > 4 GB should work correctly.

And, on my new computer with 4x 2GB memory = 8 GB, with that i486 kernel configured to 4 GB is working only 3,2 GB

root@werner:~# free
             total       used       free     shared    buffers     cached
Mem:       3100860    2932104     168756          0     295460     373064
-/+ buffers/cache:    2263580     837280
Swap:            0          0          0
Comment 5 H. Peter Anvin 2008-06-16 21:09:10 UTC
The internal differences between a PAE and a non-PAE kernel are dramatic.  Your assessmen that "The kernel configured to >8 GB should see when it's running on a 486 computer and in this case automatically disconnect >4 GB memory, but when it's running on a newer computer with > 4 GB memory then > 4 GB should work correctly." is ridiculous.

This can be done in the boot loader, however.  That's more of a packaging problem than a kernel problem.
Comment 6 Werner Landgraf 2008-06-22 13:13:41 UTC
OK when it's really too complicated to manage this put the two conditions together, then the only possibility is to have 2 different kernels.   It's not only a packaging problem, because a) on the litte install system and b) on the definitive installation during booting the person has to select the correct kernel.   My SYS distribution has the determined and consequent intention to bring forward the desktop Linux problem and to to be manageable for the most simple people ,  On the world average, 60% are analphabets, however, even these people have computers and use them for internet, video and such things; when/because Linux don't manage it to be more easy, they just use Windows.  For this, my distribution has a full-autimatic installation, nothing asking for a normal installation.  And for the most simple persons, no-computer-specialists, it's also too difficult to know what kernel they have to selsct/start for installation or use of the system.   This was the reasun why I requested to get the two possibilities in one kernel. However, when it's not possible, then we cannot do nothing.   At least, in the next years may desappear the last 486 so I hope the problem will be resolved.

In my new version SYS 0.23-rc4 of last night I put 2 kernels, beside of 2.6.26-rc7 also 2.6.24-rc6-git2 (the last one what dont have neither the edd problem nor the /dev/hdX-not-finding problem and configured for i586).  Unfortunately, 2 alternatives, that's still too complicated for users which barely can write them nome, and Windows starts for all computers in the same manner, however, because one cannot get everything in 1 kernel, currently one cannot do this more easy  :(   (until someone fork the kernel)

This reclamation, thus, can be labeled as no-bug or resolved.

W.Landgraf
Linux  SYS   0.23-rc4
mirror  ftp://ftp5.gwdg.de/pub/linux/install/sys/  
  
Comment 7 H. Peter Anvin 2008-06-22 13:17:47 UTC
This is nonsensical drivel.

Boot a 486 kernel during install (who cares if you don't use more than several gigabytes) and install the right kernel for the user.

It sounds like the real problem is that your distribution has an installer which is so inflexible that you can't deal with it.

Note You need to log in before you can comment on or make changes to this bug.