Bug 10905 - 2.6.26: x86/kernel/pci_dma.c: gfp |= __GFP_NORETRY ?
2.6.26: x86/kernel/pci_dma.c: gfp |= __GFP_NORETRY ?
Status: CLOSED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: i386
All Linux
: P1 normal
Assigned To: platform_i386
:
Depends on:
Blocks: 10492
  Show dependency treegraph
 
Reported: 2008-06-13 08:33 UTC by Rafael J. Wysocki
Modified: 2008-06-16 06:16 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.26-rc
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-06-13 08:33:11 UTC
Subject    : 2.6.26: x86/kernel/pci_dma.c: gfp |= __GFP_NORETRY ?
Submitter  : Miquel van Smoorenburg <miquels@cistron.nl>
Date       : 2008-05-21 13:30
References : http://lkml.org/lkml/2008/5/21/131
Handled-By : Glauber Costa <gcosta@redhat.com>
Handled-By : Andi Kleen <andi@firstfloor.org>
Handled-By : Miquel van Smoorenburg <mikevs@xs4all.net>
Patch      : http://lkml.org/lkml/2008/5/28/42

This entry is being used for tracking a regression from 2.6.25.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-06-13 08:35:23 UTC
Problem that may be related to this issue:
References : http://lkml.org/lkml/2008/6/12/121
Comment 2 Andi Kleen 2008-06-13 09:39:48 UTC
There's already a patch on l-k for fixing the wireless driver. The GFP_ATOMIC
issue makes it worse, but is not the underlying problem.



Note You need to log in before you can comment on or make changes to this bug.