Bug 10902 - "Write Protect is on" error
"Write Protect is on" error
Status: RESOLVED DUPLICATE of bug 10725
Product: Drivers
Classification: Unclassified
Component: USB
All Linux
: P1 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-12 22:40 UTC by Peter Teoh
Modified: 2008-06-22 23:37 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.26-rc5
Tree: Mainline
Regression: ---


Attachments

Description Peter Teoh 2008-06-12 22:40:24 UTC
Latest working kernel version:

Cannot remember.

Earliest failing kernel version:

The earliest is (cannot remember - questions is same as "latest working") possibly 2.6.26-rc2....but till now the 2.6.26-rc5 it is still not wroking for me.

Distribution:
Hardware Environment:
Software Environment:
Problem Description:
I first highlighted it here:

http://mail.nl.linux.org/kernelnewbies/2008-05/msg00092.html

Now on my 2.6.26-rc5 (laptop):

usb 5-7: new high speed USB device using ehci_hcd and address 3
usb 5-7: configuration #1 chosen from 1 choice
scsi2 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 3
usb-storage: waiting for device to settle before scanning
usb-storage: device scan complete
scsi 2:0:0:0: Direct-Access     WD       1600BEAExternal  1.02 PQ: 0 ANSI: 0
sd 2:0:0:0: [sdb] 312581808 512-byte hardware sectors (160042 MB)
sd 2:0:0:0: [sdb] Write Protect is on
sd 2:0:0:0: [sdb] Mode Sense: 12 a1 9e af
sd 2:0:0:0: [sdb] Assuming drive cache: write through
sd 2:0:0:0: [sdb] 312581808 512-byte hardware sectors (160042 MB)
sd 2:0:0:0: [sdb] Write Protect is on
sd 2:0:0:0: [sdb] Mode Sense: 12 a1 9e af
sd 2:0:0:0: [sdb] Assuming drive cache: write through
 sdb: sdb1 sdb2 sdb3 < sdb5 > sdb4
sd 2:0:0:0: [sdb] Attached SCSI disk
sd 2:0:0:0: Attached scsi generic sg2 type 0

It used to be "Write Protect is off" in the past, so that I was able to write to it.   Was it a bug in the kernel?

Thanks.

Steps to reproduce:
Comment 1 Adrian Bunk 2008-06-14 16:01:58 UTC
Does 2.6.25 work?
Comment 2 Peter Teoh 2008-06-15 09:19:44 UTC
Thank you Adrian, I just attempted reboot over the last few kernels I have in the past, and the result is that the problem started to arise in between the two version:

Jun 15 22:39:59 funnyman kernel: Linux version 2.6.26-rc2 (root@funnyman) (gcc version 4.1.2 20070626 (Red Hat 4.1.2-13)) #8 SMP Sun May 18 11:12:23 SGT 2008
Jun 15 22:40:00 funnyman kernel: sd 6:0:0:0: [sdc] 312581808 512-byte hardware sectors (160042 MB)
Jun 15 22:40:00 funnyman kernel: sd 6:0:0:0: [sdc] Write Protect is on
Jun 15 22:40:00 funnyman kernel: sd 6:0:0:0: [sdc] Assuming drive cache: write through
Jun 15 22:40:00 funnyman kernel: sd 6:0:0:0: [sdc] 312581808 512-byte hardware sectors (160042 MB)
Jun 15 22:40:00 funnyman kernel: sd 6:0:0:0: [sdc] Write Protect is on
Jun 15 22:40:00 funnyman kernel: sd 6:0:0:0: [sdc] Assuming drive cache: write through
Jun 15 22:40:00 funnyman kernel:  sdc: sdc1 sdc2 sdc3 < sdc5 > sdc4
Jun 15 22:40:00 funnyman kernel: sd 6:0:0:0: [sdc] Attached SCSI disk

And the earlier non-problematic kernel is 2.6.25-rc7.

Jun 15 22:44:07 funnyman kernel: Linux version 2.6.25-rc7 (root@funnyman) (gcc version 4.1.2 20070626 (Red Hat 4.1.2-13)) #3 SMP Thu Apr 3 18:46:16 SGT 2008
Jun 15 22:44:08 funnyman kernel: sd 6:0:0:0: [sdc] 312581808 512-byte hardware sectors (160042 MB)
Jun 15 22:44:08 funnyman kernel: sd 6:0:0:0: [sdc] Write Protect is off
Jun 15 22:44:08 funnyman kernel: sd 6:0:0:0: [sdc] Assuming drive cache: write through
Jun 15 22:44:08 funnyman kernel: sd 6:0:0:0: [sdc] 312581808 512-byte hardware sectors (160042 MB)
Jun 15 22:44:08 funnyman kernel: sd 6:0:0:0: [sdc] Write Protect is off

Comment 3 Peter Teoh 2008-06-16 04:59:20 UTC
Further testing revealed:

1.   v2.6.25-rc9--->Write Protect is Off.

2.   v2.6.26-rc1 ---> Write Protect is On.

I have yet to compile 2.6.25.

Thanks.
Comment 4 Adrian Bunk 2008-06-22 02:16:11 UTC
Peter, can you confirm that 2.6.25 works fine?

If yes, then this is a known regression.
Comment 5 Peter Teoh 2008-06-22 18:41:20 UTC
Sorry for the delay....yes it is working!!!

Linux version 2.6.25 (root@xentiger) (gcc version 4.1.2 20070925 (Red Hat 4.1.2-27)) #10 SMP Thu May 8 16:29:49 SGT 2008
Using APIC driver default
BIOS bug, APIC version is 0 for CPU#0! fixing up to 0x10. (tell your hw vendor)
BIOS bug, APIC version is 0 for CPU#0! fixing up to 0x10. (tell your hw vendor)

scsi 3:0:0:0: Direct-Access     WD       1600BEAExternal  1.02 PQ: 0 ANSI: 0
sd 3:0:0:0: [sdd] 312581808 512-byte hardware sectors (160042 MB)
sd 3:0:0:0: [sdd] Write Protect is off
sd 3:0:0:0: [sdd] Mode Sense: 00 00 00 00
sd 3:0:0:0: [sdd] Assuming drive cache: write through
sd 3:0:0:0: [sdd] 312581808 512-byte hardware sectors (160042 MB)
sd 3:0:0:0: [sdd] Write Protect is off
sd 3:0:0:0: [sdd] Mode Sense: 00 00 00 00
sd 3:0:0:0: [sdd] Assuming drive cache: write through
 sdd: sdd1 sdd2 sdd3 < sdd5 > sdd4
sd 3:0:0:0: [sdd] Attached SCSI disk

Thank you for the follow up Adrian.   
Comment 6 Adrian Bunk 2008-06-22 23:37:28 UTC

*** This bug has been marked as a duplicate of bug 10725 ***

Note You need to log in before you can comment on or make changes to this bug.