Bug 10864 - [regression][bisected] ~90,000 wakeups as of 2.6.26-rc3
Summary: [regression][bisected] ~90,000 wakeups as of 2.6.26-rc3
Status: CLOSED CODE_FIX
Alias: None
Product: Platform Specific/Hardware
Classification: Unclassified
Component: i386 (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: platform_i386
URL:
Keywords:
Depends on:
Blocks: 10492
  Show dependency tree
 
Reported: 2008-06-05 14:46 UTC by Rafael J. Wysocki
Modified: 2008-06-15 03:43 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.26-rc3
Tree: Mainline
Regression: Yes


Attachments
used .config for 2.6.26-rc6 (28.97 KB, application/octet-stream)
2008-06-13 23:19 UTC, Márton Németh
Details
full dmesg (30.23 KB, text/plain)
2008-06-13 23:20 UTC, Márton Németh
Details

Description Rafael J. Wysocki 2008-06-05 14:46:51 UTC
Subject    : [regression][bisected] ~90,000 wakeups as of 2.6.26-rc3
Submitter  : Németh Márton <nm127@freemail.hu>
Date       : 2008-06-03 5:18
References : http://marc.info/?l=linux-kernel&m=121247101601790&w=4

This entry is being used for tracking a regression from 2.6.25.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-06-05 14:48:08 UTC
Caused by:

commit 6e908947b4995bc0e551a8257c586d5c3e428201
Author: Ingo Molnar <mingo@elte.hu>
Date:   Fri Mar 21 14:32:36 2008 +0100

    x86: fix ioapic bug again
Comment 2 Márton Németh 2008-06-06 00:16:21 UTC
See also bug #9489.
Comment 3 Márton Németh 2008-06-06 13:27:16 UTC
Still see this behaviour as of 2.6.26-rc5.
Comment 4 Márton Németh 2008-06-13 23:19:53 UTC
Created attachment 16465 [details]
used .config for 2.6.26-rc6

In case of kernel version 2.6.26-rc6 there are only ~50 wakeups per second when the system is in idle. I think the problem is fixed at this version.
Comment 5 Márton Németh 2008-06-13 23:20:38 UTC
Created attachment 16466 [details]
full dmesg

Note You need to log in before you can comment on or make changes to this bug.