Bug 10861 - 2.6.26-rc4-git2 - long pause during boot
2.6.26-rc4-git2 - long pause during boot
Status: CLOSED INVALID
Product: IO/Storage
Classification: Unclassified
Component: SCSI
All Linux
: P1 normal
Assigned To: linux-scsi@vger.kernel.org
:
Depends on:
Blocks: 10492
  Show dependency treegraph
 
Reported: 2008-06-05 14:25 UTC by Rafael J. Wysocki
Modified: 2008-07-06 10:13 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.26-rc4-git2
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-06-05 14:25:43 UTC
Subject    : 2.6.26-rc4-git2 - long pause during boot
Submitter  : Chris Clayton <chris2553@googlemail.com>
Date       : 2008-06-01 4:15
References : http://marc.info/?l=linux-kernel&m=121229382917834&w=4

This entry is being used for tracking a regression from 2.6.25.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-06-05 14:26:37 UTC
Caused by:

commit b0ed43360fdca227048d88a08290365cb681c1a8
Author: Hannes Reinecke <hare@suse.de>
Date:   Tue Mar 18 14:32:28 2008 +0100

    [SCSI] add scsi_host and scsi_target to scsi_bus

    Signed-off-by: Hannes Reinecke <hare@suse.de>
    Signed-off-by: Kay Sievers <kay.sievers@vrfy.org>
    Signed-off-by: James Bottomley <James.Bottomley@HansenPartnership.com>
Comment 2 Anonymous Emailer 2008-06-05 14:51:41 UTC
Reply-To: James.Bottomley@HansenPartnership.com

On Thu, 2008-06-05 at 14:26 -0700, bugme-daemon@bugzilla.kernel.org
wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=10861
> 
> 
> 
> 
> 
> ------- Comment #1 from rjw@sisk.pl  2008-06-05 14:26 -------
> Caused by:
> 
> commit b0ed43360fdca227048d88a08290365cb681c1a8
> Author: Hannes Reinecke <hare@suse.de>
> Date:   Tue Mar 18 14:32:28 2008 +0100
> 
>     [SCSI] add scsi_host and scsi_target to scsi_bus
> 
>     Signed-off-by: Hannes Reinecke <hare@suse.de>
>     Signed-off-by: Kay Sievers <kay.sievers@vrfy.org>
>     Signed-off-by: James Bottomley <James.Bottomley@HansenPartnership.com>
 
This looks like another manifestation of the bus_uevent problem ... does
2.6.26-rc5 work OK?

James


Comment 3 Rafael J. Wysocki 2008-06-15 03:40:46 UTC
On Sunday, 15 of June 2008, Chris Clayton wrote:
> On Saturday 14 June 2008, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> >
> > The following bug entry is on the current list of known regressions
> > from 2.6.25.  Please verify if it still should be listed.
> >
> >
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=10861
> > Subject		: 2.6.26-rc4-git2 - long pause during boot
> > Submitter	: Chris Clayton <chris2553@googlemail.com>
> > Date		: 2008-06-01 4:15 (14 days old)
> > References	: http://marc.info/?l=linux-kernel&m=121229382917834&w=4
> 
> Well, we know how to create (and to avoid) the problem. Since the original patch 
> adversely affects existing user space, it could be argued that it is a 
> regression, but I see that there is a counter argument that the udev rule that 
> triggers the problem is quite simply a bad rule.
> 
> I'll leave to those more closely concerned that rule on that.

Comment 4 Kay Sievers 2008-06-22 12:31:56 UTC
The udev rules are "broken"/insufficient. If they can't be updated with a simple fix, the kernel should be compiled with CONFIG_SYSFS_DEPRECATED=y, which keeps old userspace happy, and should avoid this issue.
Comment 5 Chris Clayton 2008-06-25 01:26:53 UTC
Kay,

The udev rules that are broken/insufficient are part of the Slackware rules file that are present in the udev distribution (including that latest release, 124).
This is the patch that I am now applying when I build udev:

--- udev-122/etc/udev/slackware/udev.rules~     2008-06-14 05:45:11.000000000 +0000
+++ udev-122/etc/udev/slackware/udev.rules      2008-06-14 05:45:30.000000000 +0000
@@ -9,7 +9,7 @@

 # wait for sysfs
 ACTION=="add", DEVPATH=="/devices/*", ENV{PHYSDEVBUS}=="?*", WAIT_FOR_SYSFS="bus"
-ACTION=="add", SUBSYSTEM=="scsi", WAIT_FOR_SYSFS="ioerr_cnt"
+ACTION=="add", KERNEL=="[0-9]*:[0-9]*", SUBSYSTEM=="scsi", WAIT_FOR_SYSFS="ioerr_cnt"
 ACTION=="add", SUBSYSTEM=="net", WAIT_FOR_SYSFS="address"

 # all block devices

The new rule is taken from the udev rules file for Slackware 12.1
Comment 6 Rafael J. Wysocki 2008-07-02 09:18:40 UTC
On Monday, 30 of June 2008, Chris Clayton wrote:
> Rafael
> 
> On Sunday 29 June 2008, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> >
> > The following bug entry is on the current list of known regressions
> > from 2.6.25.  Please verify if it still should be listed.
> >
> 
> As far as I'm concerned, the entry can be closed.. As I've said before, the 
> patch did have a bad effect on existing user space, but, as Kay pointed out, 
> there's no getting away from the fact that the rule in Slackware rules 
> distributed with udev is a bad rule. the Slackware distribution does not 
> include that rule in its udev rules.
> 
> I assume Kay will fix it in the udev package.
> 
> >
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=10861
> > Subject		: 2.6.26-rc4-git2 - long pause during boot
> > Submitter	: Chris Clayton <chris2553@googlemail.com>
> > Date		: 2008-06-01 4:15 (29 days old)
> > References	: http://marc.info/?l=linux-kernel&m=121229382917834&w=4

Comment 7 Rafael J. Wysocki 2008-07-06 10:12:49 UTC
On Sunday, 6 of July 2008, James Bottomley wrote:
> On Sun, 2008-07-06 at 13:45 +0200, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.25.  Please verify if it still should be listed.
> 
> Erm, this isn't a kernel regression, it's a udev rule problem.
> 
> The rule has been identified and fixed; the reporter confirms it fixes
> the problem and the upstream maintainer of udev is putting out a release
> with it in ... what more exactly needs to be done?


Note You need to log in before you can comment on or make changes to this bug.