Bug 10855 - battery status info dissapears on MSI PR200
battery status info dissapears on MSI PR200
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: ACPI
Classification: Unclassified
Component: Power-Battery
All Linux
: P1 normal
Assigned To: acpi_power-battery
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-04 12:16 UTC by Leonid Podolny
Modified: 2009-03-13 17:15 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.26-rc4
Tree: Mainline
Regression: ---


Attachments
dmesg outpu (29.72 KB, text/plain)
2008-06-04 12:17 UTC, Leonid Podolny
Details
acpidump (152.83 KB, application/octet-stream)
2008-06-04 12:21 UTC, Leonid Podolny
Details
.config for a kernel (51.51 KB, application/octet-stream)
2008-06-04 12:37 UTC, Leonid Podolny
Details
dmidecode (8.04 KB, application/octet-stream)
2008-06-04 13:34 UTC, Leonid Podolny
Details
acpidump for MSI PR200WX-058EU (153.41 KB, application/octet-stream)
2009-03-10 03:19 UTC, Eddy Petrișor
Details
The config for the stock Debian Lenny 2.6.26-amd64 kernel (83.58 KB, application/octet-stream)
2009-03-10 03:21 UTC, Eddy Petrișor
Details

Description Leonid Podolny 2008-06-04 12:16:12 UTC
Latest working kernel version: None
Earliest failing kernel version: 
Distribution: Gentoo
Hardware Environment: MSI PR200
Software Environment: Gentoo 
Problem Description: 
My laptop stops recognizing both its battery and ac_adapter. With both the battery fully charged and AC plugged in:

looptop ~ # cat /proc/acpi/battery/BAT1/*
present:                 no
present:                 no
present:                 no
looptop ~ # cat /proc/acpi/ac_adapter/ADP1/*
state:                   off-line

I also stop seeing ACPI events in dmesg.
After a reboot, these files have sane values for a while, but then, in a matter of minutes, something happens and it reverts to the wrong situation as described above. dmesg displays some errors during boot-up, but I don't think it's relevant because the system runs fine for some time after. I'm attaching everything to the bug.
I have this laptop since about 2.6.22 and it was like that since the beginning. All the similar issues I see in Internet mention MSI laptops.
Comment 1 Leonid Podolny 2008-06-04 12:17:52 UTC
Created attachment 16395 [details]
dmesg outpu
Comment 2 Leonid Podolny 2008-06-04 12:21:05 UTC
Created attachment 16396 [details]
acpidump
Comment 3 Leonid Podolny 2008-06-04 12:37:16 UTC
Created attachment 16397 [details]
.config for a kernel
Comment 4 Leonid Podolny 2008-06-04 13:34:32 UTC
Created attachment 16398 [details]
dmidecode
Comment 5 Alexey Starikovskiy 2008-06-05 02:32:36 UTC
Please check if the bug 10699 is the same, e.g. if patches there help.
Comment 6 Leonid Podolny 2008-06-05 09:28:13 UTC
(In reply to comment #5)
> Please check if the bug 10699 is the same, e.g. if patches there help.
> 
Alexey,
I can't load the msi-laptop module, because it doesn't support the pr-200 model.

looptop ~ # modprobe msi-laptop
FATAL: Error inserting msi_laptop (/lib/modules/2.6.26-rc4/kernel/drivers/misc/msi-laptop.ko): No such device

As far as I understand, the bug 10699 is about msi-laptop module messing things up. Here, it's obviously not the case, as I can't load this module even if I want to.
Comment 7 Leonid Podolny 2008-06-05 09:33:02 UTC
Sorry, if I've been rude. 
Applied the patch, recompiled. No luck :(
Comment 8 Leonid Podolny 2008-06-15 11:10:39 UTC
This issue was solved after I upgraded to 2.6.26-rc6. What do I do, close the bug?
Comment 9 Alexey Starikovskiy 2008-06-15 14:34:46 UTC
thanks
Comment 10 Eddy Petrișor 2009-03-10 03:13:48 UTC
I have also a MSI PR200 laptop, but is probably different in some regards.

The model is: MSI PR200WX-058EU and I can't load the msi-laptop module, either.

heidi:/home/eddy/usr/src/osm/planet/git-planet-rom# modprobe msi-laptop 
FATAL: Error inserting msi_laptop (/lib/modules/2.6.26-1-amd64/kernel/drivers/misc/msi-laptop.ko): No such device


I am running the Debian Lenny 2.6.26-1-amd64 kernel. I have also issues related to suspend to ram, but I will take issues one at a time.


Please tell me what information you need me to supply.
Comment 11 Eddy Petrișor 2009-03-10 03:19:02 UTC
Created attachment 20480 [details]
acpidump for MSI PR200WX-058EU

This dump seems to be different from the one provided before by Leonid.
Comment 12 Eddy Petrișor 2009-03-10 03:21:33 UTC
Created attachment 20481 [details]
The config for the stock Debian Lenny 2.6.26-amd64 kernel
Comment 13 Leonid Podolny 2009-03-10 03:24:52 UTC
(In reply to comment #10)
> I have also a MSI PR200 laptop, but is probably different in some regards.
> 
> The model is: MSI PR200WX-058EU and I can't load the msi-laptop module, either.

Eddy,
First, msi-laptop has nothing to do with PR200, it's for some other older
versions. 
Second, this issue is currently being worke on in this bug: 
http://bugzilla.kernel.org/show_bug.cgi?id=12011. There are some patches in
that bug, I still hadn't time to check if any of those help. Anyway, I don't
think the patches there will work (or apply) with kernel as old as 2.6.26.

> 
> I am running the Debian Lenny 2.6.26-1-amd64 kernel. I have also issues related
> to suspend to ram, but I will take issues one at a time.
> 
> 
> Please tell me what information you need me to supply.
> 

Comment 14 Eddy Petrișor 2009-03-10 14:51:57 UTC
(In reply to comment #13)
> (In reply to comment #10)
> > I have also a MSI PR200 laptop, but is probably different in some regards.
> > 
> > The model is: MSI PR200WX-058EU and I can't load the msi-laptop module, either.
> 
> Eddy,
> First, msi-laptop has nothing to do with PR200, it's for some other older
> versions. 

OK, I saw that comment in comment #6 and I was under the impression that I needed msi-laptop on PR200.


> Second, this issue is currently being worke on in this bug: 
> http://bugzilla.kernel.org/show_bug.cgi?id=12011. There are some patches in
> that bug, I still hadn't time to check if any of those help. Anyway, I don't
> think the patches there will work (or apply) with kernel as old as 2.6.26.

I don't mind trying a patched linus git tree.

> > 
> > I am running the Debian Lenny 2.6.26-1-amd64 kernel. I have also issues related
> > to suspend to ram, but I will take issues one at a time.
> > 
> > 
> > Please tell me what information you need me to supply.
> > 
> 

Comment 15 Eddy Petrișor 2009-03-13 17:15:05 UTC
I compiled 2.6.29-rc7 and it correctly detects when on battery and when not.

Now I'll have to report just the sleep issue.

Note You need to log in before you can comment on or make changes to this bug.