Bug 10854 - CDROM is nor detected with libata and 3Ware.
CDROM is nor detected with libata and 3Ware.
Status: CLOSED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: i386
All Linux
: P1 normal
Assigned To: Alan
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-04 11:06 UTC by Frederic MASSOT
Modified: 2012-05-21 15:43 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.33
Tree: Mainline
Regression: Yes


Attachments
Config file for kernel 2.6.20 (31.97 KB, text/plain)
2008-06-04 11:08 UTC, Frederic MASSOT
Details
Config file for kernel 2.6.25 (34.51 KB, text/plain)
2008-06-04 11:08 UTC, Frederic MASSOT
Details
dmesg for kernel 2.6.20 (14.53 KB, text/plain)
2008-06-04 11:10 UTC, Frederic MASSOT
Details
dmesg for kernel 2.6.25 (14.40 KB, text/plain)
2008-06-04 11:10 UTC, Frederic MASSOT
Details
lspci -v output (4.93 KB, text/plain)
2008-06-04 11:12 UTC, Frederic MASSOT
Details
The lspci -vvxxx output (21.82 KB, text/plain)
2008-06-05 01:39 UTC, Frederic MASSOT
Details
dmesg for kernel 2.6.25 with CONFIG_IDE instead of CONFIG_ATA (15.14 KB, text/plain)
2008-06-05 03:39 UTC, Frederic MASSOT
Details
The iomem (1.28 KB, text/plain)
2008-06-10 08:42 UTC, Frederic MASSOT
Details
The ioports (1.28 KB, text/plain)
2008-06-10 08:43 UTC, Frederic MASSOT
Details
config file for kernel 2.6.32 without CONFIG_IDE and with CONFIG_ATA (42.71 KB, text/plain)
2010-02-19 17:58 UTC, Frederic MASSOT
Details
dmesg for kernel 2.6.32 without CONFIG_IDE and with CONFIG_ATA (19.83 KB, text/plain)
2010-02-19 17:58 UTC, Frederic MASSOT
Details
config file for kernel 2.6.32 without CONFIG_PATA_ACPI (42.72 KB, text/plain)
2010-02-24 08:44 UTC, Frederic MASSOT
Details
dmesg for kernel 2.6.32 without CONFIG_PATA_ACPI (19.18 KB, text/plain)
2010-02-24 08:45 UTC, Frederic MASSOT
Details
config file for kernel 2.6.33 with CONFIG_PATA_ACPI (44.63 KB, text/plain)
2010-02-25 12:03 UTC, Frederic MASSOT
Details
dmesg for kernel 2.6.33 with CONFIG_PATA_ACPI (19.76 KB, text/plain)
2010-02-25 12:04 UTC, Frederic MASSOT
Details

Description Frederic MASSOT 2008-06-04 11:06:33 UTC
Latest working kernel version: 2.6.20
Earliest failing kernel version: 2.6.25
Distribution: Debian Lenny
Hardware Environment: 
- CPU Intel Pentium 4 2.40GHz

- 00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller (rev 02) (prog-if 8a [Master SecP PriP])
	Subsystem: ASUSTeK Computer Inc. Device 80a6
	Flags: bus master, medium devsel, latency 0
	I/O ports at 01f0 [size=8]
	I/O ports at 03f4 [size=1]
	I/O ports at 0170 [size=8]
	I/O ports at 0374 [size=1]
	I/O ports at fc00 [size=16]
	Memory at 70100000 (32-bit, non-prefetchable) [disabled] [size=1K]

02:09.0 RAID bus controller: 3ware Inc 7xxx/8xxx-series PATA/SATA-RAID (rev 01)
	Subsystem: 3ware Inc 7xxx/8xxx-series PATA/SATA-RAID
	Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 21
	I/O ports at df80 [size=16]
	Memory at fe6fbc00 (32-bit, non-prefetchable) [size=16]
	Memory at fd800000 (32-bit, non-prefetchable) [size=8M]
	Expansion ROM at 70020000 [disabled] [size=64K]
	Capabilities: [40] Power Management version 1
	Kernel driver in use: 3w-xxxx

Problem Description:

Hi,

I have a server with a Intel 82801EB/ER (ICH5/ICH5R) chipset and 3ware 7506-4LP PATA RAID controller. The hard disks are connected to the RAID card, the cdrom is connected to the ICH5 IDE controller on the motherboard.

- With the kernel 2.6.20 and IDE support (CONFIG_IDE, CONFIG_BLK_DEV_IDECD) and 3Ware support (CONFIG_BLK_DEV_3W_XXXX_RAID) all works, cdrom is detected (/dev/hdd).

- With the kernel 2.6.25 without the IDE support, with libata support (CONFIG_ATA, CONFIG_ATA_PIIX) and 3ware support (CONFIG_BLK_DEV_3W_XXXX_RAID), RAID array is detected and the system boot without problems, but the cdrom is not detected.

Below the config files and dmesg for kernels 2.6.20 and 2.6.25.

Regards.
Comment 1 Frederic MASSOT 2008-06-04 11:08:03 UTC
Created attachment 16390 [details]
Config file for kernel 2.6.20
Comment 2 Frederic MASSOT 2008-06-04 11:08:24 UTC
Created attachment 16391 [details]
Config file for kernel 2.6.25
Comment 3 Frederic MASSOT 2008-06-04 11:10:21 UTC
Created attachment 16392 [details]
dmesg for kernel 2.6.20
Comment 4 Frederic MASSOT 2008-06-04 11:10:43 UTC
Created attachment 16393 [details]
dmesg for kernel 2.6.25
Comment 5 Frederic MASSOT 2008-06-04 11:12:26 UTC
Created attachment 16394 [details]
lspci -v output
Comment 6 Adrian Bunk 2008-06-04 11:17:30 UTC
You changed two things at the same time:
- kernel version
- CONFIG_IDE -> CONFIG_ATA

Does 2.6.25 with CONFIG_IDE instead of CONFIG_ATA work?
Comment 7 Anonymous Emailer 2008-06-04 12:30:11 UTC
Reply-To: akpm@linux-foundation.org


(switched to email.  Please respond via emailed reply-to-all, not via the
bugzilla web interface).

On Wed,  4 Jun 2008 11:06:34 -0700 (PDT) bugme-daemon@bugzilla.kernel.org wrote:

> http://bugzilla.kernel.org/show_bug.cgi?id=10854
> 
>            Summary: CDROM is nor detected with libata and 3Ware.
>            Product: IO/Storage
>            Version: 2.5
>      KernelVersion: 2.6.20 and 2.6.25
>           Platform: All
>         OS/Version: Linux
>               Tree: Mainline
>             Status: NEW
>           Severity: normal
>           Priority: P1
>          Component: Serial ATA
>         AssignedTo: jgarzik@pobox.com
>         ReportedBy: frederic@juliana-multimedia.com
> 
> 
> Latest working kernel version: 2.6.20
> Earliest failing kernel version: 2.6.25
> Distribution: Debian Lenny
> Hardware Environment: 
> - CPU Intel Pentium 4 2.40GHz
> 
> - 00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE
> Controller (rev 02) (prog-if 8a [Master SecP PriP])
>         Subsystem: ASUSTeK Computer Inc. Device 80a6
>         Flags: bus master, medium devsel, latency 0
>         I/O ports at 01f0 [size=8]
>         I/O ports at 03f4 [size=1]
>         I/O ports at 0170 [size=8]
>         I/O ports at 0374 [size=1]
>         I/O ports at fc00 [size=16]
>         Memory at 70100000 (32-bit, non-prefetchable) [disabled] [size=1K]
> 
> 02:09.0 RAID bus controller: 3ware Inc 7xxx/8xxx-series PATA/SATA-RAID (rev 01)
>         Subsystem: 3ware Inc 7xxx/8xxx-series PATA/SATA-RAID
>         Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 21
>         I/O ports at df80 [size=16]
>         Memory at fe6fbc00 (32-bit, non-prefetchable) [size=16]
>         Memory at fd800000 (32-bit, non-prefetchable) [size=8M]
>         Expansion ROM at 70020000 [disabled] [size=64K]
>         Capabilities: [40] Power Management version 1
>         Kernel driver in use: 3w-xxxx
> 
> Problem Description:
> 
> Hi,
> 
> I have a server with a Intel 82801EB/ER (ICH5/ICH5R) chipset and 3ware 7506-4LP
> PATA RAID controller. The hard disks are connected to the RAID card, the cdrom
> is connected to the ICH5 IDE controller on the motherboard.
> 
> - With the kernel 2.6.20 and IDE support (CONFIG_IDE, CONFIG_BLK_DEV_IDECD) and
> 3Ware support (CONFIG_BLK_DEV_3W_XXXX_RAID) all works, cdrom is detected
> (/dev/hdd).
> 
> - With the kernel 2.6.25 without the IDE support, with libata support
> (CONFIG_ATA, CONFIG_ATA_PIIX) and 3ware support (CONFIG_BLK_DEV_3W_XXXX_RAID),
> RAID array is detected and the system boot without problems, but the cdrom is
> not detected.
> 
> Below the config files and dmesg for kernels 2.6.20 and 2.6.25.
> 

Comment 8 Alan 2008-06-04 12:44:24 UTC
Please provide an lspci -vvxxx, I need to see the numeric PCI identifiers as your trace shows the libata driver is never being called at all from the PCI layer - which might be an id problem or might be something else.
Comment 9 Frederic MASSOT 2008-06-05 01:39:34 UTC
Created attachment 16401 [details]
The lspci -vvxxx output
Comment 10 Frederic MASSOT 2008-06-05 03:38:23 UTC
Hi,

Below the dmesg for kernel 2.6.25 with CONFIG_IDE instead of CONFIG_ATA, the cdrom is detected (/dev/hdd).

A few weeks ago I re-open the bug report 7997, there may be a relationship: http://bugzilla.kernel.org/show_bug.cgi?id=7997

Regards.
Comment 11 Frederic MASSOT 2008-06-05 03:39:25 UTC
Created attachment 16402 [details]
dmesg for kernel 2.6.25 with CONFIG_IDE instead of CONFIG_ATA
Comment 12 Alan 2008-06-10 08:12:59 UTC
Thanks.  Doesn't make any sense at all but is does confirm the PCI identifiers are present in the upstream kernel and the driver is not getting loaded on your system.
Comment 13 Alan 2008-06-10 08:15:21 UTC
recategorizing as this looks like a PCI layer bug not an ATA one. Most odd
Comment 14 Alan 2008-06-10 08:16:08 UTC
Can you attach /proc/ioports and /proc/iomem (from either kernel)
Comment 15 Frederic MASSOT 2008-06-10 08:42:36 UTC
Created attachment 16448 [details]
The iomem
Comment 16 Frederic MASSOT 2008-06-10 08:43:02 UTC
Created attachment 16449 [details]
The ioports
Comment 17 Tejun Heo 2008-06-11 01:25:51 UTC
Another bug reported by Frederic MASSOT regarding PIIX4.  The device ID is there and everything should work but it just never gets attached to the controller.  What the hell is going on?

http://bugzilla.kernel.org/show_bug.cgi?id=7997
Comment 18 Frederic MASSOT 2010-02-19 17:55:51 UTC
Hi,

I updated the server to the kernel 2.6.32 and the CDROM is still not detected, yet it is clearly visible in the BIOS.

In attachment the dmesg and config file.

Regards.
Comment 19 Frederic MASSOT 2010-02-19 17:58:19 UTC
Created attachment 25120 [details]
config file for kernel 2.6.32 without CONFIG_IDE and with CONFIG_ATA
Comment 20 Frederic MASSOT 2010-02-19 17:58:54 UTC
Created attachment 25121 [details]
dmesg for kernel 2.6.32 without CONFIG_IDE and with CONFIG_ATA
Comment 21 Tejun Heo 2010-02-23 02:02:20 UTC
Can you please turn off CONFIG_PATA_ACPI and try again?
Comment 22 Frederic MASSOT 2010-02-23 19:00:57 UTC
Hi,

I turn off CONFIG_PATA_ACPI and the CDROM is still not detected.

Regards.
Comment 23 Tejun Heo 2010-02-24 01:43:14 UTC
Can you please post kernel log w/o PATA_ACPI?
Comment 24 Frederic MASSOT 2010-02-24 08:44:09 UTC
Created attachment 25182 [details]
config file for kernel 2.6.32 without CONFIG_PATA_ACPI
Comment 25 Frederic MASSOT 2010-02-24 08:45:06 UTC
Created attachment 25183 [details]
dmesg for kernel 2.6.32 without CONFIG_PATA_ACPI
Comment 26 Tejun Heo 2010-02-25 01:45:07 UTC
Weird, the driver probe routine is not being called at all even though the driver registers the PCI ID and the device isn't attached to any other driver.  cc'ing Jesse Barnes.  Hi, Jesse, any ideas?
Comment 27 Frederic MASSOT 2010-02-25 12:01:29 UTC
Hi,

I test the new kernel 2.6.33 and the CDROM is alive.  :o)

Regards.
Comment 28 Frederic MASSOT 2010-02-25 12:03:05 UTC
Created attachment 25210 [details]
config file for kernel 2.6.33 with CONFIG_PATA_ACPI
Comment 29 Frederic MASSOT 2010-02-25 12:04:17 UTC
Created attachment 25211 [details]
dmesg for kernel 2.6.33 with CONFIG_PATA_ACPI

Note You need to log in before you can comment on or make changes to this bug.