Bug 10843 - Display artifacts on XOrg logout with PAT kernel and VESA framebuffer
Summary: Display artifacts on XOrg logout with PAT kernel and VESA framebuffer
Status: CLOSED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Console/Framebuffers (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Venkatesh Pallipadi
URL:
Keywords:
Depends on:
Blocks: 10492
  Show dependency tree
 
Reported: 2008-05-31 14:04 UTC by Frans Pop
Modified: 2008-11-19 04:51 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.26-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Frans Pop 2008-05-31 14:04:30 UTC
Latest working kernel version: 2.6.25
Earliest failing kernel version: 2.6.26-rc1
Distribution: Debian
Hardware Environment: Intel D945GCZ mainboard, Intel Pentium D 3.20GHz
Video:  00:02.0 VGA compatible controller [0300]:
        Intel Corporation 82945G/GZ Integrated Graphics Controller
        [8086:2772] (rev 02)
Software Environment: x86_64; Debian unstable

First reported: http://lkml.org/lkml/2008/5/2/406
(the error messages reported in that mail have already been resolved)

Problem Description:
When CONFIG_X86_PAT is enabled and the VESA framebuffer is used for the console by booting with "vga=791", logging out of XOrg will result in artifacts (sometimes a 2cm band, sometimes covering most of the display) being displayed for a short time.

Jesse Barnes has done some initial work on this issue, see:
http://groups.google.co.uk/group/fa.linux.kernel/msg/f5bf9294bf744612
(cannot find that message on lkml.org)
This patch proved insufficient to solve the issue.
Comment 1 Frans Pop 2008-05-31 14:08:38 UTC
The issue is still present in 2.6.26-rc4.
Comment 2 Rafael J. Wysocki 2008-06-08 09:53:59 UTC
Confirmed to be present in 2.6.26-rc5-git2.
References : http://lkml.org/lkml/2008/6/7/206
Comment 3 Rafael J. Wysocki 2008-06-14 15:05:55 UTC
On Saturday, 14 of June 2008, Frans Pop wrote:
> On Saturday 14 June 2008, Rafael J. Wysocki wrote:
> > The following bug entry is on the current list of known regressions
> > from 2.6.25.  Please verify if it still should be listed.
> >
> > Bug-Entry   : http://bugzilla.kernel.org/show_bug.cgi?id=10843
> > Subject     : Display artifacts on XOrg logout with PAT kernel and VESA
> >               framebuffer
> > Submitter   : Frans Pop <elendil@planet.nl> 
> > Date                : 2008-05-31 14:04 (15 days old)
> > References  : http://lkml.org/lkml/2008/6/7/206
> 
> Yes. See also: http://lkml.org/lkml/2008/6/13/159
Comment 4 Rafael J. Wysocki 2008-06-16 06:13:26 UTC
Regressions list annotation:
References : http://lkml.org/lkml/2008/6/15/119
Comment 5 Rafael J. Wysocki 2008-06-22 12:34:25 UTC
On Sunday, 22 of June 2008, you wrote:
> On Sunday 22 June 2008, Rafael J. Wysocki wrote:
> > The following bug entry is on the current list of known regressions
> > from 2.6.25.  Please verify if it still should be listed.
> >
> >
> > Bug-Entry   : http://bugzilla.kernel.org/show_bug.cgi?id=10843
> > Subject     : Display artifacts on XOrg logout with PAT kernel and VESA
> >               framebuffer
> > Submitter   : Frans Pop <elendil@planet.nl> 
> > Date                : 2008-05-31 14:04 (23 days old)
> > References  : http://lkml.org/lkml/2008/6/7/206
> >               http://lkml.org/lkml/2008/6/15/119
> 
> Yes.
Comment 6 Rafael J. Wysocki 2008-06-23 07:17:29 UTC
References : http://lkml.org/lkml/2008/6/23/160
Comment 7 Rafael J. Wysocki 2008-07-02 09:19:35 UTC
On Sunday, 29 of June 2008, Frans Pop wrote:
> On Sunday 29 June 2008, you wrote:
> > The following bug entry is on the current list of known regressions
> > from 2.6.25.  Please verify if it still should be listed.
> >
> > Bug-Entry   : http://bugzilla.kernel.org/show_bug.cgi?id=10843
> > Subject     : Display artifacts on XOrg logout with PAT kernel and VESA
> >               framebuffer
> 
> Yes.
Comment 8 Rafael J. Wysocki 2008-07-07 15:29:32 UTC
On Monday, 7 of July 2008, Frans Pop wrote:
> On Sunday 06 July 2008, you wrote:
> > The following bug entry is on the current list of known regressions
> > from 2.6.25.  Please verify if it still should be listed.
> >
> > Bug-Entry   : http://bugzilla.kernel.org/show_bug.cgi?id=10843
> > Subject     : Display artifacts on XOrg logout with PAT kernel and VESA
> >               framebuffer
> 
> Yes.
Comment 9 Frans Pop 2008-09-12 03:56:53 UTC
Confirmed present in 2.6.27-rc6.
References : http://lkml.org/lkml/2008/9/12/44

Trivially reproducible on 3 of my systems; see reference for details.
Comment 10 Frans Pop 2008-11-19 04:51:01 UTC
Fixed with:
commit 9542ada803198e6eba29d3289abb39ea82047b92
Author: Suresh Siddha <suresh.b.siddha@intel.com>
Date:   Wed Sep 24 08:53:33 2008 -0700

    x86: track memtype for RAM in page struct

Note You need to log in before you can comment on or make changes to this bug.