Bug 10828 - [2.6.25-git18 => 2.6.26-rc1-git1] Xorg crash with xf86MapVidMem error
[2.6.25-git18 => 2.6.26-rc1-git1] Xorg crash with xf86MapVidMem error
Status: CLOSED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: x86-64
All Linux
: P1 normal
Assigned To: platform_x86_64@kernel-bugs.osdl.org
:
Depends on:
Blocks: 10492 11808
  Show dependency treegraph
 
Reported: 2008-05-29 15:02 UTC by Rafael J. Wysocki
Modified: 2009-01-19 01:38 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.26-rc1-git1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-05-29 15:02:45 UTC
Subject    : [2.6.25-git18 => 2.6.26-rc1-git1] Xorg crash with xf86MapVidMem error
Submitter  : Rufus & Azrael <rufus-azrael@numericable.fr>
Date       : 2008-05-04 10:24
References : http://lkml.org/lkml/2008/5/4/37
Handled-By : Ingo Molnar <mingo@elte.hu>
Handled-By : "H. Peter Anvin" <hpa@zytor.com>
Handled-By : "Pallipadi, Venkatesh" <venkatesh.pallipadi@intel.com>
Patch      : http://lkml.org/lkml/2008/5/29/371

This entry is being used for tracking a regression from 2.6.25.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Ingo Molnar 2008-06-15 00:55:48 UTC
fixed by:

commit 282c454cd3a7041f59a37112bb2f82263bc38f6c
Author: Venki Pallipadi <venkatesh.pallipadi@intel.com>
Date:   Thu May 29 12:01:44 2008 -0700

    x86: fix Xorg crash with xf86MapVidMem error
Comment 2 Tomasz Chmielewski 2008-11-04 08:27:00 UTC
I see the exact same error with 2.6.28-rc3.

X works fine with 2.6.27.x kernels and the same xorg.conf setup.

This is where it breaks on 2.6.28-rc3 kernel:

(...)
(==) SIS(0): Write-combining range (0xf0000000,0x2000000)

Fatal server error:
xf86MapVidMem: Could not mmap framebuffer (0x00000000,0x2000) (Invalid argument)



2.6.27 would show:

(...)
(==) SIS(0): Write-combining range (0xf0000000,0x2000000)
(II) SIS(0): Setting custom mode 1280x1024 on CRT1
(II) SIS(0): Setting custom mode 1280x1024 on CRT2
(II) SIS(0): RENDER acceleration enabled
(...)


01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter (prog-if 00 [VGA controller])
        Subsystem: Fujitsu Siemens Computers Device 1046
        Flags: 66MHz, medium devsel
        BIST result: 00
        Memory at f0000000 (32-bit, prefetchable) [size=128M]
        Memory at fc100000 (32-bit, non-prefetchable) [size=128K]
        I/O ports at 2000 [size=128]
        Capabilities: [40] Power Management version 2
        Capabilities: [50] AGP version 3.0
        Kernel modules: sisfb
Comment 3 Thierry Vignaud 2009-01-06 06:59:36 UTC
Hum... This happens with SiS 651 on kernel-2.6.28 (tested with rc8, rc9 and final). 2.6.27 worked smoothly.
See bug #12372
Comment 4 Thierry Vignaud 2009-01-06 07:04:41 UTC
After reading bug ♯11958, I'm wondering if the fix for a machine hasn't broken another machine...

Note You need to log in before you can comment on or make changes to this bug.