Bug 10825 - appletouch after wakeup
appletouch after wakeup
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: USB
All Linux
: P1 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: 7216 10492
  Show dependency treegraph
 
Reported: 2008-05-29 14:49 UTC by Rafael J. Wysocki
Modified: 2008-10-07 12:26 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.26-rc3
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-05-29 14:49:15 UTC
Subject    : appletouch after wakeup
Submitter  : "Justin Mattock" <justinmattock@gmail.com>
Date       : 2008-05-27 3:29
References : http://marc.info/?l=linux-kernel&m=121185900618047&w=4
Handled-By : Oliver Neukum <oliver@neukum.org>

This entry is being used for tracking a regression from 2.6.25.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-06-05 14:01:39 UTC
Regressions list annotation:
References : http://lkml.org/lkml/2008/5/31/193
Comment 2 Justin P. Mattock 2008-06-05 14:14:56 UTC
On Thu, Jun 5, 2008 at 9:01 PM,  <bugme-daemon@bugzilla.kernel.org> wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=10825
>
>
>
>
>
> ------- Comment #1 from rjw@sisk.pl  2008-06-05 14:01 -------
> Regressions list annotation:
> References : http://lkml.org/lkml/2008/5/31/193
>
>
> --
> Configure bugmail: http://bugzilla.kernel.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug, or are watching someone who is.
>

After applying the patches from oliver appletouch seems to be
cooperating upon wakeup properly.
regards;

Comment 3 Anonymous Emailer 2008-06-05 14:21:15 UTC
Reply-To: oliver@neukum.org

Am Donnerstag 05 Juni 2008 23:14:56 schrieb bugme-daemon@bugzilla.kernel.org:
> http://bugzilla.kernel.org/show_bug.cgi?id=10825

OK, I need to respin this against the current kernel. Can somebody tell
me the vendor/product id of the affected device?

	Regards
		Oliver

Comment 4 Justin P. Mattock 2008-06-05 14:24:11 UTC
On Thu, Jun 5, 2008 at 9:21 PM,  <bugme-daemon@bugzilla.kernel.org> wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=10825
>
>
>
>
>
> ------- Comment #3 from anonymous@kernel-bugs.osdl.org  2008-06-05 14:21 -------
> Reply-To: oliver@neukum.org
>
> Am Donnerstag 05 Juni 2008 23:14:56 schrieb bugme-daemon@bugzilla.kernel.org:
>> http://bugzilla.kernel.org/show_bug.cgi?id=10825
>
> OK, I need to respin this against the current kernel. Can somebody tell
> me the vendor/product id of the affected device?
>
>        Regards
>                Oliver
>
>
> --
> Configure bugmail: http://bugzilla.kernel.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug, or are watching someone who is.
>

Here's what was put into quirks.c

{ USB_DEVICE(0x05ac, 0x021a), .driver_info = USB_QUIRK_RESET_RESUME },

hopefully this resolves the issue.
regards;
Comment 5 Rafael J. Wysocki 2008-06-13 09:23:04 UTC
Regressions list annotation:
References : http://marc.info/?l=linux-kernel&m=121308260006285&w=4
Comment 6 Justin P. Mattock 2008-06-13 13:11:59 UTC
On Fri, Jun 13, 2008 at 4:23 PM,  <bugme-daemon@bugzilla.kernel.org> wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=10825
>
>
>
>
>
> ------- Comment #5 from rjw@sisk.pl  2008-06-13 09:23 -------
> Regressions list annotation:
> References : http://marc.info/?l=linux-kernel&m=121308260006285&w=4
>
>
> --
> Configure bugmail: http://bugzilla.kernel.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug, or are watching someone who is.
>


I say it's fixed. fixed and even running better.
regards;
Comment 7 Rafael J. Wysocki 2008-06-13 13:14:05 UTC
OK, closing.
Comment 8 Justin P. Mattock 2008-06-13 13:16:50 UTC
On Fri, Jun 13, 2008 at 8:14 PM,  <bugme-daemon@bugzilla.kernel.org> wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=10825
>
>
> rjw@sisk.pl changed:
>
>           What    |Removed                     |Added
> ----------------------------------------------------------------------------
>             Status|NEW                         |CLOSED
>         Resolution|                            |CODE_FIX
>
>
>
>
> ------- Comment #7 from rjw@sisk.pl  2008-06-13 13:14 -------
> OK, closing.
>
>
> --
> Configure bugmail: http://bugzilla.kernel.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug, or are watching someone who is.
>

Cool.

Comment 9 Leif Ryge 2008-07-29 15:25:56 UTC
I am still experiencing this problem in 2.6.26 on an iBook G4 (PowerBook6,7) running Debian etch (stable) with this kernel:
http://kernel-archive.buildserver.net/debian-kernel/pool/main/l/linux-2.6/linux-2.6_2.6.26-1~experimental.1~snapshot.11914.dsc

During startup I see this:
[   25.384647] appletouch: Geyser mode initialized.
[   25.391105] input: appletouch as /class/input/input6
[   25.568732] usbcore: registered new interface driver appletouch
[   69.786672] appletouch: incomplete data package (first byte: 0, length: 17).

The trackpad works fine until the system is suspended. Upon waking up, it sometimes works but usually has become unusably erratic. Eventually it stops working altogether.

When I rmmod appletouch, dmesg shows:
[65783.588743] usbcore: deregistering interface driver appletouch

And then, when I modprobe appletouch again:
[65786.214204] appletouch: Could not do mode read request from device (Geyser Raw mode)
[65786.214263] appletouch: probe of 1-2:1.0 failed with error -5

At this point, it doesn't work again until the system is rebooted.
Comment 10 Justin P. Mattock 2008-07-29 15:43:03 UTC
On Tue, Jul 29, 2008 at 3:25 PM,  <bugme-daemon@bugzilla.kernel.org> wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=10825
>
>
> leif@synthesize.us changed:
>
>           What    |Removed                     |Added
> ----------------------------------------------------------------------------
>                 CC|                            |leif@synthesize.us
>
>
>
>
> ------- Comment #9 from leif@synthesize.us  2008-07-29 15:25 -------
> I am still experiencing this problem in 2.6.26 on an iBook G4 (PowerBook6,7)
> running Debian etch (stable) with this kernel:
> http://kernel-archive.buildserver.net/debian-kernel/pool/main/l/linux-2.6/linux-2.6_2.6.26-1~experimental.1~snapshot.11914.dsc
>
> During startup I see this:
> [   25.384647] appletouch: Geyser mode initialized.
> [   25.391105] input: appletouch as /class/input/input6
> [   25.568732] usbcore: registered new interface driver appletouch
> [   69.786672] appletouch: incomplete data package (first byte: 0, length: 17).
>
> The trackpad works fine until the system is suspended. Upon waking up, it
> sometimes works but usually has become unusably erratic. Eventually it stops
> working altogether.
>
> When I rmmod appletouch, dmesg shows:
> [65783.588743] usbcore: deregistering interface driver appletouch
>
> And then, when I modprobe appletouch again:
> [65786.214204] appletouch: Could not do mode read request from device (Geyser
> Raw mode)
> [65786.214263] appletouch: probe of 1-2:1.0 failed with error -5
>
> At this point, it doesn't work again until the system is rebooted.
>
>
> --
> Configure bugmail: http://bugzilla.kernel.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug, or are watching someone who is.
>

with 2.6.26 the appletouch wakeup
as it should. I loaded 2.6.27 but did'nt have a chance to
test suspend due to not installing fglrx(want a clean proprietary
free kernel) nor any other modules
that cause suspend to work. maybe adding the device info in quirks.c
is what needs to happen.


Comment 11 Anonymous Emailer 2008-07-30 00:16:38 UTC
Reply-To: oliver@neukum.org

Am Mittwoch 30 Juli 2008 00:25:57 schrieb bugme-daemon@bugzilla.kernel.org:
> http://bugzilla.kernel.org/show_bug.cgi?id=10825
> 
> 
> leif@synthesize.us changed:
> 
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
>                  CC|                            |leif@synthesize.us
> 
> 
> 
> 
> ------- Comment #9 from leif@synthesize.us  2008-07-29 15:25 -------
> I am still experiencing this problem in 2.6.26 on an iBook G4 (PowerBook6,7)
> running Debian etch (stable) with this kernel:
> http://kernel-archive.buildserver.net/debian-kernel/pool/main/l/linux-2.6/linux-2.6_2.6.26-1~experimental.1~snapshot.11914.dsc
> 
> During startup I see this:
> [   25.384647] appletouch: Geyser mode initialized.
> [   25.391105] input: appletouch as /class/input/input6
> [   25.568732] usbcore: registered new interface driver appletouch
> [   69.786672] appletouch: incomplete data package (first byte: 0, length: 17).
> 
> The trackpad works fine until the system is suspended. Upon waking up, it
> sometimes works but usually has become unusably erratic. Eventually it stops
> working altogether.
> 
> When I rmmod appletouch, dmesg shows:
> [65783.588743] usbcore: deregistering interface driver appletouch
> 
> And then, when I modprobe appletouch again:
> [65786.214204] appletouch: Could not do mode read request from device (Geyser
> Raw mode)
> [65786.214263] appletouch: probe of 1-2:1.0 failed with error -5
> 
> At this point, it doesn't work again until the system is rebooted.

Recompile your kernel with CONFIG_USB_DEBUG and provide full dmesg and lsusb -v

	Regards
		Oliver

Comment 12 Justin P. Mattock 2008-07-30 00:30:55 UTC
On Wed, Jul 30, 2008 at 12:16 AM,  <bugme-daemon@bugzilla.kernel.org> wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=10825
>
>
>
>
>
> ------- Comment #11 from anonymous@kernel-bugs.osdl.org  2008-07-30 00:16 -------
> Reply-To: oliver@neukum.org
>
> Am Mittwoch 30 Juli 2008 00:25:57 schrieb bugme-daemon@bugzilla.kernel.org:
>> http://bugzilla.kernel.org/show_bug.cgi?id=10825
>>
>>
>> leif@synthesize.us changed:
>>
>>            What    |Removed                     |Added
>> ----------------------------------------------------------------------------
>>                  CC|                            |leif@synthesize.us
>>
>>
>>
>>
>> ------- Comment #9 from leif@synthesize.us  2008-07-29 15:25 -------
>> I am still experiencing this problem in 2.6.26 on an iBook G4 (PowerBook6,7)
>> running Debian etch (stable) with this kernel:
>> http://kernel-archive.buildserver.net/debian-kernel/pool/main/l/linux-2.6/linux-2.6_2.6.26-1~experimental.1~snapshot.11914.dsc
>>
>> During startup I see this:
>> [   25.384647] appletouch: Geyser mode initialized.
>> [   25.391105] input: appletouch as /class/input/input6
>> [   25.568732] usbcore: registered new interface driver appletouch
>> [   69.786672] appletouch: incomplete data package (first byte: 0, length: 17).
>>
>> The trackpad works fine until the system is suspended. Upon waking up, it
>> sometimes works but usually has become unusably erratic. Eventually it stops
>> working altogether.
>>
>> When I rmmod appletouch, dmesg shows:
>> [65783.588743] usbcore: deregistering interface driver appletouch
>>
>> And then, when I modprobe appletouch again:
>> [65786.214204] appletouch: Could not do mode read request from device (Geyser
>> Raw mode)
>> [65786.214263] appletouch: probe of 1-2:1.0 failed with error -5
>>
>> At this point, it doesn't work again until the system is rebooted.
>
> Recompile your kernel with CONFIG_USB_DEBUG and provide full dmesg and lsusb -v
>
>        Regards
>                Oliver
>
>
> --
> Configure bugmail: http://bugzilla.kernel.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug, or are watching someone who is.
>

O.k. here you go


Note You need to log in before you can comment on or make changes to this bug.