Bug 10814 - 2.6.26-rc4: RIP __call_for_each_cic+0x20/0x50
2.6.26-rc4: RIP __call_for_each_cic+0x20/0x50
Status: CLOSED CODE_FIX
Product: IO/Storage
Classification: Unclassified
Component: Block Layer
All Linux
: P1 normal
Assigned To: Jens Axboe
:
Depends on:
Blocks: 10492
  Show dependency treegraph
 
Reported: 2008-05-28 15:44 UTC by Rafael J. Wysocki
Modified: 2008-05-30 02:28 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.26-rc4
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-05-28 15:44:16 UTC
Subject    : 2.6.26-rc4: RIP __call_for_each_cic+0x20/0x50
Submitter  : adobriyan@gmail.com
Date       : 2008-05-27 09:27
References : http://lkml.org/lkml/2008/5/27/11
Handled-By : Jens Axboe <jens.axboe@oracle.com>
Handled-By : "Paul E. McKenney" <paulmck@linux.vnet.ibm.com>
Patch      : http://lkml.org/lkml/2008/5/28/88

This entry is being used for tracking a regression from 2.6.25.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-05-28 15:44:55 UTC
Submitter : Alexey Dobriyan <adobriyan@gmail.com>
Comment 2 Rafael J. Wysocki 2008-05-29 13:32:16 UTC
Regressions list annotation:
Patch : http://lkml.org/lkml/2008/5/29/33
Comment 3 Jens Axboe 2008-05-30 02:28:17 UTC
The patch from comment #2 is for a different bug, mainly a theoretical one that (to my knowledge) no one has ever hit. The fix for the regression with preempt rcu is already merged.

It was this one:

http://git.kernel.dk/?p=linux-2.6-block.git;a=commit;h=d6de8be711b28049a5cb93c954722c311c7d3f7f

Note You need to log in before you can comment on or make changes to this bug.