Bug 10800 - Hard lock up after removing forcedeth module
Hard lock up after removing forcedeth module
Status: CLOSED DUPLICATE of bug 10487
Product: Drivers
Classification: Unclassified
Component: Network
All Linux
: P1 high
Assigned To: Jeff Garzik
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2008-05-26 11:42 UTC by Artem S. Tashkinov
Modified: 2009-04-21 18:21 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.26
Tree: Mainline
Regression: No


Attachments

Description Artem S. Tashkinov 2008-05-26 11:42:30 UTC
Latest working kernel version: haven't tested
Earliest failing kernel version: haven't tested
Distribution: Fedora 8
Hardware Environment: 00:07.0 Bridge: nVidia Corporation MCP61 Ethernet (rev a2), nVidia Corporation MCP61 based mobo
Software Environment: n/a
Problem Description: rmmod forcedeth causes instant hard lock-up

Steps to reproduce: boot the PC, put it to the software suspend, wake it up, # rmmod forcedeth.
Comment 1 Artem S. Tashkinov 2008-05-26 11:44:40 UTC
I'm using vanilla kernel.
Comment 2 Anonymous Emailer 2008-05-26 12:12:25 UTC
Reply-To: akpm@linux-foundation.org

On Mon, 26 May 2008 11:42:31 -0700 (PDT) bugme-daemon@bugzilla.kernel.org wrote:

> http://bugzilla.kernel.org/show_bug.cgi?id=10800
> 
>            Summary: Hard lock up after removing forcedeth module
>            Product: Networking
>            Version: 2.5
>      KernelVersion: 2.6.25.4
>           Platform: All
>         OS/Version: Linux
>               Tree: Mainline
>             Status: NEW
>           Severity: high
>           Priority: P1
>          Component: Other
>         AssignedTo: acme@ghostprotocols.net
>         ReportedBy: t.artem@mailcity.com
> 
> 
> Latest working kernel version: haven't tested
> Earliest failing kernel version: haven't tested
> Distribution: Fedora 8
> Hardware Environment: 00:07.0 Bridge: nVidia Corporation MCP61 Ethernet (rev
> a2), nVidia Corporation MCP61 based mobo
> Software Environment: n/a
> Problem Description: rmmod forcedeth causes instant hard lock-up
> 
> Steps to reproduce: boot the PC, put it to the software suspend, wake it up, #
> rmmod forcedeth.
> 

Is the suspend/resume operation a required step to make this occur?  I
assume so.

Do you know if this is a regression?  In other words, did any earlier
kernel perform these steps without crashing the machine?

Thanks.

Comment 3 Artem S. Tashkinov 2008-05-27 11:17:38 UTC
> Is the suspend/resume operation a required step to make this occur?

Absolutely. Without suspend I can modprobe; rmmod great many times without any problems.

> Do you know if this is a regression?  In other words, did any earlier
kernel perform these steps without crashing the machine?

I have never tried to do that before, so no I don't know if it's a regression.

A few notes: a hard lock up happens no matter if X server has been started or not; it happens without any proprietary modules loaded (so the kernel is not tainted); after '# rmmod forcedeth' in the first text VT - I get no output - no kernel panic, no oops, just a complete and immediate system lock up.
Comment 4 Artem S. Tashkinov 2008-06-01 02:36:58 UTC
The worst of all is that after computer wake up, the network interface connected to this NIC doesn't work at all. ethtool says that cable is not connected.

After reboot everything works fine.
Comment 5 Artem S. Tashkinov 2008-07-18 12:05:34 UTC
2.6.26 - no changes.
Comment 6 Ayaz Abdulla 2009-04-21 16:42:46 UTC
Please try the latest forcedeth driver.

I had put in a patch to fix MSI issue after suspend.

See bug: http://bugzilla.kernel.org/show_bug.cgi?id=10487
Comment 7 Artem S. Tashkinov 2009-04-21 17:03:08 UTC
Definitely a dupe.

*** This bug has been marked as a duplicate of bug 10487 ***

Note You need to log in before you can comment on or make changes to this bug.