Bug 10796 - PS/2 keyboard becomes dead/non-responsive on boot with kernel > 2.6.24.3-50.fc8
PS/2 keyboard becomes dead/non-responsive on boot with kernel > 2.6.24.3-50.fc8
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: IEEE1394
All Linux
: P1 high
Assigned To: Stefan Richter
:
Depends on:
Blocks: 10492
  Show dependency treegraph
 
Reported: 2008-05-25 12:36 UTC by J
Modified: 2008-06-21 01:42 UTC (History)
3 users (show)

See Also:
Kernel Version: > 2.6.24.3-50.fc8
Tree: Fedora
Regression: Yes


Attachments
Diff -y on config-2.4.26.7 and config-2.4.26.7-92.fc8 (164.10 KB, application/octet-stream)
2008-05-27 06:16 UTC, J
Details

Description J 2008-05-25 12:36:01 UTC
Latest working kernel version: 2.6.24.3-50.fc8
Earliest failing kernel version: > 2.6.24.3-50.fc8
Distribution: FEDORA
Hardware Environment: x86_64 two xeon 3.0 GHz CPU/ ASUS ncch-dl MB
Software Environment: Fedora 8
Problem Description: During boot the keyboard becomes unresponsive/dead.  The keyboard stops working after a finite period of time and can be monitored by pressing the caps lock on and off until the light no longer responds.

Steps to reproduce:
Install kernel > 2.6.24.3-50.fc8 using YUM boot to that kernel keybaord stops working, get second PC ssh into first pc shutdown first pc.

I've also posted this to Fedora bugzilla: https://bugzilla.redhat.com/show_bug.cgi?id=446763

I'm currently going back to a pure kernel.org kernel 2.6.24.3 installing and then will try patching until it becomes faulty (if it becomes faulty).  I've tried booting into kernel 2.6.25 and that works fine.
Comment 1 J 2008-05-25 15:58:49 UTC
Building kernel 2.6.24.4 directly from the .kernel.org website using the make instructions from the readme and the config info inherited from 2.4.6.24.3-50 - not altering anything in the menuconfig stage, gave me a kernel which I could boot with no keyboard issues and make nvidia drivers for - a usable kernel.

I will try kernel 2.4.6.24.7 from the website and if that works it must be down to a fedora related patch/mod.
Comment 2 J 2008-05-26 03:52:17 UTC
I have now built the 2.6.24.7 kernel and booted successfully. This would therefore point the problem at one of the fedora patches added to the 2.6.24.7 kernel.  I'll now go through their patches and remove them from the rpm src until I can find the one at fault.
Comment 3 Roland Kletzing 2008-05-26 14:37:41 UTC
nice find ;)

if this turns out to be a fedora issue - can't this be closed then ?
Comment 4 J 2008-05-27 02:48:25 UTC
I would suspect the answer is yes. Although I've found that you can't do make binrpm-pkg using the O option to specify an alternate path. If you do it fails to find the .config file.  Instead you need to do make then make binrpm-pkg in the same src directory.  It is also annoying that make install and make install_modules will create the *img file but the rpm doesn't.

I don't suppose any of these comments really need to be in this bug?

Before closing the bug would it be ok if I try and post the patch which is causing the fedora issue?  There are 160 patches it may take me a while. Plus following the changelog comments makes it no easier a task.
Comment 5 J 2008-05-27 06:14:20 UTC
Before starting out on the patches I thought it would be worth comparing the 2.6.24.7 and 2.6.24.7-92 config files. (attached).

Comparing this with the changelogs could activating I2C_PIIX4 be the culprit?
Kernel.org                                         Fedora
# CONFIG_I2C_PIIX4 is not set                      | CONFIG_I2C_PIIX4=m

I'll try the stock kernel with this turned on to see.
Comment 6 J 2008-05-27 06:16:19 UTC
Created attachment 16293 [details]
Diff -y on config-2.4.26.7 and config-2.4.26.7-92.fc8

Diff command run on the two config files used to make the kernel. The non-fedora one works while the fedora one kills the keyboard at boot.
Comment 7 Naveed Hasan 2008-05-27 13:18:35 UTC
I am having a similar issue, however I cannot even Ctrl-Alt-Del as the PS/2
keyboard is completely unresponsive after "Enabling /etc/fstab swaps: OK" and
can only hard reset the box. See https://bugzilla.redhat.com/show_bug.cgi?id=444694
Comment 8 J 2008-06-17 15:18:06 UTC
This may have been resolved.

A patch has been put forward by the redhat/fedora guys it is suspected that the git firewire modules are to blame when coupled to a ALi firewire/usb combi card.

adding
blacklist firewire-ohci
to /etc/modprobe.conf/blacklist
allows the stock fedora kernel to boot. Likewise compiling the stock fedora kernel without the git firewire patches allows for a stable kernel.

I think you can now close this.
Comment 9 Stefan Richter 2008-06-18 14:44:45 UTC
It is a regression in mainline too, post 2.6.25.
Fix posted and verified with a newly acquired ALi based card: http://marc.info/?l=linux1394-devel&m=121380606431945
I will try to get it into mainline by the end of this week.
Comment 10 Stefan Richter 2008-06-18 14:46:45 UTC
Related: bug 10935 "fw-ohci: ALi M52xx unsupported"
Comment 11 Stefan Richter 2008-06-18 14:47:28 UTC
bug 10936 actually
Comment 12 Stefan Richter 2008-06-18 14:48:15 UTC
#-| no, 10935
Comment 13 Stefan Richter 2008-06-21 01:42:40 UTC
Fix merged into upstream 2.6.26-rc7.

J and Naveed, thanks for locating the source of the bug.  Fixing it was easy after you did all the debugging work.

Note You need to log in before you can comment on or make changes to this bug.