Bug 10794 - mips: CONF_CM_DEFAULT build error
Summary: mips: CONF_CM_DEFAULT build error
Status: CLOSED CODE_FIX
Alias: None
Product: Platform Specific/Hardware
Classification: Unclassified
Component: MIPS (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: ralf
URL:
Keywords:
Depends on:
Blocks: 10492
  Show dependency tree
 
Reported: 2008-05-25 10:11 UTC by Adrian Bunk
Modified: 2008-06-16 13:54 UTC (History)
0 users

See Also:
Kernel Version: 2.6.26-rc3-git
Tree: Mainline
Regression: Yes


Attachments

Description Adrian Bunk 2008-05-25 10:11:48 UTC
Subject         : mips: CONF_CM_DEFAULT build error
Submitter       : Adrian Bunk <adrian.bunk@movial.fi>
References      : http://lkml.org/lkml/2008/5/25/168
Comment 1 Adrian Bunk 2008-05-25 10:14:43 UTC
Caused by:

commit 351336929ccf222ae38ff0cb7a8dd5fd5c6236a0
Author: Chris Dearman <chris@mips.com>
Date:   Wed Sep 19 00:58:24 2007 +0100

    [MIPS] Allow setting of the cache attribute at run time.
    
    Slightly tacky, but there is a precedent in the sparc archirecture code.
    
    Signed-off-by: Chris Dearman <chris@mips.com>
    Signed-off-by: Atsushi Nemoto <anemo@mba.ocn.ne.jp>
    Signed-off-by: Ralf Baechle <ralf@linux-mips.org>
Comment 2 Adrian Bunk 2008-06-03 05:40:13 UTC
Handled-by: Atsushi Nemoto <anemo@mba.ocn.ne.jp>
Patch: http://lkml.org/lkml/2008/6/1/125
Comment 3 Rafael J. Wysocki 2008-06-13 14:34:23 UTC
Problem has been confirmed to be present in 2.6.26-rc5-git2.
References : http://lkml.org/lkml/2008/6/11/295
Comment 4 Rafael J. Wysocki 2008-06-14 15:03:39 UTC
On Saturday, 14 of June 2008, Adrian Bunk wrote:
> On Sat, Jun 14, 2008 at 10:12:03PM +0200, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.25.  Please verify if it still should be listed.
> 
> yes
Comment 5 Adrian Bunk 2008-06-16 13:54:44 UTC
fixed by commit 89052bd7b393434f7c573ce6a3b88c5f143586d2

Note You need to log in before you can comment on or make changes to this bug.