Bug 10765 - iwl3945/mac80211: association times out since 2.6.26-rc1
iwl3945/mac80211: association times out since 2.6.26-rc1
Status: CLOSED CODE_FIX
Product: Networking
Classification: Unclassified
Component: Wireless
All Linux
: P1 normal
Assigned To: networking_wireless@kernel-bugs.osdl.org
:
: 10763 (view as bug list)
Depends on:
Blocks: 10492
  Show dependency treegraph
 
Reported: 2008-05-20 22:46 UTC by Michael S. Tsirkin
Modified: 2008-06-10 12:09 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.26-rc1
Tree: Mainline
Regression: Yes


Attachments
cleaned version of wpa_supplicant (identity and password left out) (233 bytes, text/plain)
2008-05-23 07:08 UTC, Michael S. Tsirkin
Details
log from running wpa_supplicant -ddd with supplied config (16.07 KB, text/x-log)
2008-05-23 07:12 UTC, Michael S. Tsirkin
Details
dmesg output (87.38 KB, text/x-log)
2008-05-23 07:27 UTC, Michael S. Tsirkin
Details
my kernel .config file (62.71 KB, text/plain)
2008-05-24 11:23 UTC, Michael S. Tsirkin
Details
dmesg with debugging turned on (2.75 KB, text/plain)
2008-05-24 23:31 UTC, Michael S. Tsirkin
Details

Description Michael S. Tsirkin 2008-05-20 22:46:17 UTC
Latest working kernel version: 2.6.25
Earliest failing kernel version: 2.6.25-rc1
Distribution: ubuntu dapper, mainline kernel from kernel.org
Hardware Environment: thinkpad T60p, wireless card iwl3945
Software Environment: wpa_supplicant version 0.5.4
Problem Description:


In all  of 2.6.26-rc1, rc2 and rc3, my iwl3945 wifi card can't associate with my
+access point.
It does associate in 2.6.25.

under 2.6.-26-rc[1,2,3] wpa_supplicant reports:

        Trying to associate with 00:16:e3:ef:5d:f0 (SSID='' freq=0 MHz)
        Authentication with 00:00:00:00:00:00 timed out.

where under 2.6.25 I was associating with
        Trying to associate with 00:16:e3:ef:5d:f0 (SSID='SIEMENS-EF5DF0' freq=2437
+MHz)
        Associated with 00:16:e3:ef:5d:f0
        WPA: Key negotiation completed with 00:16:e3:ef:5d:f0 [PTK=CCMP GTK=CCMP]
I tried bisecting, and I got as far as
git-bisect good 4b119e21d0c66c22e8ca03df05d9de623d0eb50f
git-bisect bad 96d510566e4908f77f03ff1436c78ae7162a17d0

but a point between these 2 commits gets me iwl driver that hangs kernel
when it's loaded, so I gave up on bisecting at this point.
Still this leaves us with 91 candidates that might be introducing the regression
(get their list with git log
 4b119e21d0c66c22e8ca03df05d9de623d0eb50f..96d510566e4908f77f03ff1436c78ae7162a17d0)

Additional info:

I get this in dmesg

[   99.153033] ACPI: PCI Interrupt 0000:03:00.0[A] -> GSI 17 (level, low) -> IRQ 17
[   99.204031] PM: Adding info for No Bus:iwl-phy1:radio
[   99.204031] Registered led device: iwl-phy1:radio
[   99.204031] PM: Adding info for No Bus:iwl-phy1:assoc
[   99.204031] Registered led device: iwl-phy1:assoc
[   99.204031] PM: Adding info for No Bus:iwl-phy1:RX
[   99.204031] Registered led device: iwl-phy1:RX
[   99.204031] PM: Adding info for No Bus:iwl-phy1:TX
[   99.204031] Registered led device: iwl-phy1:TX
[   99.220405] ADDRCONF(NETDEV_UP): wlan0: link is not ready

and even though the led now lights up, there's no association.

portions of .config: 2.6.26-rc3:

CONFIG_IWLWIFI=m
CONFIG_IWLCORE=m
# CONFIG_IWLWIFI_LEDS is not set
CONFIG_IWLWIFI_RFKILL=y
# CONFIG_IWL4965 is not set
CONFIG_IWL3945=m
CONFIG_IWL3945_SPECTRUM_MEASUREMENT=y
CONFIG_IWL3945_LEDS=y
CONFIG_IWL3945_DEBUG=y

2.6.25:
# CONFIG_IWL4965 is not set
CONFIG_IWL3945=m
CONFIG_IWL3945_QOS=y
CONFIG_IWL3945_SPECTRUM_MEASUREMENT=y
CONFIG_IWL3945_DEBUG=y



Steps to reproduce:
 run wpa_cli, look at output
Comment 1 Zhu Yi 2008-05-21 00:00:23 UTC
Please attach your wpa_supplicant.conf. The output of "wpa_supplicant -ddd" and dmesg in the failed case.
Comment 2 Adrian Bunk 2008-05-21 05:09:53 UTC
*** Bug 10763 has been marked as a duplicate of this bug. ***
Comment 3 Rafael J. Wysocki 2008-05-21 05:12:46 UTC
This entry is being used for tracking a regression from 2.6.25.  Please don't
close it until the problem is fixed in the mainline.

Handled-By : Zhu Yi <yi.zhu@intel.com>
Comment 4 Michael S. Tsirkin 2008-05-23 07:08:27 UTC
Created attachment 16256 [details]
cleaned version of wpa_supplicant (identity and password left out)
Comment 5 Michael S. Tsirkin 2008-05-23 07:12:48 UTC
Created attachment 16257 [details]
log from running wpa_supplicant -ddd with supplied config 

some identity data cleaned out
Comment 6 Michael S. Tsirkin 2008-05-23 07:27:25 UTC
Created attachment 16258 [details]
dmesg output

I note that there are no messages from the card after
ADDRCONF(NETDEV_UP): wlan0: link is not ready
Comment 7 Michael S. Tsirkin 2008-05-24 11:23:38 UTC
Created attachment 16268 [details]
my kernel .config file
Comment 8 Johannes Berg 2008-05-24 12:58:03 UTC
Can you enable mac80211 debugging? maybe CONFIG_MAC80211_VERBOSE_DEBUG too.

The bisect is pretty useless since all the interesting wireless commits are in that range.
Comment 9 Michael S. Tsirkin 2008-05-24 14:58:31 UTC
It's not easy to do anything about it though because I get kernel hangs on commits in between. I guess I could try bisecting the hangs but seems
to be a kind of waste because mainline does not hang.

OK, I will enable CONFIG_MAC80211_VERBOSE_DEBUG. 
When you say enable debugging, do you mean CONFIG_MAC80211_DEBUG?
Comment 10 Michael S. Tsirkin 2008-05-24 23:31:37 UTC
Created attachment 16273 [details]
dmesg with debugging turned on

I modified .config in this way:

CONFIG_MAC80211_DEBUGFS=y
# CONFIG_MAC80211_DEBUG_PACKET_ALIGNMENT is not set
CONFIG_MAC80211_DEBUG=y
# CONFIG_MAC80211_HT_DEBUG is not set
CONFIG_MAC80211_VERBOSE_DEBUG=y
# CONFIG_MAC80211_DEBUG_COUNTERS is not set
# CONFIG_MAC80211_IBSS_DEBUG is not set
# CONFIG_MAC80211_VERBOSE_PS_DEBUG is not set

dmesg attached, but does not seem very informative.
Are there some module flags  I should set as well?
Comment 11 Johannes Berg 2008-05-25 01:32:29 UTC
Tomas is probably right then, try this patch: http://article.gmane.org/gmane.linux.kernel.wireless.general/15177
Comment 12 Michael S. Tsirkin 2008-05-25 22:48:05 UTC
I can confirm that the patch in comment 11 fixes the regression for me.
Comment 13 Rafael J. Wysocki 2008-05-26 08:06:15 UTC
Regressions list annotation:
Handled-By : Johannes Berg <johannes@sipsolutions.net>
Patch : http://article.gmane.org/gmane.linux.kernel.wireless.general/15177
Comment 14 Michael S. Tsirkin 2008-06-10 12:09:39 UTC
I have verified that this bug is fixed
in 2.6.26-rc5

Note You need to log in before you can comment on or make changes to this bug.