Bug 10764 - some serial configurations are now broken
some serial configurations are now broken
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Serial
All Linux
: P1 normal
Assigned To: Russell King
:
Depends on:
Blocks: 10492
  Show dependency treegraph
 
Reported: 2008-05-20 16:23 UTC by Rafael J. Wysocki
Modified: 2008-06-14 16:08 UTC (History)
1 user (show)

See Also:
Kernel Version: Commit b4aa54d951d38d7a989d6b6385494ef5ea7371d7
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-05-20 16:23:21 UTC
Subject    : b4aa54d951d38d7a989d6b6385494ef5ea7371d7 breaks some serial configurations
Submitter  : Russell King <rmk+lkml@arm.linux.org.uk>
Date       : 2008-05-20 7:35
References : http://marc.info/?l=linux-kernel&m=121126931810706&w=2
Handled-By : Javier Herrero <jherrero@hvsistemas.es>
Handled-By : Russell King <rmk+lkml@arm.linux.org.uk>

This entry is being used for tracking a regression from 2.6.25.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-05-20 16:24:16 UTC
Caused by:

commit b4aa54d951d38d7a989d6b6385494ef5ea7371d7
Author: Javier Herrero <jherrero@hvsistemas.es>
Date:   Sat May 17 18:21:42 2008 +0800

    8250 Serial Driver: Added support for 8250-class UARTs in HV Sistemas H8606 board

    Signed-off-by: Javier Herrero <jherrero@hvsistemas.es>
    Acked-by: Alan Cox <alan@lxorguk.ukuu.org.uk>
    Signed-off-by: Bryan Wu <cooloney@kernel.org>
Comment 2 Adrian Bunk 2008-06-14 16:08:11 UTC
fixed by commit a4ed1e41a734d77c9a83a88a8736e19b68e6a2a0

Note You need to log in before you can comment on or make changes to this bug.