Bug 10743 - CD/DVDs burned via sata_via contain corrupted data
Summary: CD/DVDs burned via sata_via contain corrupted data
Status: CLOSED OBSOLETE
Alias: None
Product: IO/Storage
Classification: Unclassified
Component: Serial ATA (show other bugs)
Hardware: All Linux
: P1 high
Assignee: Tejun Heo
URL:
Keywords:
: 11622 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-05-18 04:22 UTC by Utku Ozcan
Modified: 2012-05-21 15:27 UTC (History)
8 users (show)

See Also:
Kernel Version: 2.6.30
Tree: Mainline
Regression: No


Attachments
lspci -vvv (7.70 KB, application/octet-stream)
2008-05-18 04:24 UTC, Utku Ozcan
Details
system log containing exception from hardware (253.98 KB, application/octet-stream)
2008-05-18 04:32 UTC, Utku Ozcan
Details
stdout of dmesg for 2.6.25.4 on 14.06.2008 (20.00 KB, application/octet-stream)
2008-06-14 04:27 UTC, Utku Ozcan
Details
/var/log/messages of kernel 2.6.25.4 on 14.06.2008 (494.77 KB, application/octet-stream)
2008-06-14 04:30 UTC, Utku Ozcan
Details
lspci -nnvvv 17.06.2008 (9.00 KB, application/octet-stream)
2008-06-17 14:49 UTC, Utku Ozcan
Details
lspci -nnvvv 2.6.25.4-1mdv 17.06.2008 (9.02 KB, application/octet-stream)
2008-06-17 14:57 UTC, Utku Ozcan
Details
debug patch (1.21 KB, patch)
2008-06-17 19:23 UTC, Tejun Heo
Details | Diff
My setup and the commands I typed to trigger the error (12.63 KB, text/plain)
2008-07-23 10:02 UTC, Olivier Cailloux
Details
fix-tf_load.patch (2.43 KB, patch)
2008-10-01 02:56 UTC, Tejun Heo
Details | Diff
the sata_via.c from mandriva kernel tree (14.94 KB, application/octet-stream)
2008-10-01 05:39 UTC, Ilya
Details
Log from kernel since the latest boot. (55.81 KB, text/plain)
2008-11-16 05:07 UTC, Flavio Henrique Araque Gurgel
Details
Results from lspci -nn (2.60 KB, text/plain)
2008-11-16 05:08 UTC, Flavio Henrique Araque Gurgel
Details
lspci -vvv (9.94 KB, text/plain)
2008-11-28 22:06 UTC, Atanas Popov
Details
lspci output (12.85 KB, text/plain)
2009-04-22 00:41 UTC, David P Coomber
Details

Description Utku Ozcan 2008-05-18 04:22:23 UTC
Latest working kernel version:
n/a
Earliest failing kernel version:
2.6.24-16-generic (Ubuntu Hardy-Heron 8.04)
2.6.24.4-desktop-1mnb (Mandriva Linux Free 2008 Spring)
Distribution:Ubuntu, Mandriva
Hardware Environment:
- motherboard: Athlon XP 2800+, MSI-6590 KT6 Ultra, VT8237 SATA Controller,  BIOS AMI 5.6 072804 (latest version for SATA)
- hard disks: /dev/hda, /dev/hdd (each 80 GB IDE hard disk)
- storage media: /dev/hdc (Samsung SM-352B IDE CDRW Burner/DVD Reader), /dev/sr0 (LG GH20NS10 SATA DVD Writer)
Software Environment:
- Ubuntu
  kernel: 2.6.24-16-generic (Ubuntu Hardy-Heron 8.04)
  burner software: GNOME 2.22.1, GNOME brasero 0.7.1, genisoimage 1.1.6 
  
- Mandriva
  kernel: 2.6.24.4-desktop-1mnb (Mandriva Linux Free 2008 Spring)
  burner software: KDE 3.5.9, K3B 1.0.4, mkisofs: 1.1.7.1, growisofs: 7.0

Problem Description:
Linux Kernels and utilities stated above cannot burn CD or DVD+R on SATA DVD Writer LG GH20NS10. However Nero on Windows XP burns the same CD, DVD+R on the same DVD Writer without any problem. Exactly the same hardware works on Windows XP.

There is no problem with reading of media. The problem exists only for writing the media. The error is always in following form:

May 17 18:50:20 hostubuntu kernel: [20892.884264]          cdb 2a 00 00 03 0d b0 00 00  10 00 00 00 00 00 00 00
May 17 18:50:20 hostubuntu kernel: [20892.884266]          res 40/00:02:00:0c:00/00:00:00:00:00/a0 Emask 0x4 (timeout)
May 17 18:50:25 hostubuntu kernel: [20897.920162] ata2: port is slow to respond, please be patient (Status 0xc0)
May 17 18:50:29 hostubuntu kernel: [20902.900115] ata2: soft resetting link
May 17 18:50:30 hostubuntu kernel: [20903.391893] ata2.00: configured for UDMA/100
May 17 18:50:30 hostubuntu kernel: [20903.391929] ata2: EH complete

Steps to reproduce:
Insert an empty DVD+R or CD to the SATA DVD Writer LG GH20NS10. Try to burn it with any software and try to burn it any speed you want. You will receive following error in /var/log/syslog:
May 17 18:50:19 hostubuntu kernel: [20892.884246] ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
May 17 18:50:20 hostubuntu kernel: [20892.884263] ata2.00: cmd a0/01:00:00:00:80/00:00:00:00:00/a0 tag 0 dma 32768 out
May 17 18:50:20 hostubuntu kernel: [20892.884264]          cdb 2a 00 00 03 0d b0 00 00  10 00 00 00 00 00 00 00
May 17 18:50:20 hostubuntu kernel: [20892.884266]          res 40/00:02:00:0c:00/00:00:00:00:00/a0 Emask 0x4 (timeout)
May 17 18:50:20 hostubuntu kernel: [20892.884269] ata2.00: status: { DRDY }
May 17 18:50:25 hostubuntu kernel: [20897.920162] ata2: port is slow to respond, please be patient (Status 0xc0)
May 17 18:50:29 hostubuntu kernel: [20902.900115] ata2: soft resetting link
May 17 18:50:30 hostubuntu kernel: [20903.391893] ata2.00: configured for UDMA/100
May 17 18:50:30 hostubuntu kernel: [20903.391929] ata2: EH complete


The problem has been described in following forums:
Ubuntu Forum: http://ubuntuforums.org/showthread.php?t=790880
Mandriva Forum: http://forum.mandriva.com/viewtopic.php?t=86682
KDE bug: http://bugs.kde.org/show_bug.cgi?id=161996
Mandriva Expert: http://expert.mandriva.com/question/103807
Comment 1 Utku Ozcan 2008-05-18 04:24:47 UTC
Created attachment 16181 [details]
lspci -vvv
Comment 2 Utku Ozcan 2008-05-18 04:32:06 UTC
Created attachment 16182 [details]
system log containing exception from hardware

/var/log/syslog. Line 1060 shows the exception coming from the device.
Comment 3 Utku Ozcan 2008-05-18 04:56:16 UTC
There was a discussion lately on LKML for the SATA DVD Writer. It might be useful:
http://lkml.org/lkml/2008/2/25/278
Comment 4 Tejun Heo 2008-05-20 21:56:53 UTC
Can you please give a shot at 2.6.25.4?
Comment 5 Utku Ozcan 2008-05-23 12:40:23 UTC
Due to personal reasons and lack of experience on custom kernels I might response very late (~ 3 weeks of time).
Comment 6 Utku Ozcan 2008-05-31 01:54:47 UTC
I have used 2.6.25.4 kernel package from Mandriva. Version 1.0.4 of K3B, DVD burning software says it burns DVD successfully, however DVD+R media is corrupt. Operating system cannot mount it/read it.

dmesg, /var/log/messages, /var/log/syslog did not return any error. uname -a returns:
Linux localhost 2.6.25.4-1mdv #1 Sat May 24 16:29:47 EDT 2008 i686 AMD Athlon(tm) XP 2800+ GNU/Linux

DVD Media Info returns:

[root@localhost mdutku]# dvd+rw-mediainfo /dev/sr0
INQUIRY:                [HL-DT-ST][DVDRAM GH20NS10 ][EL00]
GET [CURRENT] CONFIGURATION:
 Mounted Media:         1Bh, DVD+R
 Current Write Speed:   16.0x1385=22160KB/s
 Write Speed #0:        16.0x1385=22160KB/s
 Write Speed #1:        16.0x1385=22159KB/s
 Write Speed #2:        12.0x1385=16620KB/s
 Write Speed #3:        12.0x1385=16619KB/s
 Write Speed #4:        8.0x1385=11080KB/s
 Write Speed #5:        8.0x1385=11079KB/s
 Write Speed #6:        4.0x1385=5540KB/s
GET [CURRENT] PERFORMANCE:
 Write Performance:     7.1x1385=9770KB/s@0 -> 16.0x1385=22153KB/s@1961727
                        16.0x1385=22159KB/s@[1961728 -> 2295103]
 Speed Descriptor#0:    02/2295103 R@6.6x1385=9168KB/s W@16.0x1385=22160KB/s
 Speed Descriptor#1:    02/2295103 R@6.6x1385=9168KB/s W@16.0x1385=22159KB/s
 Speed Descriptor#2:    02/2295103 R@6.6x1385=9168KB/s W@12.0x1385=16620KB/s
 Speed Descriptor#3:    02/2295103 R@6.6x1385=9168KB/s W@12.0x1385=16619KB/s
 Speed Descriptor#4:    02/2295103 R@6.6x1385=9168KB/s W@8.0x1385=11080KB/s
 Speed Descriptor#5:    02/2295103 R@6.6x1385=9168KB/s W@8.0x1385=11079KB/s
 Speed Descriptor#6:    02/2295103 R@6.6x1385=9168KB/s W@4.0x1385=5540KB/s
READ DVD STRUCTURE[#0h]:
 Media Book Type:       00h, DVD-ROM book [revision 0]
 Media ID:              INFOME/R30
 Legacy lead-out at:    2295104*2KB=4700372992
READ DISC INFORMATION:
 Disc status:           appendable
 Number of Sessions:    2
 State of Last Session: empty
 "Next" Track:          2
 Number of Tracks:      2
READ TRACK INFORMATION[#1]:
 Track State:           partial/complete
 Track Start Address:   0*2KB
 Free Blocks:           0*2KB
 Track Size:            1937616*2KB
READ TRACK INFORMATION[#2]:
 Track State:           blank
 Track Start Address:   1939664*2KB
 Next Writable Address: 1939664*2KB
 Free Blocks:           355440*2KB
 Track Size:            355440*2KB
FABRICATED TOC:
 Track#1  :             14@0
 Track#AA :             14@1937616
 Multi-session Info:    #1@0
READ CAPACITY:          1937616*2048=3968237568
[root@localhost mdutku]#

Wenn I insert this DVD, dmesg returns me:

cdrom: This disc doesn't have any tracks I recognize!
Comment 7 Utku Ozcan 2008-06-02 10:04:34 UTC
Hi, please let me know if there any log file i can look at. dmesg, syslog do not return me error, expect that one I have written above.

Since there is a behaviour difference between the different kernel versions (the ones I took from the distros and the upstream kernel 2.6.25.4 you asked), I still consider this to be a kernel bug.

Please let me know how to progress.
Comment 8 Tejun Heo 2008-06-08 22:36:48 UTC
Please attach kernel boot log and dmesg output after burning is complete.  So, you don't see any error messages while burning but after burning is complete, the media is corrupt, right?

We have other reports of data corruption when burning on sata_via.  Is it possible for you to try older kernels?  Say, live cd of older distro and see whether things work better there?
Comment 9 Utku Ozcan 2008-06-14 04:23:01 UTC
I have taken the same kernel:
[root@localhost ~]# uname -a
Linux localhost 2.6.25.4-1mdv #1 Sat May 24 16:29:47 EDT 2008 i686 AMD Athlon(tm) XP 2800+ GNU/Linux

I have tried to burn DVD+R with K3B 1.0.4 but this time it aborts with error, which is now different than I reported in my previous message. it ended with exception again. I attach now kernel boot log amd dmesg stdout.

Yes, while burning I did not see any error messages. But media was corrupt. Yes I confirm this. I have seen this 2 times. It is not reproducible, it happens sporadicly. That means, that burning no error but media is corrupt, happens sporadicly.

I have already tried older kernels. 2.6.24-4 and 2.6.24-16 have this problem. 2.6.25.4 you suggested also has this problem. Shall I try much older kernels than these ones? 
Comment 10 Utku Ozcan 2008-06-14 04:27:03 UTC
Created attachment 16472 [details]
stdout of dmesg for 2.6.25.4 on 14.06.2008
Comment 11 Utku Ozcan 2008-06-14 04:30:44 UTC
Created attachment 16473 [details]
/var/log/messages of kernel 2.6.25.4 on 14.06.2008
Comment 12 Tejun Heo 2008-06-16 22:09:41 UTC
Can you please post the result of "lpsci -nnvvv"?
Comment 13 Utku Ozcan 2008-06-17 14:49:12 UTC
Created attachment 16530 [details]
lspci -nnvvv 17.06.2008

From the kernel 2.6.24.5-2mnb of Mandriva:
Linux localhost 2.6.24.5-desktop-2mnb #1 SMP Thu Jun 12 14:37:30 EDT 2008 i686 AMD Athlon(tm) XP 2800+ GNU/Linux
Comment 14 Utku Ozcan 2008-06-17 14:57:11 UTC
Created attachment 16531 [details]
lspci -nnvvv  2.6.25.4-1mdv 17.06.2008

[mdutku@localhost ~]$ uname -a
Linux localhost 2.6.25.4-1mdv #1 Sat May 24 16:29:47 EDT 2008 i686 AMD Athlon(tm                                   ) XP 2800+ GNU/Linux
Comment 15 Tejun Heo 2008-06-17 19:23:49 UTC
Created attachment 16532 [details]
debug patch

Hmm.. yeah, this seems the same with the previous report.  vt6420.  I tested with vt6421 but couldn't reproduce it.  vt6420 and vt6421 only differ in how they're initialized.  Once probe is complete, command execution code paths are identical.  I wonder what's causing the difference.

Does the attached patch make any difference?
Comment 16 Mark Perris 2008-06-19 10:29:02 UTC
I can confirm this exact same error with a cheap HP SATA DVD writer, ID'd as 
HL-DT-ST DVD-RAM GSA-H60L R90A. This style of drive ID string seems to suggest LG-derived internals.

It's plugged into a PCI SiL 3512 SATA Controller, which also has a SATA HDD connected.

00:0a.0 Mass storage controller [0180]: Silicon Image, Inc. SiI 3512 [SATALink/SATARaid] Serial ATA Controller [1095:3512] (rev 01)
	Subsystem: Silicon Image, Inc. SiI 3512 SATALink Controller [1095:3512]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
	Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
	Latency: 32, Cache Line Size: 32 bytes
	Interrupt: pin A routed to IRQ 20
	Region 0: I/O ports at c800 [size=8]
	Region 1: I/O ports at cc00 [size=4]
	Region 2: I/O ports at d000 [size=8]
	Region 3: I/O ports at d400 [size=4]
	Region 4: I/O ports at d800 [size=16]
	Region 5: Memory at eb083000 (32-bit, non-prefetchable) [size=512]
	[virtual] Expansion ROM at 50000000 [disabled] [size=512K]
	Capabilities: [60] Power Management version 2
		Flags: PMEClk- DSI+ D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 PME-Enable- DSel=0 DScale=2 PME-

Kernel: 2.6.24-19-generic
Comment 17 Tejun Heo 2008-06-19 18:07:49 UTC
Mark, are you sure?  You'll be the first one to report data corruption while burning on SIL3512.  Can you please explain you problem in detail?
Comment 18 Mark Perris 2008-06-20 08:47:31 UTC
Sure. I haven't tested with k3b (so can't comment on data corruption) or windows, but using brasero i'm unable to burn a DVD. The burning process always fails at some point (sometimes after a considerable amount of data has been written (sometimes ~3000mb)) with the same error:

BraseroGrowisofs stderr: :-[ WRITE@LBA=13cd00h failed with SK=0h/ASC=00h/ACQ=02h]: Input/output error

and in the system logs:

[ 1200.435341] ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
[ 1200.435357] ata2.00: cmd a0/01:00:00:00:80/00:00:00:00:00/a0 tag 0 dma 32768 out
[ 1200.435359]          cdb 2a 00 00 13 cd 00 00 00  10 00 00 00 00 00 00 00
[ 1200.435361]          res 40/00:02:00:0c:00/00:00:00:00:00/a0 Emask 0x4 (timeout)
[ 1200.435365] ata2.00: status: { DRDY }
[ 1200.747047] ata2: soft resetting link
[ 1200.902930] ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
[ 1201.238942] ata2.00: configured for UDMA/100
[ 1201.238975] ata2: EH complete

The only common factor seems to be LG-based SATA DVD-RW drives. According to cdfreaks, it's a clone of the GSA-H62L.

lspci gives:
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 651 Host (rev 01)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] Virtual PCI-to-PCI bridge (AGP)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS962 [MuTIOL Media IO] (rev 04)
00:02.1 SMBus: Silicon Integrated Systems [SiS] SiS961/2 SMBus Controller
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97 Sound Controller (rev a0)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:0a.0 Mass storage controller: Silicon Image, Inc. SiI 3512 [SATALink/SATARaid] Serial ATA Controller (rev 01)
00:0f.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
00:10.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev 46)
01:00.0 VGA compatible controller: nVidia Corporation NV44A [GeForce 6200] (rev a1)

The SATA card has the non-raid bios, and the source disk for the burn is on the same controller (a SATA HDD)

dmesg | grep ata

[   36.332205] libata version 3.00 loaded.
[   36.854891] sata_sil 0000:00:0a.0: version 2.3
[   36.857265] scsi0 : sata_sil
[   36.858446] scsi1 : sata_sil
[   36.858513] ata1: SATA max UDMA/100 mmio m512@0xeb083000 tf 0xeb083080 irq 20
[   36.858517] ata2: SATA max UDMA/100 mmio m512@0xeb083000 tf 0xeb0830c0 irq 20
[   37.326153] ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
[   37.335494] ata1.00: ATA-6: WDC WD360GD-00FLA2, 31.08F31, max UDMA/133
[   37.335498] ata1.00: 72303840 sectors, multi 16: LBA48 
[   37.351488] ata1.00: configured for UDMA/100
[   37.817703] ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
[   37.981834] ata2.00: ATAPI: HL-DT-ST DVD-RAM GSA-H60L, R90A, max UDMA/100
[   38.153692] ata2.00: configured for UDMA/100
[   38.532872] EXT3-fs: mounted filesystem with ordered data mode.

dmesg | grep scsi 
[   36.857265] scsi0 : sata_sil
[   36.858446] scsi1 : sata_sil
[   38.153849] scsi 0:0:0:0: Direct-Access     ATA      WDC WD360GD-00FL 31.0 PQ: 0 ANSI: 5
[   38.157884] scsi 1:0:0:0: CD-ROM            HL-DT-ST DVD-RAM GSA-H60L R90A PQ: 0 ANSI: 5
[   38.266101] sd 0:0:0:0: Attached scsi generic sg0 type 0
[   38.266129] sr 1:0:0:0: Attached scsi generic sg1 type 5
[   38.278944] sr0: scsi3-mmc drive: 48x/48x writer dvd-ram cd/rw xa/form2 cdda tray
[   38.279024] sr 1:0:0:0: Attached scsi CD-ROM sr0

uname -a
Linux mark-desktop 2.6.24-19-generic #1 SMP Wed Jun 18 14:43:41 UTC 2008 i686 GNU/Linux

I'm happy to try any suggestions.
Comment 19 Tejun Heo 2008-06-20 10:08:04 UTC
Mark, yours is a different problem.  Please file a separate bug report and attach the result of kernel log including boot and error messages and the result of "hdparm -I /dev/sr0".  Thanks.
Comment 20 Mark Perris 2008-06-20 10:26:12 UTC
will do, sorry for the bugspam!
Comment 21 Andy Nikolenko 2008-06-23 08:05:10 UTC
I wanted to add one more "success story" for the same LG- based device.

lspci:
00:00.0 Host bridge: VIA Technologies, Inc. K8T800Pro Host Bridge
00:00.1 Host bridge: VIA Technologies, Inc. K8T800Pro Host Bridge
00:00.2 Host bridge: VIA Technologies, Inc. K8T800Pro Host Bridge
00:00.3 Host bridge: VIA Technologies, Inc. K8T800Pro Host Bridge
00:00.4 Host bridge: VIA Technologies, Inc. K8T800Pro Host Bridge
00:00.7 Host bridge: VIA Technologies, Inc. K8T800Pro Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI bridge [K8T800/K8T890 South]
00:07.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev 80)
00:08.0 RAID bus controller: Promise Technology, Inc. PDC20378 (FastTrak 378/SATA 378) (rev 02)
00:0a.0 Ethernet controller: Marvell Technology Group Ltd. 88E8001 Gigabit Ethernet Controller (rev 13)
00:0c.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 04)
00:0c.1 Input device controller: Creative Labs SB Live! Game Port (rev 01)
00:0d.0 Network controller: RaLink RT2500 802.11g Cardbus/mini-PCI (rev 01)
00:0f.0 RAID bus controller: VIA Technologies, Inc. VIA VT6420 SATA RAID Controller (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge [KT600/K8T800/K8T890 South]
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
00:11.6 Communication controller: VIA Technologies, Inc. AC'97 Modem Controller (rev 80)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: nVidia Corporation GeForce 7600 GT (rev a2)

uname -a:

Linux wkm 2.6.25-ARCH #1 SMP PREEMPT Sat Jun 14 18:07:19 CEST 2008 i686 AMD Athlon(tm) 64 Processor 3000+ AuthenticAMD GNU/Linux

(kernel is Archinux custom 2.6.25.6)

Problem Description:
got this drive today, which identifies itself as:

ata4: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
ata4.00: ATAPI: HL-DT-ST DVDRAM GH20NS10, EL00, max UDMA/100
ata4.00: configured for UDMA/100
ata5: SATA link down 1.5 Gbps (SStatus 0 SControl 300)
scsi 3:0:0:0: CD-ROM            HL-DT-ST DVDRAM GH20NS10  EL00 PQ: 0 ANSI: 5

it is connected currently to the onboard Via sata controller (that uses sata_via driver).
After some playing with it trying to write something (tried to burn several  DVD+RW and DVD-RW discs manufactured by Samsung) - all attempts ended either with "seems" properly burned disks but that cannot be read anywhere or just non-finished burn process. Another attempt to just format fresh DVD+RW with dvd+rw-format tool ended at 9.5% state.
I've got really lot of errors in /var/log/message
Some of them:

Buffer I/O error on device sr0, logical block 3921243
Buffer I/O error on device sr0, logical block 3921244
Buffer I/O error on device sr0, logical block 3921245
Buffer I/O error on device sr0, logical block 3921246
sr 3:0:0:0: [sr0] Result: hostbyte=0x00 driverbyte=0x08
sr 3:0:0:0: [sr0] Sense Key : 0x3 [current]
Info fld=0x3bd55b
sr 3:0:0:0: [sr0] ASC=0x11 ASCQ=0x0
end_request: I/O error, dev sr0, sector 15684972
printk: 4 messages suppressed.
Buffer I/O error on device sr0, logical block 3921243
Buffer I/O error on device sr0, logical block 3921244
cdrom: This disc doesn't have any tracks I recognize!
Buffer I/O error on device sr0, logical block 0
Buffer I/O error on device sr0, logical block 0
ISO 9660 Extensions: Microsoft Joliet Level 3
ISO 9660 Extensions: RRIP_1991A
ata4.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
ata4.00: cmd a0/01:00:00:10:00/00:00:00:00:00/a0 tag 0 dma 16 out
         cdb 55 10 00 00 00 00 00 00  10 00 00 00 00 00 00 00
         res 40/00:02:00:1c:00/00:00:00:00:00/a0 Emask 0x4 (timeout)
ata4.00: status: { DRDY }
ata4: port is slow to respond, please be patient (Status 0xc0)
ata4: soft resetting link
ata4.00: qc timeout (cmd 0xa1)
ata4.00: failed to IDENTIFY (I/O error, err_mask=0x4)
ata4.00: revalidation failed (errno=-5)
ata4: failed to recover some devices, retrying in 5 secs
ata4: port is slow to respond, please be patient (Status 0xc0)
ata4: soft resetting link
ata4.00: qc timeout (cmd 0xa1)
ata4.00: failed to IDENTIFY (I/O error, err_mask=0x4)
ata4.00: revalidation failed (errno=-5)
ata4: failed to recover some devices, retrying in 5 secs
ata4: port is slow to respond, please be patient (Status 0xc0)
ata4: soft resetting link
ata4.00: qc timeout (cmd 0xa1)
ata4.00: failed to IDENTIFY (I/O error, err_mask=0x4)
ata4.00: revalidation failed (errno=-5)
ata4.00: disabled
ata4: port is slow to respond, please be patient (Status 0xc0)
ata4: soft resetting link
ata4: EH complete


after last ones drive no longer respond on almost any command:

hdparm -iI /dev/sr0:

/dev/sr0:
 HDIO_GET_IDENTITY failed: No message of desired type
 HDIO_DRIVE_CMD(identify) failed: Input/output error


P.S. Can anybody tell me if there is a chance to get it working on latest kernels or it's a good idea to replace it with some other drive?

thanks
Comment 22 Tejun Heo 2008-06-23 15:26:36 UTC
I don't think it's the drive's fault.  It's more likely the controller.  Given that 6420 has fairly standard TF / BMDMA interface, I'm running out of ideas tho.  :-(
Comment 23 Utku Ozcan 2008-06-28 05:14:08 UTC
Hi Tejun, due to personal reasons (because of work) I will add your patch about 3 weeks later.

6420 is standard why is it running on Windows then? Interesting... The error is independent from the number of harddisks, filesystem and device configuration. I mean, problems occurs no matter if the burning software/operating system are data to be burned are residing on separate harddisks and on different filesystems or not.

I firstly thought that 6420 was incapable of coping with 3 different devices in the same time. My first experiments were that data to be written was on /dev/hda, operating system+burning software was on /dev/hdc and SATA Driver is on /dev/sr0. In this configuration Linux could not burn the device.

I then thought then reason for this that Linux is unable to cope with interrupts of all these 3 devices on this motherboard and with this processor. During burning process 3 devices are active and controller must cope with 3 interrupt handlers at the same time.

But I have tried other combinations like that data and operating system reside on the same harddisk. There is no change. The behaviour is the same.

I have never heard from any one that GH20NS10 is working on a Linux distro.

Please confirm a setup that this device is working with a SATA controller on a computer... If there is an issue maybe we should inform the vendor..

Funny is that this hardware is running with Windows operating systems.
Comment 24 Utku Ozcan 2008-06-28 05:18:13 UTC
Hi Tejun,

in LKML there was a discussion on this device:
http://lkml.org/lkml/2008/2/25/278

Could you please talk with that developer who was coping with the problems of this device?

Maybe this problem is the same root cause he is analyzing.

If he has found a solution, then maybe it is done.

The description in that thread seems to be almost the same one we are discussing here.

Please correct me if I am wrong.
Comment 25 Tejun Heo 2008-06-28 18:09:56 UTC
Yeah, that was the other report I was talking about (I'm on the thread too) && no solution was found for the problem.  Data corruption pattern indicates somehow part of CDB makes it into the data stream and thus corrupts it.  6420 is somehow not liking the way it's being programmed under Linux but I have no idea what at this point.  Although the interface is standard, there are a lot of things which can be done differently.  Most hardwares are tested only under windows, so it's not uncommon for some of them to be released with quirks which just don't get triggered under windows.  When treated differently, those quirks can get triggered.  Well, either that or libata/sata_via is doing something wrong but given that only certain 6420s are suffering this problem.  I'm leaning more toward the former.

Which board are you using?  Maybe I can get one locally and try to reproduce the problem.
Comment 26 Sven Arvidsson 2008-06-29 10:20:57 UTC
I'm having the same problem with a Samsung SH-S203P SATA writer, on a Abit KV7 motherboard. 

[    5.065593] ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[    5.385192] ata2.00: ATAPI: TSSTcorp CDDVDW SH-S203P, SB00, max UDMA/100
[    5.564757] ata2.00: configured for UDMA/100

lspci:
00:00.0 Host bridge: VIA Technologies, Inc. VT8377 [KT400/KT600 AGP] Host Bridge (rev 80)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI Bridge
00:0f.0 RAID bus controller: VIA Technologies, Inc. VIA VT6420 SATA RAID Controller (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge [KT600/K8T800/K8T890 South]
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 78)
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R200 QM [Radeon 9100]

uname -a:
Linux zoe 2.6.25-2-686 #1 SMP Fri Jun 27 03:23:20 UTC 2008 i686 GNU/Linux

This is the Debian package in sid (2.6.25.7).

I don't get any errors, all writes complete correctly, but the discs are unreadable in any drive and clearly corrupt.




A poster on the Ubuntu forums mentioned that using the driver from viaarena worked, but I'm not sure that's of any help. There isn't any source available for these?
http://ubuntuforums.org/showpost.php?p=5256527&postcount=24
Comment 27 Sven Arvidsson 2008-06-29 14:38:44 UTC
Bug 10137 might be the same problem as this, the workaround for mounting a written disc suggested there works for me: 
   mount -o loop,offset=32 /dev/sr0 /mountpoint
Comment 28 Sven Arvidsson 2008-06-30 07:57:15 UTC
I tried the patch, writing still doesn't work, but somethings changed. I can no longer mount the disc with offset=32, and I get this error:

Jun 30 16:55:30 zoe kernel: [  440.114383] ISO 9660 Extensions: Microsoft Joliet Level 3
Jun 30 16:55:30 zoe kernel: [  440.187669] ISOFS: changing to secondary root
Jun 30 16:55:30 zoe kernel: [  440.253554] isofs_fill_super: root inode is not a directory. Corrupted media?
Comment 29 Utku Ozcan 2008-06-30 16:36:55 UTC
Hi Sven,

well this might be because the absolute/physical offset position has been changed due to patch (struct alloc?). A number other than 32 must work, but no idea which one..

Hi Tejun, here you are:
MSI MS-6590, VT8237 V2.31 (6420 inside), with AMI BIOS A6590 VMS 5.6 (latest BIOS update related to RAID/SATA).

The firmware of this SATA DVD Writer device might be the problem, because the mainboard I am using is pretty old and this device is pretty new for host operating system (which is Linux in this case). There must be something in the writer hardware which is not backwards compatible.

You say 6420 is standard interface, then we have a problem with the hardware itself, for which Linux does not have a solution.

There are 2 firmware versions for this device, EL01 and EL02. I have EL01. I don't think EL02 will work. The firmware resides on the DVD writer hardware and does not have to do with host operating system.

It seems that hardware + firmware for GH20NS10 is tuned for Windows now. Since there are a lot of users for this device on internet, maybe porting of its Windows driver might help, because vendors seems to insist on Windows support only, as it can be seen on their web page.

Another option is, to talk with the vendor directly.

Otherwise, we will burn here a lot of DVD/CD and spend time for nothing for a problem which can be solved by the vendor maybe in 1 working day...

Just a humble thought. These are vast assumptions...
Comment 30 Tejun Heo 2008-06-30 19:53:54 UTC
Sven, last time I checked, the corruption was at the head and repeated regularly throughout the whole data region, so simple offsetting probably won't work.

Utku, in all similar reports, the common factor was vt6420 sata, so I'm more inclined toward controller problem.  The interface is standard but there are always million ways to screw up (the fault can be on the kernel and driver or the hardware).  Hmmm... I can't find the specific board on any online shops here.  :-(  I'll ask via whether they can help us.  Thanks.
Comment 31 Utku Ozcan 2008-07-01 09:16:46 UTC
Hi Tejun,

let me know how to progress. Sven confirmed that your patch does not work, therefore I can do something else.
Comment 32 Sven Arvidsson 2008-07-01 13:45:50 UTC
I tried the proprietary via driver (viamraid.ko) with 2.6.22. It does indeed work, so now I'm also sure my hardware isn't faulty.
http://www.viaarena.com/default.aspx?PageID=420&OSID=45&CatID=3270&SubCatID=143&Old=1
Comment 33 Tejun Heo 2008-07-01 17:07:51 UTC
Yeah, I don't think your particular hardware is broken && I'm aware the via proprietary driver works.  I asked via about this problem yesterday and am waiting for response.  I'll report back when I get an answer.  Thanks.
Comment 34 Olivier Cailloux 2008-07-23 10:02:46 UTC
Created attachment 16953 [details]
My setup and the commands I typed to trigger the error

I also have kernel errors related to DVD-writing with a VIA IDE controller, although I don't have the same symptoms. I thought that the problem might be related, that's why I am posting here, but I am not an expert. If it is not, please excuse me. In that case, it would be nice if someone could tell me if I should file an other bug report for that or where I should ask for help.

The problem is the following: when I use the writing-capabilities (in simulation!), after a while, the (simulated) writing process will terminate and my syslog begins to get filled with plenty of repeated kernel error messages related to my DVD-writer. My DVD-writer, from that time on, is unusable until the next reboot. The only thing I found to stop kernel error logging is to unload the ide_cd_mod module.

Here attached, you will find my setup and what I exactly tried to produce the problem. Please note that the first DVD-writing attempt did NOT trigger the error, thus I guess there is some randomness included. But I got the problem each time I tried to write at speed=1 (I guess, because the time to terminate the process is longer so more chance to trigger the problem).
Comment 35 Utku Ozcan 2008-07-24 15:15:33 UTC
Hi Olivier,

although the device driver for SATA protocol is generic, each device of a specific vendor has different settings. This bug thread is related to LG GH20NS10 DVD Writer, which is not your case.

Therefore, in order that you can get support quicker, I suggest to open another bug entry for your device and not to use this bug.
Comment 36 Sven Arvidsson 2008-07-25 08:56:27 UTC
Probably you already know this, but Harald Welte suggests contacting him for any documentation needs, as part of his new position with VIA: 
http://laforge.gnumonks.org/weblog/2008/07/24/#20080724-via_opensource_liaison
Comment 37 Tejun Heo 2008-07-28 02:39:24 UTC
VIA posted a rather large patch to fix vt8251 support.  It seems vt8251 is quite a different beast from vt8250 and requires a number of changes to get it working properly.  No wonder the current code doesn't work.  It looks like vt8251 support would involve some libata core layer changes meaning it won't be easily backportable to stable kernels.  Dunno whether it will be able to make it into 2.6.27 either as the merge window is closed now.  Anyways, 2.6.28 will definitely have this fixed and after things settle down I'll see whether the support can be backported to -stable branch.  Thanks.
Comment 38 Utku Ozcan 2008-07-30 01:53:01 UTC
Hi Sven,

many thanks for this link. This will be very useful for upcoming kernel updates.

Hi Tejun,

I had tested the DVD writer of LG, GH20NS10 stated in this bug thread with VT8237 with VT6420 core, because my mainboard has VT8237. But you mention VT8250/51. Are these updates backwards compatible to my hardware? Is 8251 100% backwards compatible to 8237? Does 8251 have the same problem?

Many thanks...
Comment 39 Tejun Heo 2008-07-30 16:04:54 UTC
Oh.. the changes also affect 6420 although 5421 sees more changes.  The device requires custom TF register access routine, so this could be the cause of the failure you're seeing.  I'm not yet sure tho.
Comment 40 Bob B. 2008-09-05 20:55:39 UTC
I agree with the comments associating the problem the Via chipset.  Or possibly it's interoperability with some Via chipsets and certain SATA DVD drives.  I tried Sven's suggestion in comment #32.  It fixed two problems on my system: burning CDs/DVDs and playing back encrypted DVDs.  My system is contains: Via KT600-A motherboard, Sempron Processor, DVD drive: SATA LG GSA-H62N.  The problem is that the proprietary Via driver only works with kernel 2.6.22-14.

Thanks Sven
Comment 41 Utku Ozcan 2008-09-07 07:30:02 UTC
Hi Bob, many thanks for this info.

Hi Tejun, when is the timeframe for 2.26.28? RC builds will also take up time. That means maybe in October for official release?

I wish that the fixes for VT8250/VT8251 are also for VT8237/VT6420 because there are still a lot people around who are using the mainboard with these chipsets.

Cheers.
Comment 42 Tejun Heo 2008-09-08 02:10:20 UTC
I'm afraid I don't have much idea when 2.6.28 will be released, but bulk of changes for via controllers got acked, so I'm fairly sure it will show up in 2.6.28.  Thanks.
Comment 43 Ilya 2008-09-30 05:20:52 UTC
(In reply to comment #30)
> Sven, last time I checked, the corruption was at the head and repeated
> regularly throughout the whole data region, so simple offsetting probably
> won't
> work.

Hi. This workaround was suggested by me. I have "diffed" the burned image with the original.
Only 0x20 bytes of head are "extra".

I can repeat the experiment, if you want. Or somebody else can do this.
I have the   Samsung SH-S203P too.
Comment 44 Tejun Heo 2008-10-01 02:56:51 UTC
Created attachment 18126 [details]
fix-tf_load.patch

Does this patch make any difference?
Comment 45 Tejun Heo 2008-10-01 02:57:37 UTC
*** Bug 11622 has been marked as a duplicate of this bug. ***
Comment 46 Ilya 2008-10-01 05:15:00 UTC
(In reply to comment #44)
> Created an attachment (id=18126) [details]
> fix-tf_load.patch
> 
> Does this patch make any difference?
> 

wich version of kernel must be patched? latest - 2.6.26.5?
Comment 47 Ilya 2008-10-01 05:16:38 UTC
(In reply to comment #45)

I have currently 2.6.25-0.rc6.1mdv. But I have always downloaded the latest kernel. 2.6.26.5
Comment 48 Ilya 2008-10-01 05:39:15 UTC
Created attachment 18134 [details]
the sata_via.c from mandriva kernel tree

There is some interesting places in the file. Its look as somebody added some code for the 6420 chipset...
Comment 49 Ilya 2008-10-01 09:43:24 UTC
(In reply to comment #44)
> Created an attachment (id=18126) [details]
> fix-tf_load.patch
> 
> Does this patch make any difference?
> 

Burning was successful (but fixating was with error). But after first try to access the device
it goes blocked. And then stays blocked to any I/O with the message:

end_request: I/O error, dev sr0, sector 0
Buffer I/O error on device sr0, logical block 0

======================

log from wodim:

Performing OPC...
Starting new track at sector: 0
Track 01:  155 of  155 MB written (fifo 100%) [buf 100%]   2.1x.
Track 01: Total bytes read/written: 162600960/162600960 (79395 sectors).
Writing  time:   98.439s
Average write speed   1.2x.
Min drive buffer fill was 100%
Fixating...
Errno: 5 (Input/output error), flush cache scsi sendcmd: no error
CDB:  35 00 00 00 00 00 00 00 00 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 72 0B 00 00 00 00 00 0E 09 0C 00 00 00 02 00 00
Sense Key: 0x0 No Additional Sense, Segment 11
Sense Code: 0x00 Qual 0x02 (end-of-partition/medium detected) Fru 0x0
Sense flags: Blk 0 (not valid)
cmd finished after 135.367s timeout 120s
Trouble flushing the cache
wodim: Cannot fixate disk.
Fixating time:  135.399s
wodim: fifo had 2562 puts and 2562 gets.
wodim: fifo was 0 times empty and 2475 times full, min fill was 81%.
/var/tmp/log3_fixating.txt lines 1-21/21 (END)                      


log from kernel (after fixating):
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: cmd a0/00:00:00:00:00/00:00:00:00:00/a0 tag 0
         cdb 35 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00
         res 40/00:02:00:0c:00/00:00:00:00:00/a0 Emask 0x4 (timeout)
ata2.00: status: { DRDY }
ata2: link is slow to respond, please be patient (ready=0)
ata2: soft resetting link
ata2.00: both IDENTIFYs aborted, assuming NODEV
ata2.00: revalidation failed (errno=-2)
ata2: failed to recover some devices, retrying in 5 secs
ata2: soft resetting link
ata2.00: configured for UDMA/100
ata2: EH complete

And after boot was once the following message:

ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata2.00: cmd a0/01:00:00:fe:00/00:00:00:00:00/a0 tag 0 dma 16640 in
         cdb 12 01 00 00 fe 00 00 00  00 00 00 00 00 00 00 00
         res 40/00:03:00:00:00/00:00:00:00:00/a0 Emask 0x4 (timeout)
ata2.00: status: { DRDY }
ata2: soft resetting link
ata2.00: configured for UDMA/100
ata2: EH complete
Comment 50 Utku Ozcan 2008-10-03 03:20:14 UTC
Even the exception after the boot is very interesting, but I think it is because that a disk was in the device. When you boot and when the hardware cannot read the device, I think this exception is the same as the first one in the log.

Remove the disk and reboot the machine. Can you see the same exception? I doubt you can.
Comment 51 Ilya 2008-10-29 15:44:39 UTC
Yes. I don't see it.

And, I have updated to 2.6.28-rc2......
The problems are the same :(
Comment 52 Flavio Henrique Araque Gurgel 2008-10-31 13:46:58 UTC
I had problems to login here and sent a direct mail to Tejun, sorry.
What I want to add is: Testing here with Kubuntu 64bit, 2.6.27-7
Asus k8v deluxe, vt8237 southbridge, Pioneer DVR-215 recorder, same problems.
PC-BSD installed on the same machine, it works.
Not possible to write CDs, DVDs and read encrypted DVDs.

I'm available to test now, my machine was without linux since the problem arose.
Comment 53 Flavio Henrique Araque Gurgel 2008-11-03 19:02:58 UTC
Have just compiled the latest RC from git. uname -a:
Linux highboots 2.6.28-rc3 #1 SMP Mon Nov 3 22:55:05 BRST 2008 x86_64 GNU/Linux

Same problems.
Tryed to burn a CD-RW in TAO and DAO modes, 4x speed.
Comment 54 Tejun Heo 2008-11-03 21:26:25 UTC
Flavio, are you seeing timeouts or data corruptions?
Comment 55 Flavio Henrique Araque Gurgel 2008-11-04 03:25:25 UTC
(In reply to comment #54)
> Flavio, are you seeing timeouts or data corruptions?
> 

The CDRW is just blank after the process, I cannot check any written data. I'm trying to burn a data CD with a small text file. Is there another way to check for corruption? Always test the media in a PATA drive in the same machine to be sure it's not the problem.

I didn't see timeouts, the output from wodim (from k3b log) returns some errors. I'm at work now, what outputs are good for you? I can send later when at home with the machine.
Comment 56 Flavio Henrique Araque Gurgel 2008-11-04 14:55:56 UTC
I tryied to write via command line. Here is the command, the output and the tail of dmesg from the moment I fired the command.

flavio@highboots:~$ mkisofs -R /home/flavio/Desktop/ | wodim -v dev=1,0,0 -wodim: No write mode specified.                                            
wodim: Asuming -tao mode.                                                  
wodim: Future versions of wodim may have different drive dependent defaults.
TOC Type: 1 = CD-ROM                                                        
wodim: Operation not permitted. Warning: Cannot raise RLIMIT_MEMLOCK limits.I: -input-charset not specified, using utf-8 (detected in locale settings)          
Total translation table size: 0                                                 
Total rockridge attributes bytes: 250                                           
Total directory bytes: 364                                                      
Path table size(bytes): 10                                                      
scsidev: '1,0,0'                                                                
scsibus: 1 target: 0 lun: 0                                                     
WARNING: the deprecated pseudo SCSI syntax found as device specification.       
Support for that may cease in the future versions of wodim. For now,            
the device will be mapped to a block device file where possible.                
Run "wodim --devices" for details.                                              
Linux sg driver version: 3.5.27                                                 
Wodim version: 1.1.8                                                            
SCSI buffer size: 64512                                                         
Device type    : Removable CD-ROM                                               
Version        : 5                                                              
Response Format: 2                                                              
Capabilities   :                                                                
Vendor_info    : 'PIONEER '                                                     
Identification : 'DVD-RW  DVR-215D'                                             
Revision       : '1.18'                                                         
Device seems to be: Generic mmc2 DVD-R/DVD-RW.                                  
Current: 0x000A (CD-RW)                                                         
Profile: 0x002B (DVD+R/DL)                                                      
Profile: 0x001B (DVD+R)                                                         
Profile: 0x001A (DVD+RW)                                                        
Profile: 0x0016 (DVD-R/DL layer jump recording)                                 
Profile: 0x0015 (DVD-R/DL sequential recording)                                 
Profile: 0x0014 (DVD-RW sequential recording)                                   
Profile: 0x0013 (DVD-RW restricted overwrite)                                   
Profile: 0x0011 (DVD-R sequential recording)                                    
Profile: 0x0010 (DVD-ROM)                                                       
Profile: 0x000A (CD-RW) (current)                                               
Profile: 0x0009 (CD-R) (current)                                                
Profile: 0x0008 (CD-ROM)                                                        
Using generic SCSI-3/mmc   CD-R/CD-RW driver (mmc_cdr).                         
Driver flags   : MMC-3 SWABAUDIO BURNFREE                                       
Supported modes: TAO PACKET SAO SAO/R96P SAO/R96R RAW/R16 RAW/R96P RAW/R96R     
Drive buf size : 1267712 = 1238 KB                                              
Beginning DMA speed test. Set CDR_NODMATEST environment variable if device      
communication breaks or freezes immediately after that.                         
FIFO size      : 12582912 = 12288 KB                                            
Track 01: data  unknown length                                                  
Total size:        0 MB (00:00.00) = 0 sectors                                  
Lout start:        0 MB (00:02/00) = 0 sectors                                  
Current Secsize: 2048                                                           
ATIP info from disk:                                                            
  Indicated writing power: 5                                                    
  Reference speed: 2                                                            
  Is not unrestricted                                                           
  Is erasable                                                                   
  ATIP start of lead in:  -11940 (97:22/60)                                     
  ATIP start of lead out: 359849 (79:59/74)                                     
  1T speed low:  0 (reserved val  0) 1T speed high:  4                          
  2T speed low:  0 (reserved val  5) 2T speed high:  0 (reserved val 10)        
  power mult factor: 3 5                                                        
  recommended erase/write power: 2                                              
  A1 values: 02 3A A0                                                           
  A2 values: 5A A6 14                                                           
Disk type:    Phase change                                                      
Manuf. index: 43                                                                
Manufacturer: Acer Media Technology, Inc.                                       
wodim: WARNING: Total disk size unknown. Data may not fit on disk.              
Max brk space used 0                                                            
176 extents written (0 MB)                                                      
Speed set to 705 KB/s
Starting to write CD/DVD at speed   4.0 in real TAO mode for single session.
Last chance to quit, starting real write in    0 seconds. Operation starts.
Waiting for reader process to fill input buffer ... input buffer ready.
Performing OPC...
Starting new track at sector: 0
Track 01:    0 MB written.Errno: 5 (Input/output error), write_g1 scsi sendcmd:no error
CDB:  2A 00 00 00 00 00 00 00 1F 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 05 06 00 00 20 0E 24 08 10 40 A8 04 00 00
Sense Key: 0x5 Illegal Request, Segment 0
Sense Code: 0xA8 Qual 0x04 (vendor unique sense code 0xA8) [No matching qualifier] Fru 0x0
Sense flags: Blk 100663328 (not valid)
cmd finished after 0.017s timeout 40s

write track data: error after 0 bytes
wodim: A write error occured.
wodim: Please properly read the error message above.
Writing  time:   13.992s
Fixating...
Errno: 5 (Input/output error), close track/session scsi sendcmd: no error
CDB:  5B 00 02 00 00 00 00 00 00 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 25 00 00 00 00 0E 00 00 00 00 64 00 00 00
Sense Key: 0x5 Illegal Request, Segment 0
Sense Code: 0x64 Qual 0x00 (illegal mode for this track) Fru 0x0
Sense flags: Blk 0 (not valid) illegal block length
cmd finished after 0.015s timeout 480s
cmd finished after 0.015s timeout 480s
wodim: Cannot fixate disk.
Fixating time:    0.024s
wodim: fifo had 7 puts and 1 gets.
wodim: fifo was 0 times empty and 0 times full, min fill was 100%.




dmesg:
[  502.145751] cdrom: This disc doesn't have any tracks I recognize!
[  502.269630] sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
[  502.269645] sr 1:0:0:0: [sr0] Sense Key : Blank Check [current]
[  502.269649] sr 1:0:0:0: [sr0] Add. Sense: No additional sense information
[  502.269654] end_request: I/O error, dev sr0, sector 0
[  502.269661] Buffer I/O error on device sr0, logical block 0
[  502.279846] sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
[  502.279856] sr 1:0:0:0: [sr0] Sense Key : Blank Check [current]
[  502.279860] sr 1:0:0:0: [sr0] Add. Sense: No additional sense information
[  502.279865] end_request: I/O error, dev sr0, sector 0
[  502.279871] Buffer I/O error on device sr0, logical block 0
Comment 57 Tejun Heo 2008-11-10 00:49:14 UTC
Flavio, please post the result of "lspci -nn" and kernel boot log.
Comment 58 Flavio Henrique Araque Gurgel 2008-11-16 05:07:41 UTC
Created attachment 18878 [details]
Log from kernel since the latest boot.
Comment 59 Flavio Henrique Araque Gurgel 2008-11-16 05:08:19 UTC
Created attachment 18879 [details]
Results from lspci -nn
Comment 60 Flavio Henrique Araque Gurgel 2008-11-16 05:10:18 UTC
Attachments #58 and #59 where created from latest rc. uname -a:
Linux highboots 2.6.28-rc4-flavio #1 SMP Sat Nov 15 17:37:09 BRST 2008 i686 GNU/Linux

The results are the same.
Comment 61 Tejun Heo 2008-11-16 18:33:56 UTC
Flavio, I'm not sure what you're seeing is the same problem reported here.  The failure mode is quite different.  It could have been caused by the same problem but the drive seems to have some peculiarities.

  http://club.cdfreaks.com/f7/pioneer-dvr-215d-failing-burn-243187/

 19:04:29 #21 SPTI -1064 File SCSIPassThrough.cpp, Line 179
 CdRom0: SCSIStatus(x02) WinError(0) NeroError(-1064)
 Sense Key: 0x05 (KEY_ILLEGAL_REQUEST)
 Sense Code: 0x21
 Sense Qual: 0x02
 CDB Data: 0x2A 00 00 00 00 20 00 00 20 00 00 00
 Sense Area: 0x70 00 05 00 00 00 00 0E 00 00 00 00 21 02

Hmmm.. but it seems your firmware is already the newer one.  Can you please connect the drive to a different SATA controller and see whether it works there?

Thanks.
Comment 62 Tejun Heo 2008-11-16 19:03:15 UTC
There was an earlier report of the same problem with more analysis.

  http://thread.gmane.org/gmane.linux.kernel/645736
Comment 63 Ilya 2008-11-17 11:17:25 UTC
(In reply to comment #62)
> There was an earlier report of the same problem with more analysis.
> 
>   http://thread.gmane.org/gmane.linux.kernel/645736
> 

Tejun, must the 2.6.28-rc* kernel work with the drive flawless? Must I test it?
Comment 64 Tejun Heo 2008-11-17 16:45:36 UTC
Ilya, it has some related changes but probably doesn't fix the problem.  Can you still give it a shot just to be sure?  Thanks.
Comment 65 Atanas Popov 2008-11-28 22:06:15 UTC
Created attachment 19072 [details]
lspci -vvv

Same problem, writing disks CDs, DVDs and reading encrypted disks work only with drivers from viaarena. SATA DVD: Samsung SH-S203D, MB: GA-7VT600P-RZ. vt8237 chipset
Comment 66 David P Coomber 2009-04-22 00:41:41 UTC
Created attachment 21075 [details]
lspci output

I recently changed motherboards and my SATA DVD-Writer (LiteOn and LG) both stopped working (or, at least, appeared to work but the end-product will not mount).

After a process of logic similar to that followed in this bug report, I found that it is the VIA chipset on my mobo - VIA did not implement ATAPI, but rather a proprietary interface.

I found drivers and sourcecode patches on VIA's website and can confirm that these work in Ubuntu 7.10 (Hardy Heron).  Unfortunately, the sourcecode patch files are only available for 7.04 (Gutsy Gibbon).

I attempted patching the 8.10 scsi_via.c and ahci.c files manually, but the changes to libata are far too significant for a kernel noob like me and although I was able to hack out compiled kernel modules, these would not load.

I applied your fix-tf_load.patch (2008-10-01 02:56) to the 2.6.27-11 version of scsi.c and the modules compiled without any warnings or errors.  These custom modules load and my DVD-writers are picked up by the operating system, but the original problem has not been resolved.

I have emailed the VIA open source liaison regarding releasing updated drivers for my chipset (see attached lspci.txt), but have not yet received a response.  It is a pity that VIA are not considering releasing their drivers under a license allowing for their default inclusion in the kernel.
Comment 67 David P Coomber 2009-04-22 00:53:23 UTC
Apologies for the spam...

Further to my previous comment (#66), the Ubuntu 7.04 VIA drivers installs ahci.ko and scsi.ko, whereas the Ubuntu 7.10 VIA drivers install viamraid.ko.
Comment 68 R Deepak 2009-05-08 00:42:19 UTC
I can verify that this problem still exists with 2.6.29
Comment 69 Pablo Fabian Wagner Boian 2009-10-26 19:05:29 UTC
Same problem with a Biostar P4VMA-M motherboard with VIA vt8237 southbridge. I've two drives, a LITE-ON COMBO SOHC-5236K CD-RW/DVD with RK01 firmware revision; and a LG HL-DT-ST DVDRAM GH22NS50 with TN01 firm revision (no bluebird). The Lite-On is plugged to an IDE connector while the LG to a sata one.

The Lite-On burn CDs sucssesfully, but de LG can't (neither DVDs). I've no problems reading CDs or DVDs in both drives.

I am using Ubuntu 9.04 with 2.6.28-16-generic linux kernel. Also, I've tried Nero Linux but same problem: DVD burn seems to be ok, but when re-inserting media It can not be mounted (data corruption as I see).

Under Windows XP, LG drive works fine. I've tried an IDE-SATA bridge with a hardware converter (no drivers requiered) and I could burn some DVD but re-mounting drive couldn't be done. Reading process gave me a lot of I/O errors (I can't say if is the IDE-SATA bridge or the drive). Only restarting the system turns the drive opperative on again.
Comment 70 Yuri Bushmelev 2009-12-27 19:20:17 UTC
Same problem on m/b Abit K8V MAX3 with SATA Optiarc AD-7240S.

How to repeat:

$ dd if=/dev/zero of=/dev/sr0 bs=1024k count=10
$ dd if=/dev/sr0 of=image.bin bs=1024k count=10
$ cmp -l /dev/zero image.bin
       1   0  52                         
       9   0 100                         
  131073   0  52                         
  131078   0 100                         
  131081   0 100                         
  131086   0 100                         
  262145   0  52                         
  262150   0 200                         
  262153   0 100                         
  262158   0 200                         
  393217   0  52                         
  393222   0 300                         
  393225   0 100                         
  393230   0 300                         
  524289   0  52                         
  524293   0   1                         
  524297   0 100                         
  524301   0   1                         
  [...]

Details about hardware/software:

ALT Linux Sisyphus. Last updated 2009-12-26.

Linux is.home 2.6.30-std-def-alt15 #1 SMP Mon Dec 14 08:45:48 UTC 2009 i686 GNU/Linux

00:0f.0 RAID bus controller: VIA Technologies, Inc. VIA VT6420 SATA RAID Controller (rev 80)
        Subsystem: ABIT Computer Corp. Device 1406
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 32
        Interrupt: pin B routed to IRQ 20
        Region 0: I/O ports at 9400 [size=8]
        Region 1: I/O ports at 9800 [size=4]
        Region 2: I/O ports at 9c00 [size=8]
        Region 3: I/O ports at a000 [size=4]
        Region 4: I/O ports at a400 [size=16]
        Region 5: I/O ports at a800 [size=256]
        Capabilities: <access denied>
        Kernel driver in use: sata_via

INQUIRY:                [Optiarc ][DVD RW AD-7240S ][1.02]
GET [CURRENT] CONFIGURATION:
 Mounted Media:         1Ah, DVD+RW
 Media ID:              MKM/A02
 Current Write Speed:   4.0x1385=5540KB/s
 Write Speed #0:        4.0x1385=5540KB/s
GET [CURRENT] PERFORMANCE:
 Write Performance:     4.0x1385=5540KB/s@[0 -> 2295103]
 Speed Descriptor#0:    00/2295104 R@5.0x1385=6925KB/s W@4.0x1385=5540KB/s
READ DVD STRUCTURE[#0h]:
 Media Book Type:       00h, DVD-ROM book [revision 0]
 Legacy lead-out at:    2295104*2KB=4700372992
READ DISC INFORMATION:
 Disc status:           complete
 Number of Sessions:    1
 State of Last Session: complete
 Number of Tracks:      1
 BG Format Status:      suspended
READ FORMAT CAPACITIES:
 formatted:             2295104*2048=4700372992
 26h(0):                2295104*2048=4700372992
READ TRACK INFORMATION[#1]:
 Track State:           complete
 Track Start Address:   0*2KB
 Free Blocks:           0*2KB
 Track Size:            2295104*2KB
FABRICATED TOC:
 Track#1  :             14@0
 Track#AA :             14@2295104
 Multi-session Info:    #1@0
READ CAPACITY:          2295104*2048=4700372992
Comment 71 Tejun Heo 2009-12-28 09:59:51 UTC
I still don't have much idea about this problem but there are reports that the problem doesn't exist with recent versions of some burning applications.  Maybe it has something to do with max transfer size.  It would be interesting to find out which one triggers the problem and which doesn't.

Thanks.
Comment 72 Yuri Bushmelev 2009-12-28 10:17:05 UTC
JFYI I'm using dvd+rw-tools-7.1-alt1. Now I've just switched to onboard Silicon Image controller.
Comment 73 Tejun Heo 2010-01-20 03:27:40 UTC
There's a proposed fix.  If you still have the affected system, please give a shot at the following patch.

  http://article.gmane.org/gmane.linux.kernel/939112/raw

Thanks.
Comment 74 Pablo Fabian Wagner Boian 2010-03-26 09:02:06 UTC
 The problem remains in 2.6.31-20-generic ubuntu 9.10 linux kernel. Hopping a solution on next release (Ubuntu 10.04). I also have tried a BSD flavour, PC-BSD to be exactly, and I was able to record DVD and CD in a normal way using K3B. 
 Why there is no fix to this problem? I am talking a official fix from the sata_via development team. It's a big issue that concerns to all who posses a motherboard with VIA chipsets (many 6 years age machines up to now, a lot of people still have them, including me).
 I had tried to contact VIA trough email asking if there was a binary driver provided by them, or something like that; but they didn't respond. There were several official drivers releases until ubuntu 8.04 from VIA web page, but no more.
 Sorry my bad english. I think I will try luck with the kernel patch. Thanks about that!!
Comment 75 Tejun Heo 2010-03-26 09:12:12 UTC
Can you please test patch attached in comment#73?  The patch is merged into 2.6.34 but I don't want to backport it without verification.

Note You need to log in before you can comment on or make changes to this bug.