Bug 10722 - Suspend not working
Suspend not working
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 high
Assigned To: Jeffrin Jose
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2008-05-16 08:43 UTC by Vitor Antunes
Modified: 2008-10-22 03:47 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.25
Tree: Mainline
Regression: ---


Attachments

Description Vitor Antunes 2008-05-16 08:43:50 UTC
Latest working kernel version: unknown
Earliest failing kernel version: 2.6.22
Distribution: Debian Sid
Hardware Environment: Packard Bell BV EasyNote_BU45
Software Environment: @ initramfs level
Problem Description:

Suspend is not working, even at initramfs level.
Tested most of the possible combinations of s2ram options (see below).
Also ran all pm_test test modes with success (after a full init).

uname -s -r -v -m -p -i -o:

Linux 2.6.25-1-amd64 #1 SMP Fri Apr 25 14:38:55 UTC 2008 x86_64 unknown unknown GNU/Linux

Details about hardware:

# cat /proc/cpuinfo 
processor	: 0
vendor_id	: GenuineIntel
cpu family	: 6
model		: 15
model name	: Intel(R) Core(TM)2 CPU         T5300  @ 1.73GHz
stepping	: 2
cpu MHz		: 798.000
cache size	: 2048 KB
physical id	: 0
siblings	: 2
core id		: 0
cpu cores	: 2
fpu		: yes
fpu_exception	: yes
cpuid level	: 10
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good pni monitor ds_cpl est tm2 ssse3 cx16 xtpr lahf_lm
bogomips	: 3462.13
clflush size	: 64
cache_alignment	: 64
address sizes	: 36 bits physical, 48 bits virtual
power management:

processor	: 1
vendor_id	: GenuineIntel
cpu family	: 6
model		: 15
model name	: Intel(R) Core(TM)2 CPU         T5300  @ 1.73GHz
stepping	: 2
cpu MHz		: 798.000
cache size	: 2048 KB
physical id	: 0
siblings	: 2
core id		: 1
cpu cores	: 2
fpu		: yes
fpu_exception	: yes
cpuid level	: 10
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good pni monitor ds_cpl est tm2 ssse3 cx16 xtpr lahf_lm
bogomips	: 3485.30
clflush size	: 64
cache_alignment	: 64
address sizes	: 36 bits physical, 48 bits virtual
power management:

# s2ram
Machine is unknown.
This machine can be identified by:
   sys_vendor   = "Packard Bell BV              "
   sys_product  = "EasyNote_BU45"
   sys_version  = "PB72E06210"
   bios_version = "206    "

# lspci
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS/940GML and 945GT Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) Serial ATA Storage Controller IDE (rev 02)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02)
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E PCI Express Fast Ethernet controller (rev 01)
02:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)

# biosdecode
# biosdecode 2.9
BIOS32 Service Directory present.
       Revision: 0
       Calling Interface Address: 0x000F0010
PCI Interrupt Routing 1.0 present.
       Router ID: 00:1f.0
       Exclusive IRQs: None
       Compatible Router: 8086:27b9
       Slot Entry 1: ID 02:00, slot number 16
       Slot Entry 2: ID 00:1f, on-board
       Slot Entry 3: ID 00:1d, on-board
       Slot Entry 4: ID 04:00, slot number 7
       Slot Entry 5: ID 00:02, on-board
       Slot Entry 6: ID 00:1b, on-board
       Slot Entry 7: ID 03:01, on-board
       Slot Entry 8: ID 00:01, on-board
       Slot Entry 9: ID 00:1c, on-board
       Slot Entry 10: ID 01:00, on-board
PNP BIOS 1.0 present.
       Event Notification: Not Supported
       Real Mode 16-bit Code Address: F000:6552
       Real Mode 16-bit Data Address: F000:0000
       16-bit Protected Mode Code Address: 0x000F657A
       16-bit Protected Mode Data Address: 0x000F0000
ACPI 1.0 present.
       OEM Identifier: ACPIAM
       RSD Table 32-bit Address: 0x3F7B0000
SMBIOS 2.4 present.
       Structure Table Length: 1716 bytes
       Structure Table Address: 0x000FCD20
       Number Of Structures: 38
       Maximum Structure Size: 181 bytes

Steps to reproduce:

Break init during the initramfs phase and run any of the following commands:

s2ram -f -a 3
s2ram -f -a 2
s2ram -f -a 1
s2ram -f -p -m
s2ram -f -p -s
s2ram -f -m
s2ram -f -s
s2ram -f -p
s2ram -f -a 1 -m
s2ram -f -a 1 -s 
s2ram -f -v -a 3
s2ram -f -v -a 2
s2ram -f -v -a 1
s2ram -f -v -p -m
s2ram -f -v -p -s
s2ram -f -v -m
s2ram -f -v -s
s2ram -f -v -p
s2ram -f -v -a 1 -m
s2ram -f -v -a 1 -s
Comment 1 Jeffrin Jose 2008-08-20 05:59:43 UTC
iam currently using 2.6.27-rc3-git6.
suspend seems to be working in my kernel version.

Linux jeffrin-laptop 2.6.27-rc3-git6 #5 SMP PREEMPT Wed Aug 20 16:32:41 IST 2008 i686 GNU/Linux
Comment 2 Rafael J. Wysocki 2008-08-20 06:12:51 UTC
OK, so do you think the bug can be closed?
Comment 3 Jeffrin Jose 2008-08-20 06:24:54 UTC
not yet . i did not break init during the initramfs phase.
just wait i have to check that ..
Comment 4 Jeffrin Jose 2008-08-20 06:35:51 UTC
(In reply to comment #2)
> OK, so do you think the bug can be closed?
> 

i have slight confusion regarding breaking init during initramfs.
but otherwise the bug can be closed.
Comment 5 Vitor Antunes 2008-10-22 03:47:21 UTC
Just installed 2.6.27.2 and tried the following:

s2ram -f
s2ram -f -a 3
s2ram -f -a 1

None of these worked. What options for s2ram did you use? Are you sure you are testing in an equal machine?
I think I was not clear enough on the first report. I only broke during the initramfs phase to guarantee that there wasn't much things "going on" (and to make the boot time smaller). This is not a requirement for this bug.

Thanks guys (and sorry for such a late reply)

Note You need to log in before you can comment on or make changes to this bug.