Bug 1072 - Laptop touchpad does not work; synaptics driver missing
Summary: Laptop touchpad does not work; synaptics driver missing
Status: CLOSED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Input Devices (show other bugs)
Hardware: i386 Linux
: P2 high
Assignee: Vojtech Pavlik
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-08-10 10:30 UTC by D Bandopadhyay
Modified: 2004-02-01 02:25 UTC (History)
0 users

See Also:
Kernel Version: 2.6.0-test3
Tree: Mainline
Regression: ---


Attachments
dmesg.log (9.00 KB, text/plain)
2003-08-10 10:31 UTC, D Bandopadhyay
Details
/usr/src/linux-2.6.0-test3-bk1/.config (22.84 KB, text/plain)
2003-08-12 14:41 UTC, D Bandopadhyay
Details
lspci-v.txt (5.17 KB, text/plain)
2003-08-16 12:37 UTC, D Bandopadhyay
Details

Description D Bandopadhyay 2003-08-10 10:30:11 UTC
Distribution: Gentoo GNU/Linux
Hardware Environment: Dell Inspiron 8100
Software Environment: XFree 4.3.0
Problem Description: Laptop touchpad does not work; synaptics driver missing

Steps to reproduce: Configure kernel, compile and boot off kernel.  Touch pad
won't work.

Description:

If you configure the kernel by including all options necessary for your laptop
and boot off it the touchpad on your laptop will not work.  I had to do
additionally the following in order to get it to work.

(1) visit and read http://w1.894.telia.com/~u89404340/touchpad/
(2) wget http://w1.894.telia.com/~u89404340/touchpad/synaptics-0.11.3p11.tar.bz2
-P ~
(3) tar -xvjf ~/synaptics-0.11.3p11.tar.bz2
(4) cp synaptics/synaptics_drv.o /usr/X11R6/lib/modules/input/
(5) modify /etc/X11/XF86Config-4 to replace existing InputDevice section with
text below.

Section "InputDevice"
    Identifier  "Mouse0"
    Driver      "synaptics"
    Option      "Device"       "/dev/input/event0"
    Option      "Protocol"     "event"
    Option      "LeftEdge"     "1900"
    Option      "RightEdge"    "5400"
    Option      "BottomEdge"   "1800"
    Option      "TopEdge"      "3900"
    Option      "FingerLow"    "25"
    Option      "FingerHigh"   "30"
    Option      "MaxTapTime"   "180"
    Option      "MaxTapMove"   "220"
    Option      "VertScrollDelta" "100"
    Option      "MinSpeed"     "0.02"
    Option      "MaxSpeed"     "0.18"
    Option      "AccelFactor"  "0.0010"
#Option   "Emulate3Buttons"   "on"
#Option   "Repeater"          "/dev/ps2mouse"
#Option   "SHMConfig"         "on"
EndSection

(6) restart xfree server

Instead of this six step procedure can this be made into a one step procedure of
simply enabling an option in the kernel?  There are literally hundreds of users
who are experiencing this same problem in the Gentoo Linux community and as a
result one of them took the initiative to write a small how-to [1] summarised
above by myself.

[1] http://forums.gentoo.org/viewtopic.php?t=67852

I'd be very grateful if this could be incorporated into the kernel and automated
for ease and convenience.  If you require any further information or wish to
discuss this further please let me know.  Also, below are certain error messages
about synaptics found in dmesg.

$ dmesg | grep synaptics
synaptics reset failed
synaptics reset failed
synaptics reset failed

I will also attach the entire output of dmesg for reference.  Many thanks.
Comment 1 D Bandopadhyay 2003-08-10 10:31:22 UTC
Created attachment 634 [details]
dmesg.log
Comment 2 D Bandopadhyay 2003-08-12 14:41:02 UTC
Created attachment 642 [details]
/usr/src/linux-2.6.0-test3-bk1/.config
Comment 3 D Bandopadhyay 2003-08-16 12:37:08 UTC
Created attachment 660 [details]
lspci-v.txt
Comment 4 D Bandopadhyay 2003-09-28 04:08:56 UTC
This bug is now fixed since the synaptics touchpad driver is present in the
latest kernel (test6).
Comment 5 D Bandopadhyay 2003-10-20 07:48:41 UTC
Any progress on this one?  As far as I can tell the synaptics driver is now in
the kernel and does indeed work.  So this can be closed.
Comment 6 Vojtech Pavlik 2004-02-01 02:25:27 UTC
Well, the part of the synaptics driver which can be in the kernel is
in the kernel now, plus another bit that makes X work even when the X
synaptics driver is not present.

But you should still get the new X synaptics driver to get the full
functionality out of your touchpad.

I hope some new X release will include the driver, simplifying installation.

Note You need to log in before you can comment on or make changes to this bug.